WpimSystem Namespace

[image]

伟鹏即时通讯Web Service说明文档

类

类 | 说明
WpimSystemFacade | 提供伟鹏各子管理类接口

接口

接口 | 说明
IWpimSystemProvider |

伟鹏即时通讯


IWpimSystemProvider Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IWpimSystemProvider
Visual Basic (Declaration)
Public Interface IWpimSystemProvider
Visual C++
public interface class IWpimSystemProvider

参见

IWpimSystemProvider 成员
WpimSystem 命名空间


IWpimSystemProvider Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 方法 参见

IWpimSystemProvider 类型暴露了以下成员.

方法

名称 | 说明
GetIDBAdManager |
GetIDBCommunityManager |
GetIDBCommunityMemberManager |
GetIDBCommunityMsgRecordManager |
GetIDBCompanyGatheringManager |
GetIDBCompanyManager |
GetIDBDepartmentManager |
GetIDBEmployeeManager |
GetIDBLoginRecordManager |
GetIDBNewsManager |
GetIDBOnlineBroadManager |
GetIDBOtherManager |
GetIDBPanelManager |
GetIDBUserBriefManager |
GetIDBUserDetailManager |
GetIDBUserFileManager |

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


IWpimSystemProvider Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

IWpimSystemProvider 类型暴露了以下方法.

方法

名称 | 说明
GetIDBAdManager |
GetIDBCommunityManager |
GetIDBCommunityMemberManager |
GetIDBCommunityMsgRecordManager |
GetIDBCompanyGatheringManager |
GetIDBCompanyManager |
GetIDBDepartmentManager |
GetIDBEmployeeManager |
GetIDBLoginRecordManager |
GetIDBNewsManager |
GetIDBOnlineBroadManager |
GetIDBOtherManager |
GetIDBPanelManager |
GetIDBUserBriefManager |
GetIDBUserDetailManager |
GetIDBUserFileManager |

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBAdManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBAdManager GetIDBAdManager()
Visual Basic (Declaration)
Function GetIDBAdManager As IDBAdManager
Visual C++
IDBAdManager^ GetIDBAdManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBCommunityManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBCommunityManager GetIDBCommunityManager()
Visual Basic (Declaration)
Function GetIDBCommunityManager As IDBCommunityManager
Visual C++
IDBCommunityManager^ GetIDBCommunityManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBCommunityMemberManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBCommunityMemberManager GetIDBCommunityMemberManager()
Visual Basic (Declaration)
Function GetIDBCommunityMemberManager As IDBCommunityMemberManager
Visual C++
IDBCommunityMemberManager^ GetIDBCommunityMemberManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBCommunityMsgRecordManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBCommunityMsgRecordManager GetIDBCommunityMsgRecordManager()
Visual Basic (Declaration)
Function GetIDBCommunityMsgRecordManager As IDBCommunityMsgRecordManager
Visual C++
IDBCommunityMsgRecordManager^ GetIDBCommunityMsgRecordManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBCompanyGatheringManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBCompanyGatheringManager GetIDBCompanyGatheringManager()
Visual Basic (Declaration)
Function GetIDBCompanyGatheringManager As IDBCompanyGatheringManager
Visual C++
IDBCompanyGatheringManager^ GetIDBCompanyGatheringManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBCompanyManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBCompanyManager GetIDBCompanyManager()
Visual Basic (Declaration)
Function GetIDBCompanyManager As IDBCompanyManager
Visual C++
IDBCompanyManager^ GetIDBCompanyManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBDepartmentManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBDepartmentManager GetIDBDepartmentManager()
Visual Basic (Declaration)
Function GetIDBDepartmentManager As IDBDepartmentManager
Visual C++
IDBDepartmentManager^ GetIDBDepartmentManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBEmployeeManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBEmployeeManager GetIDBEmployeeManager()
Visual Basic (Declaration)
Function GetIDBEmployeeManager As IDBEmployeeManager
Visual C++
IDBEmployeeManager^ GetIDBEmployeeManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBLoginRecordManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBLoginRecordManager GetIDBLoginRecordManager()
Visual Basic (Declaration)
Function GetIDBLoginRecordManager As IDBLoginRecordManager
Visual C++
IDBLoginRecordManager^ GetIDBLoginRecordManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBNewsManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBMiniNewsManager GetIDBNewsManager()
Visual Basic (Declaration)
Function GetIDBNewsManager As IDBMiniNewsManager
Visual C++
IDBMiniNewsManager^ GetIDBNewsManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBOnlineBroadManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBOnlineBroadManager GetIDBOnlineBroadManager()
Visual Basic (Declaration)
Function GetIDBOnlineBroadManager As IDBOnlineBroadManager
Visual C++
IDBOnlineBroadManager^ GetIDBOnlineBroadManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBOtherManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBTblAdvManager GetIDBOtherManager()
Visual Basic (Declaration)
Function GetIDBOtherManager As IDBTblAdvManager
Visual C++
IDBTblAdvManager^ GetIDBOtherManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBPanelManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBPanelManager GetIDBPanelManager()
Visual Basic (Declaration)
Function GetIDBPanelManager As IDBPanelManager
Visual C++
IDBPanelManager^ GetIDBPanelManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBUserBriefManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBUserBriefManager GetIDBUserBriefManager()
Visual Basic (Declaration)
Function GetIDBUserBriefManager As IDBUserBriefManager
Visual C++
IDBUserBriefManager^ GetIDBUserBriefManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBUserDetailManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBUserDetailManager GetIDBUserDetailManager()
Visual Basic (Declaration)
Function GetIDBUserDetailManager As IDBUserDetailManager
Visual C++
IDBUserDetailManager^ GetIDBUserDetailManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


GetIDBUserFileManager Method

[image]

伟鹏即时通讯Web Service说明文档
IWpimSystemProvider 接口 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IDBUserFileManager GetIDBUserFileManager()
Visual Basic (Declaration)
Function GetIDBUserFileManager As IDBUserFileManager
Visual C++
IDBUserFileManager^ GetIDBUserFileManager()

参见

IWpimSystemProvider 接口
WpimSystem 命名空间


WpimSystemFacade Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
提供伟鹏各子管理类接口

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class WpimSystemFacade
Visual Basic (Declaration)
Public Class WpimSystemFacade
Visual C++
public ref class WpimSystemFacade

继承层次结构

System..::.Object
WpimSystem..::.WpimSystemFacade

参见

WpimSystemFacade 成员
WpimSystem 命名空间


WpimSystemFacade Members

[image] [image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 构造函数 方法 参见

WpimSystemFacade 类型暴露了以下成员.

构造函数

名称 | 说明
WpimSystemFacade | Initializes a new instance of the WpimSystemFacade class

方法

名称 | 说明
GetFacade |
GetIDBAdManager |
GetIDBCommunityManager |
GetIDBCommunityMemberManager |
GetIDBCommunityMsgRecordManager |
GetIDBCompanyGatheringManager |
GetIDBCompanyManager |
GetIDBDepartmentManager |
GetIDBEmployeeManager |
GetIDBLoginRecordManager |
GetIDBNewsManager |
GetIDBOnlineBroadManager |
GetIDBOtherManager |
GetIDBPanelManager |
GetIDBUserBriefManager |
GetIDBUserDetailManager |
GetIDBUserFileManager |

参见

WpimSystemFacade 类
WpimSystem 命名空间


WpimSystemFacade Constructor

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见
Initializes a new instance of the WpimSystemFacade class

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public WpimSystemFacade()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WpimSystemFacade()

参见

WpimSystemFacade 类
WpimSystem 命名空间


WpimSystemFacade Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

WpimSystemFacade 类型暴露了以下方法.

方法

名称 | 说明
GetFacade |
GetIDBAdManager |
GetIDBCommunityManager |
GetIDBCommunityMemberManager |
GetIDBCommunityMsgRecordManager |
GetIDBCompanyGatheringManager |
GetIDBCompanyManager |
GetIDBDepartmentManager |
GetIDBEmployeeManager |
GetIDBLoginRecordManager |
GetIDBNewsManager |
GetIDBOnlineBroadManager |
GetIDBOtherManager |
GetIDBPanelManager |
GetIDBUserBriefManager |
GetIDBUserDetailManager |
GetIDBUserFileManager |

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetFacade Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public static WpimSystemFacade GetFacade()
Visual Basic (Declaration)
Public Shared Function GetFacade As WpimSystemFacade
Visual C++
public:
static WpimSystemFacade^ GetFacade()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBAdManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBAdManager GetIDBAdManager()
Visual Basic (Declaration)
Public Function GetIDBAdManager As IDBAdManager
Visual C++
public:
IDBAdManager^ GetIDBAdManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBCommunityManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBCommunityManager GetIDBCommunityManager()
Visual Basic (Declaration)
Public Function GetIDBCommunityManager As IDBCommunityManager
Visual C++
public:
IDBCommunityManager^ GetIDBCommunityManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBCommunityMemberManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBCommunityMemberManager GetIDBCommunityMemberManager()
Visual Basic (Declaration)
Public Function GetIDBCommunityMemberManager As IDBCommunityMemberManager
Visual C++
public:
IDBCommunityMemberManager^ GetIDBCommunityMemberManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBCommunityMsgRecordManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBCommunityMsgRecordManager GetIDBCommunityMsgRecordManager()
Visual Basic (Declaration)
Public Function GetIDBCommunityMsgRecordManager As IDBCommunityMsgRecordManager
Visual C++
public:
IDBCommunityMsgRecordManager^ GetIDBCommunityMsgRecordManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBCompanyGatheringManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBCompanyGatheringManager GetIDBCompanyGatheringManager()
Visual Basic (Declaration)
Public Function GetIDBCompanyGatheringManager As IDBCompanyGatheringManager
Visual C++
public:
IDBCompanyGatheringManager^ GetIDBCompanyGatheringManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBCompanyManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBCompanyManager GetIDBCompanyManager()
Visual Basic (Declaration)
Public Function GetIDBCompanyManager As IDBCompanyManager
Visual C++
public:
IDBCompanyManager^ GetIDBCompanyManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBDepartmentManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBDepartmentManager GetIDBDepartmentManager()
Visual Basic (Declaration)
Public Function GetIDBDepartmentManager As IDBDepartmentManager
Visual C++
public:
IDBDepartmentManager^ GetIDBDepartmentManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBEmployeeManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBEmployeeManager GetIDBEmployeeManager()
Visual Basic (Declaration)
Public Function GetIDBEmployeeManager As IDBEmployeeManager
Visual C++
public:
IDBEmployeeManager^ GetIDBEmployeeManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBLoginRecordManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBLoginRecordManager GetIDBLoginRecordManager()
Visual Basic (Declaration)
Public Function GetIDBLoginRecordManager As IDBLoginRecordManager
Visual C++
public:
IDBLoginRecordManager^ GetIDBLoginRecordManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBNewsManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBMiniNewsManager GetIDBNewsManager()
Visual Basic (Declaration)
Public Function GetIDBNewsManager As IDBMiniNewsManager
Visual C++
public:
IDBMiniNewsManager^ GetIDBNewsManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBOnlineBroadManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBOnlineBroadManager GetIDBOnlineBroadManager()
Visual Basic (Declaration)
Public Function GetIDBOnlineBroadManager As IDBOnlineBroadManager
Visual C++
public:
IDBOnlineBroadManager^ GetIDBOnlineBroadManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBOtherManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBTblAdvManager GetIDBOtherManager()
Visual Basic (Declaration)
Public Function GetIDBOtherManager As IDBTblAdvManager
Visual C++
public:
IDBTblAdvManager^ GetIDBOtherManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBPanelManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBPanelManager GetIDBPanelManager()
Visual Basic (Declaration)
Public Function GetIDBPanelManager As IDBPanelManager
Visual C++
public:
IDBPanelManager^ GetIDBPanelManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBUserBriefManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBUserBriefManager GetIDBUserBriefManager()
Visual Basic (Declaration)
Public Function GetIDBUserBriefManager As IDBUserBriefManager
Visual C++
public:
IDBUserBriefManager^ GetIDBUserBriefManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBUserDetailManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBUserDetailManager GetIDBUserDetailManager()
Visual Basic (Declaration)
Public Function GetIDBUserDetailManager As IDBUserDetailManager
Visual C++
public:
IDBUserDetailManager^ GetIDBUserDetailManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


GetIDBUserFileManager Method

[image]

伟鹏即时通讯Web Service说明文档
WpimSystemFacade 类 参见

命名空间： WpimSystem
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public IDBUserFileManager GetIDBUserFileManager()
Visual Basic (Declaration)
Public Function GetIDBUserFileManager As IDBUserFileManager
Visual C++
public:
IDBUserFileManager^ GetIDBUserFileManager()

参见

WpimSystemFacade 类
WpimSystem 命名空间


WpimSystem.Domain Namespace

[image]

伟鹏即时通讯Web Service说明文档

类

类 | 说明
Ad | [广告]领域类
Community | [群组]领域类
CommunityMember | [群用户]领域类
CommunityMsgRecord | [群消息记录]领域类
Company | [公司]领域类
CompanyGathering | [企业收款登记]领域类
Department | [部门]领域类
Employee | [员工]领域类
LoginRecord | [登录记录]领域类
MiniNews | [迷你新闻]领域类
OnlineBroad | [在线广播]领域类
Panel | [频道]领域类
TblAdv | [TblAdv]领域类
UserBrief | [UserBrief]伟鹏即时通用户简要信息
UserDetail | [用户详情]领域类
UserFile | [用户文件]领域类


Ad Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[广告]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class Ad
Visual Basic (Declaration)
Public Class Ad
Visual C++
public ref class Ad

继承层次结构

System..::.Object
WpimSystem.Domain..::.Ad

参见

Ad 成员
WpimSystem.Domain 命名空间


Ad Members

[image] [image]

伟鹏即时通讯Web Service说明文档
Ad 类 构造函数 属性 参见

Ad 类型暴露了以下成员.

构造函数

名称 | 说明
Ad | Initializes a new instance of the Ad class

属性

名称 | 说明
AdCreaTime | 创建时间
AdDescription | 广告说明，只用于后台显示
AdEditTime | 编辑时间
AdHttpUrl | 链接地址
AdImgUrl | 图片路径
AdName | 广告名称
AdType | 广告类型
Id | 自动编号
State | 广告状态

参见

Ad 类
WpimSystem.Domain 命名空间


Ad Constructor

[image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见
Initializes a new instance of the Ad class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public Ad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Ad()

参见

Ad 类
WpimSystem.Domain 命名空间


Ad Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见

Ad 类型暴露了以下属性.

属性

名称 | 说明
AdCreaTime | 创建时间
AdDescription | 广告说明，只用于后台显示
AdEditTime | 编辑时间
AdHttpUrl | 链接地址
AdImgUrl | 图片路径
AdName | 广告名称
AdType | 广告类型
Id | 自动编号
State | 广告状态

参见

Ad 类
WpimSystem.Domain 命名空间


AdCreaTime Property

[image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见
创建时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime AdCreaTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdCreaTime As DateTime
Visual C++
public:
virtual property DateTime AdCreaTime {
    DateTime get ();
    void set (DateTime value);
}

参见

Ad 类
WpimSystem.Domain 命名空间


AdDescription Property

[image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见
广告说明，只用于后台显示

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string AdDescription { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdDescription As String
Visual C++
public:
virtual property String^ AdDescription {
    String^ get ();
    void set (String^ value);
}

参见

Ad 类
WpimSystem.Domain 命名空间


AdEditTime Property

[image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见
编辑时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime AdEditTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdEditTime As DateTime
Visual C++
public:
virtual property DateTime AdEditTime {
    DateTime get ();
    void set (DateTime value);
}

参见

Ad 类
WpimSystem.Domain 命名空间


AdHttpUrl Property

[image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见
链接地址

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string AdHttpUrl { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdHttpUrl As String
Visual C++
public:
virtual property String^ AdHttpUrl {
    String^ get ();
    void set (String^ value);
}

参见

Ad 类
WpimSystem.Domain 命名空间


AdImgUrl Property

[image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见
图片路径

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string AdImgUrl { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdImgUrl As String
Visual C++
public:
virtual property String^ AdImgUrl {
    String^ get ();
    void set (String^ value);
}

参见

Ad 类
WpimSystem.Domain 命名空间


AdName Property

[image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见
广告名称

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string AdName { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdName As String
Visual C++
public:
virtual property String^ AdName {
    String^ get ();
    void set (String^ value);
}

参见

Ad 类
WpimSystem.Domain 命名空间


AdType Property

[image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见
广告类型

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int AdType { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdType As Integer
Visual C++
public:
virtual property int AdType {
    int get ();
    void set (int value);
}

参见

Ad 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见
自动编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

Ad 类
WpimSystem.Domain 命名空间


State Property

[image]

伟鹏即时通讯Web Service说明文档
Ad 类 参见
广告状态

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int State { get; set; }
Visual Basic (Declaration)
Public Overridable Property State As Integer
Visual C++
public:
virtual property int State {
    int get ();
    void set (int value);
}

参见

Ad 类
WpimSystem.Domain 命名空间


Community Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[群组]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class Community
Visual Basic (Declaration)
Public Class Community
Visual C++
public ref class Community

继承层次结构

System..::.Object
WpimSystem.Domain..::.Community

参见

Community 成员
WpimSystem.Domain 命名空间


Community Members

[image] [image]

伟鹏即时通讯Web Service说明文档
Community 类 构造函数 属性 参见

Community 类型暴露了以下成员.

构造函数

名称 | 说明
Community | Initializes a new instance of the Community class

属性

名称 | 说明
AdminUins | 管理员
BeginTime | 开始日期
Billboard | 公告
CommunityType | 群类型
CreaterUin | 创建人
Descr | 描述
EndTime | 结束日期
Id | Id
MaxMember | 最大用户数
Name | 名称
Password | 密码
Status | 状态

参见

Community 类
WpimSystem.Domain 命名空间


Community Constructor

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
Initializes a new instance of the Community class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public Community()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Community()

参见

Community 类
WpimSystem.Domain 命名空间


Community Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
Community 类 参见

Community 类型暴露了以下属性.

属性

名称 | 说明
AdminUins | 管理员
BeginTime | 开始日期
Billboard | 公告
CommunityType | 群类型
CreaterUin | 创建人
Descr | 描述
EndTime | 结束日期
Id | Id
MaxMember | 最大用户数
Name | 名称
Password | 密码
Status | 状态

参见

Community 类
WpimSystem.Domain 命名空间


AdminUins Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
管理员

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string AdminUins { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdminUins As String
Visual C++
public:
virtual property String^ AdminUins {
    String^ get ();
    void set (String^ value);
}

参见

Community 类
WpimSystem.Domain 命名空间


BeginTime Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
开始日期

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime BeginTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property BeginTime As DateTime
Visual C++
public:
virtual property DateTime BeginTime {
    DateTime get ();
    void set (DateTime value);
}

参见

Community 类
WpimSystem.Domain 命名空间


Billboard Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
公告

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Billboard { get; set; }
Visual Basic (Declaration)
Public Overridable Property Billboard As String
Visual C++
public:
virtual property String^ Billboard {
    String^ get ();
    void set (String^ value);
}

参见

Community 类
WpimSystem.Domain 命名空间


CommunityType Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
群类型

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int CommunityType { get; set; }
Visual Basic (Declaration)
Public Overridable Property CommunityType As Integer
Visual C++
public:
virtual property int CommunityType {
    int get ();
    void set (int value);
}

参见

Community 类
WpimSystem.Domain 命名空间


CreaterUin Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
创建人

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int CreaterUin { get; set; }
Visual Basic (Declaration)
Public Overridable Property CreaterUin As Integer
Visual C++
public:
virtual property int CreaterUin {
    int get ();
    void set (int value);
}

参见

Community 类
WpimSystem.Domain 命名空间


Descr Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
描述

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Descr { get; set; }
Visual Basic (Declaration)
Public Overridable Property Descr As String
Visual C++
public:
virtual property String^ Descr {
    String^ get ();
    void set (String^ value);
}

参见

Community 类
WpimSystem.Domain 命名空间


EndTime Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
结束日期

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime EndTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property EndTime As DateTime
Visual C++
public:
virtual property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}

参见

Community 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

Community 类
WpimSystem.Domain 命名空间


MaxMember Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
最大用户数

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int MaxMember { get; set; }
Visual Basic (Declaration)
Public Overridable Property MaxMember As Integer
Visual C++
public:
virtual property int MaxMember {
    int get ();
    void set (int value);
}

参见

Community 类
WpimSystem.Domain 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
名称

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

参见

Community 类
WpimSystem.Domain 命名空间


Password Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
密码

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Password { get; set; }
Visual Basic (Declaration)
Public Overridable Property Password As String
Visual C++
public:
virtual property String^ Password {
    String^ get ();
    void set (String^ value);
}

参见

Community 类
WpimSystem.Domain 命名空间


Status Property

[image]

伟鹏即时通讯Web Service说明文档
Community 类 参见
状态

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Status { get; set; }
Visual Basic (Declaration)
Public Overridable Property Status As Integer
Visual C++
public:
virtual property int Status {
    int get ();
    void set (int value);
}

参见

Community 类
WpimSystem.Domain 命名空间


CommunityMember Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[群用户]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class CommunityMember
Visual Basic (Declaration)
Public Class CommunityMember
Visual C++
public ref class CommunityMember

继承层次结构

System..::.Object
WpimSystem.Domain..::.CommunityMember

参见

CommunityMember 成员
WpimSystem.Domain 命名空间


CommunityMember Members

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityMember 类 构造函数 属性 参见

CommunityMember 类型暴露了以下成员.

构造函数

名称 | 说明
CommunityMember | Initializes a new instance of the CommunityMember class

属性

名称 | 说明
BeginTime | 开始时间
CommunityId | 群Id
EndTime | 结束时间
Id | Id
Status | 状态
Uin | 即时通号

参见

CommunityMember 类
WpimSystem.Domain 命名空间


CommunityMember Constructor

[image]

伟鹏即时通讯Web Service说明文档
CommunityMember 类 参见
Initializes a new instance of the CommunityMember class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public CommunityMember()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CommunityMember()

参见

CommunityMember 类
WpimSystem.Domain 命名空间


CommunityMember Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityMember 类 参见

CommunityMember 类型暴露了以下属性.

属性

名称 | 说明
BeginTime | 开始时间
CommunityId | 群Id
EndTime | 结束时间
Id | Id
Status | 状态
Uin | 即时通号

参见

CommunityMember 类
WpimSystem.Domain 命名空间


BeginTime Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMember 类 参见
开始时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime BeginTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property BeginTime As DateTime
Visual C++
public:
virtual property DateTime BeginTime {
    DateTime get ();
    void set (DateTime value);
}

参见

CommunityMember 类
WpimSystem.Domain 命名空间


CommunityId Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMember 类 参见
群Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int CommunityId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CommunityId As Integer
Visual C++
public:
virtual property int CommunityId {
    int get ();
    void set (int value);
}

参见

CommunityMember 类
WpimSystem.Domain 命名空间


EndTime Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMember 类 参见
结束时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime EndTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property EndTime As DateTime
Visual C++
public:
virtual property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}

参见

CommunityMember 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMember 类 参见
Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

CommunityMember 类
WpimSystem.Domain 命名空间


Status Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMember 类 参见
状态

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Status { get; set; }
Visual Basic (Declaration)
Public Overridable Property Status As Integer
Visual C++
public:
virtual property int Status {
    int get ();
    void set (int value);
}

参见

CommunityMember 类
WpimSystem.Domain 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMember 类 参见
即时通号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As Integer
Visual C++
public:
virtual property int Uin {
    int get ();
    void set (int value);
}

参见

CommunityMember 类
WpimSystem.Domain 命名空间


CommunityMsgRecord Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[群消息记录]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class CommunityMsgRecord
Visual Basic (Declaration)
Public Class CommunityMsgRecord
Visual C++
public ref class CommunityMsgRecord

继承层次结构

System..::.Object
WpimSystem.Domain..::.CommunityMsgRecord

参见

CommunityMsgRecord 成员
WpimSystem.Domain 命名空间


CommunityMsgRecord Members

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 构造函数 属性 参见

CommunityMsgRecord 类型暴露了以下成员.

构造函数

名称 | 说明
CommunityMsgRecord | Initializes a new instance of the CommunityMsgRecord class

属性

名称 | 说明
AtTime | 时间
CommunityId | 群Id
CommunityType | 群类别
FromUin | 发送人即时通号码
FromUserCompanyId | 发送用户公司Id
FromUserIp | 发送人IP
FromUserNickname | 发送人昵称
Id | 自动编号
IsFromGuest | 是否来源于访客
Msg | 消息内容
ToUin | 接收人即时通号
ToUserCompanyId | 接收用户公司Id
ToUserIp | 接收人IP
ToUserNickname | 接收人昵称

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


CommunityMsgRecord Constructor

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
Initializes a new instance of the CommunityMsgRecord class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public CommunityMsgRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CommunityMsgRecord()

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


CommunityMsgRecord Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见

CommunityMsgRecord 类型暴露了以下属性.

属性

名称 | 说明
AtTime | 时间
CommunityId | 群Id
CommunityType | 群类别
FromUin | 发送人即时通号码
FromUserCompanyId | 发送用户公司Id
FromUserIp | 发送人IP
FromUserNickname | 发送人昵称
Id | 自动编号
IsFromGuest | 是否来源于访客
Msg | 消息内容
ToUin | 接收人即时通号
ToUserCompanyId | 接收用户公司Id
ToUserIp | 接收人IP
ToUserNickname | 接收人昵称

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


AtTime Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime AtTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property AtTime As DateTime
Visual C++
public:
virtual property DateTime AtTime {
    DateTime get ();
    void set (DateTime value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


CommunityId Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
群Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int CommunityId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CommunityId As Integer
Visual C++
public:
virtual property int CommunityId {
    int get ();
    void set (int value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


CommunityType Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
群类别

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int CommunityType { get; set; }
Visual Basic (Declaration)
Public Overridable Property CommunityType As Integer
Visual C++
public:
virtual property int CommunityType {
    int get ();
    void set (int value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


FromUin Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
发送人即时通号码

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int FromUin { get; set; }
Visual Basic (Declaration)
Public Overridable Property FromUin As Integer
Visual C++
public:
virtual property int FromUin {
    int get ();
    void set (int value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


FromUserCompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
发送用户公司Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int FromUserCompanyId { get; set; }
Visual Basic (Declaration)
Public Overridable Property FromUserCompanyId As Integer
Visual C++
public:
virtual property int FromUserCompanyId {
    int get ();
    void set (int value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


FromUserIp Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
发送人IP

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string FromUserIp { get; set; }
Visual Basic (Declaration)
Public Overridable Property FromUserIp As String
Visual C++
public:
virtual property String^ FromUserIp {
    String^ get ();
    void set (String^ value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


FromUserNickname Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
发送人昵称

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string FromUserNickname { get; set; }
Visual Basic (Declaration)
Public Overridable Property FromUserNickname As String
Visual C++
public:
virtual property String^ FromUserNickname {
    String^ get ();
    void set (String^ value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
自动编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


IsFromGuest Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
是否来源于访客

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual bool IsFromGuest { get; set; }
Visual Basic (Declaration)
Public Overridable Property IsFromGuest As Boolean
Visual C++
public:
virtual property bool IsFromGuest {
    bool get ();
    void set (bool value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


Msg Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
消息内容

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Msg { get; set; }
Visual Basic (Declaration)
Public Overridable Property Msg As String
Visual C++
public:
virtual property String^ Msg {
    String^ get ();
    void set (String^ value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


ToUin Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
接收人即时通号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int ToUin { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToUin As Integer
Visual C++
public:
virtual property int ToUin {
    int get ();
    void set (int value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


ToUserCompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
接收用户公司Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int ToUserCompanyId { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToUserCompanyId As Integer
Visual C++
public:
virtual property int ToUserCompanyId {
    int get ();
    void set (int value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


ToUserIp Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
接收人IP

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string ToUserIp { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToUserIp As String
Visual C++
public:
virtual property String^ ToUserIp {
    String^ get ();
    void set (String^ value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


ToUserNickname Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecord 类 参见
接收人昵称

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string ToUserNickname { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToUserNickname As String
Visual C++
public:
virtual property String^ ToUserNickname {
    String^ get ();
    void set (String^ value);
}

参见

CommunityMsgRecord 类
WpimSystem.Domain 命名空间


Company Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[公司]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class Company
Visual Basic (Declaration)
Public Class Company
Visual C++
public ref class Company

继承层次结构

System..::.Object
WpimSystem.Domain..::.Company

参见

Company 成员
WpimSystem.Domain 命名空间


Company Members

[image] [image]

伟鹏即时通讯Web Service说明文档
Company 类 构造函数 属性 参见

Company 类型暴露了以下成员.

构造函数

名称 | 说明
Company | Initializes a new instance of the Company class

属性

名称 | 说明
Account | 帐号
Answer | Answer
City | 城市
CommunityId | CommumityId 主群Id（经营品牌）
Country | 国家
CreateTime | 创建时间
Email | 电子邮件
EmployeeLimitNumber | 职员限制数
Fax | 传真
Id | Id
License | 执照编号
LicenseImage | 执照照片
Linkman | 联系人
Mobile | 手机
MSN | MSN
Name | 名称
Password | 密码
Province | 省份
QQ | QQ
Question | Question
Status | 状态
Tel | 电话
Web | 网站

参见

Company 类
WpimSystem.Domain 命名空间


Company Constructor

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
Initializes a new instance of the Company class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public Company()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Company()

参见

Company 类
WpimSystem.Domain 命名空间


Company Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
Company 类 参见

Company 类型暴露了以下属性.

属性

名称 | 说明
Account | 帐号
Answer | Answer
City | 城市
CommunityId | CommumityId 主群Id（经营品牌）
Country | 国家
CreateTime | 创建时间
Email | 电子邮件
EmployeeLimitNumber | 职员限制数
Fax | 传真
Id | Id
License | 执照编号
LicenseImage | 执照照片
Linkman | 联系人
Mobile | 手机
MSN | MSN
Name | 名称
Password | 密码
Province | 省份
QQ | QQ
Question | Question
Status | 状态
Tel | 电话
Web | 网站

参见

Company 类
WpimSystem.Domain 命名空间


Account Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
帐号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Account { get; set; }
Visual Basic (Declaration)
Public Overridable Property Account As String
Visual C++
public:
virtual property String^ Account {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Answer Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
Answer

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Answer { get; set; }
Visual Basic (Declaration)
Public Overridable Property Answer As String
Visual C++
public:
virtual property String^ Answer {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


City Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
城市

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string City { get; set; }
Visual Basic (Declaration)
Public Overridable Property City As String
Visual C++
public:
virtual property String^ City {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


CommunityId Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
CommumityId 主群Id（经营品牌）

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string CommunityId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CommunityId As String
Visual C++
public:
virtual property String^ CommunityId {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Country Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
国家

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Country { get; set; }
Visual Basic (Declaration)
Public Overridable Property Country As String
Visual C++
public:
virtual property String^ Country {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


CreateTime Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
创建时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime CreateTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property CreateTime As DateTime
Visual C++
public:
virtual property DateTime CreateTime {
    DateTime get ();
    void set (DateTime value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Email Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
电子邮件

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Email { get; set; }
Visual Basic (Declaration)
Public Overridable Property Email As String
Visual C++
public:
virtual property String^ Email {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


EmployeeLimitNumber Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
职员限制数

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int EmployeeLimitNumber { get; set; }
Visual Basic (Declaration)
Public Overridable Property EmployeeLimitNumber As Integer
Visual C++
public:
virtual property int EmployeeLimitNumber {
    int get ();
    void set (int value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Fax Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
传真

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Fax { get; set; }
Visual Basic (Declaration)
Public Overridable Property Fax As String
Visual C++
public:
virtual property String^ Fax {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

Company 类
WpimSystem.Domain 命名空间


License Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
执照编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string License { get; set; }
Visual Basic (Declaration)
Public Overridable Property License As String
Visual C++
public:
virtual property String^ License {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


LicenseImage Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
执照照片

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string LicenseImage { get; set; }
Visual Basic (Declaration)
Public Overridable Property LicenseImage As String
Visual C++
public:
virtual property String^ LicenseImage {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Linkman Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
联系人

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Linkman { get; set; }
Visual Basic (Declaration)
Public Overridable Property Linkman As String
Visual C++
public:
virtual property String^ Linkman {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Mobile Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
手机

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Mobile { get; set; }
Visual Basic (Declaration)
Public Overridable Property Mobile As String
Visual C++
public:
virtual property String^ Mobile {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


MSN Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
MSN

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string MSN { get; set; }
Visual Basic (Declaration)
Public Overridable Property MSN As String
Visual C++
public:
virtual property String^ MSN {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
名称

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Password Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
密码

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Password { get; set; }
Visual Basic (Declaration)
Public Overridable Property Password As String
Visual C++
public:
virtual property String^ Password {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Province Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
省份

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Province { get; set; }
Visual Basic (Declaration)
Public Overridable Property Province As String
Visual C++
public:
virtual property String^ Province {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


QQ Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
QQ

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string QQ { get; set; }
Visual Basic (Declaration)
Public Overridable Property QQ As String
Visual C++
public:
virtual property String^ QQ {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Question Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
Question

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Question { get; set; }
Visual Basic (Declaration)
Public Overridable Property Question As String
Visual C++
public:
virtual property String^ Question {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Status Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
状态

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Status { get; set; }
Visual Basic (Declaration)
Public Overridable Property Status As Integer
Visual C++
public:
virtual property int Status {
    int get ();
    void set (int value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Tel Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
电话

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Tel { get; set; }
Visual Basic (Declaration)
Public Overridable Property Tel As String
Visual C++
public:
virtual property String^ Tel {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


Web Property

[image]

伟鹏即时通讯Web Service说明文档
Company 类 参见
网站

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Web { get; set; }
Visual Basic (Declaration)
Public Overridable Property Web As String
Visual C++
public:
virtual property String^ Web {
    String^ get ();
    void set (String^ value);
}

参见

Company 类
WpimSystem.Domain 命名空间


CompanyGathering Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[企业收款登记]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class CompanyGathering
Visual Basic (Declaration)
Public Class CompanyGathering
Visual C++
public ref class CompanyGathering

继承层次结构

System..::.Object
WpimSystem.Domain..::.CompanyGathering

参见

CompanyGathering 成员
WpimSystem.Domain 命名空间


CompanyGathering Members

[image] [image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 构造函数 属性 参见

CompanyGathering 类型暴露了以下成员.

构造函数

名称 | 说明
CompanyGathering | Initializes a new instance of the CompanyGathering class

属性

名称 | 说明
CompanyAccount | 企业帐号
CompanyId | 企业ID
CompanyName |
Id | 自动编号
InputTime | 记帐日期
ModifTime | 修改时间
Modifyer | 修改人
Money | 金额
Payee | 收款人
PayeeAccount | 收款帐号
PayeeBank | 收款银行
PayeeTime | 收款日期
Payer | 付款人
PayerAccount | 付款帐号
PayerBank | 付款银行
PaymentMethod | 收款方式
Recorder | 记帐人
Rmark | 备注
Summary | 收款摘要

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


CompanyGathering Constructor

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
Initializes a new instance of the CompanyGathering class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public CompanyGathering()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompanyGathering()

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


CompanyGathering Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见

CompanyGathering 类型暴露了以下属性.

属性

名称 | 说明
CompanyAccount | 企业帐号
CompanyId | 企业ID
CompanyName |
Id | 自动编号
InputTime | 记帐日期
ModifTime | 修改时间
Modifyer | 修改人
Money | 金额
Payee | 收款人
PayeeAccount | 收款帐号
PayeeBank | 收款银行
PayeeTime | 收款日期
Payer | 付款人
PayerAccount | 付款帐号
PayerBank | 付款银行
PaymentMethod | 收款方式
Recorder | 记帐人
Rmark | 备注
Summary | 收款摘要

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


CompanyAccount Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
企业帐号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string CompanyAccount { get; set; }
Visual Basic (Declaration)
Public Overridable Property CompanyAccount As String
Visual C++
public:
virtual property String^ CompanyAccount {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


CompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
企业ID

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int CompanyId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CompanyId As Integer
Visual C++
public:
virtual property int CompanyId {
    int get ();
    void set (int value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


CompanyName Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string CompanyName { get; set; }
Visual Basic (Declaration)
Public Property CompanyName As String
Visual C++
public:
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
自动编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


InputTime Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
记帐日期

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime InputTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property InputTime As DateTime
Visual C++
public:
virtual property DateTime InputTime {
    DateTime get ();
    void set (DateTime value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


ModifTime Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
修改时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime ModifTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property ModifTime As DateTime
Visual C++
public:
virtual property DateTime ModifTime {
    DateTime get ();
    void set (DateTime value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


Modifyer Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
修改人

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Modifyer { get; set; }
Visual Basic (Declaration)
Public Overridable Property Modifyer As String
Visual C++
public:
virtual property String^ Modifyer {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


Money Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
金额

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual double Money { get; set; }
Visual Basic (Declaration)
Public Overridable Property Money As Double
Visual C++
public:
virtual property double Money {
    double get ();
    void set (double value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


Payee Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
收款人

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Payee { get; set; }
Visual Basic (Declaration)
Public Overridable Property Payee As String
Visual C++
public:
virtual property String^ Payee {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


PayeeAccount Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
收款帐号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string PayeeAccount { get; set; }
Visual Basic (Declaration)
Public Overridable Property PayeeAccount As String
Visual C++
public:
virtual property String^ PayeeAccount {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


PayeeBank Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
收款银行

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string PayeeBank { get; set; }
Visual Basic (Declaration)
Public Overridable Property PayeeBank As String
Visual C++
public:
virtual property String^ PayeeBank {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


PayeeTime Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
收款日期

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime PayeeTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property PayeeTime As DateTime
Visual C++
public:
virtual property DateTime PayeeTime {
    DateTime get ();
    void set (DateTime value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


Payer Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
付款人

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Payer { get; set; }
Visual Basic (Declaration)
Public Overridable Property Payer As String
Visual C++
public:
virtual property String^ Payer {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


PayerAccount Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
付款帐号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string PayerAccount { get; set; }
Visual Basic (Declaration)
Public Overridable Property PayerAccount As String
Visual C++
public:
virtual property String^ PayerAccount {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


PayerBank Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
付款银行

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string PayerBank { get; set; }
Visual Basic (Declaration)
Public Overridable Property PayerBank As String
Visual C++
public:
virtual property String^ PayerBank {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


PaymentMethod Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
收款方式

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string PaymentMethod { get; set; }
Visual Basic (Declaration)
Public Overridable Property PaymentMethod As String
Visual C++
public:
virtual property String^ PaymentMethod {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


Recorder Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
记帐人

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Recorder { get; set; }
Visual Basic (Declaration)
Public Overridable Property Recorder As String
Visual C++
public:
virtual property String^ Recorder {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


Rmark Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
备注

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Rmark { get; set; }
Visual Basic (Declaration)
Public Overridable Property Rmark As String
Visual C++
public:
virtual property String^ Rmark {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


Summary Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGathering 类 参见
收款摘要

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Summary { get; set; }
Visual Basic (Declaration)
Public Overridable Property Summary As String
Visual C++
public:
virtual property String^ Summary {
    String^ get ();
    void set (String^ value);
}

参见

CompanyGathering 类
WpimSystem.Domain 命名空间


Department Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[部门]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class Department
Visual Basic (Declaration)
Public Class Department
Visual C++
public ref class Department

继承层次结构

System..::.Object
WpimSystem.Domain..::.Department

参见

Department 成员
WpimSystem.Domain 命名空间


Department Members

[image] [image]

伟鹏即时通讯Web Service说明文档
Department 类 构造函数 属性 参见

Department 类型暴露了以下成员.

构造函数

名称 | 说明
Department | Initializes a new instance of the Department class

属性

名称 | 说明
CompanyId |
Id | 自动编号
Name | 名称
Ordering | 排序
ParentId |

参见

Department 类
WpimSystem.Domain 命名空间


Department Constructor

[image]

伟鹏即时通讯Web Service说明文档
Department 类 参见
Initializes a new instance of the Department class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public Department()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Department()

参见

Department 类
WpimSystem.Domain 命名空间


Department Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
Department 类 参见

Department 类型暴露了以下属性.

属性

名称 | 说明
CompanyId |
Id | 自动编号
Name | 名称
Ordering | 排序
ParentId |

参见

Department 类
WpimSystem.Domain 命名空间


CompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
Department 类 参见

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int CompanyId { get; set; }
Visual Basic (Declaration)
Public Property CompanyId As Integer
Visual C++
public:
property int CompanyId {
    int get ();
    void set (int value);
}

参见

Department 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
Department 类 参见
自动编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

Department 类
WpimSystem.Domain 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
Department 类 参见
名称

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

参见

Department 类
WpimSystem.Domain 命名空间


Ordering Property

[image]

伟鹏即时通讯Web Service说明文档
Department 类 参见
排序

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Ordering { get; set; }
Visual Basic (Declaration)
Public Overridable Property Ordering As Integer
Visual C++
public:
virtual property int Ordering {
    int get ();
    void set (int value);
}

参见

Department 类
WpimSystem.Domain 命名空间


ParentId Property

[image]

伟鹏即时通讯Web Service说明文档
Department 类 参见

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int ParentId { get; set; }
Visual Basic (Declaration)
Public Property ParentId As Integer
Visual C++
public:
property int ParentId {
    int get ();
    void set (int value);
}

参见

Department 类
WpimSystem.Domain 命名空间


Employee Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[员工]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class Employee
Visual Basic (Declaration)
Public Class Employee
Visual C++
public ref class Employee

继承层次结构

System..::.Object
WpimSystem.Domain..::.Employee

参见

Employee 成员
WpimSystem.Domain 命名空间


Employee Members

[image] [image]

伟鹏即时通讯Web Service说明文档
Employee 类 构造函数 属性 参见

Employee 类型暴露了以下成员.

构造函数

名称 | 说明
Employee | Initializes a new instance of the Employee class

属性

名称 | 说明
Company | 公司名称
CompanyId | 所属公司
CreateTime | 创建时间
DepartmentId | 所属部门
ExpireTime | 有效时间
GroupIds | 加入的群组
Id | Id
Name | 姓名
Status | 状态
Uin | 即时通号

参见

Employee 类
WpimSystem.Domain 命名空间


Employee Constructor

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
Initializes a new instance of the Employee class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public Employee()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Employee()

参见

Employee 类
WpimSystem.Domain 命名空间


Employee Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见

Employee 类型暴露了以下属性.

属性

名称 | 说明
Company | 公司名称
CompanyId | 所属公司
CreateTime | 创建时间
DepartmentId | 所属部门
ExpireTime | 有效时间
GroupIds | 加入的群组
Id | Id
Name | 姓名
Status | 状态
Uin | 即时通号

参见

Employee 类
WpimSystem.Domain 命名空间


Company Property

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
公司名称

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Company { get; set; }
Visual Basic (Declaration)
Public Overridable Property Company As String
Visual C++
public:
virtual property String^ Company {
    String^ get ();
    void set (String^ value);
}

参见

Employee 类
WpimSystem.Domain 命名空间


CompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
所属公司

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int CompanyId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CompanyId As Integer
Visual C++
public:
virtual property int CompanyId {
    int get ();
    void set (int value);
}

参见

Employee 类
WpimSystem.Domain 命名空间


CreateTime Property

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
创建时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime CreateTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property CreateTime As DateTime
Visual C++
public:
virtual property DateTime CreateTime {
    DateTime get ();
    void set (DateTime value);
}

参见

Employee 类
WpimSystem.Domain 命名空间


DepartmentId Property

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
所属部门

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int DepartmentId { get; set; }
Visual Basic (Declaration)
Public Property DepartmentId As Integer
Visual C++
public:
property int DepartmentId {
    int get ();
    void set (int value);
}

参见

Employee 类
WpimSystem.Domain 命名空间


ExpireTime Property

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
有效时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime ExpireTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property ExpireTime As DateTime
Visual C++
public:
virtual property DateTime ExpireTime {
    DateTime get ();
    void set (DateTime value);
}

参见

Employee 类
WpimSystem.Domain 命名空间


GroupIds Property

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
加入的群组

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string GroupIds { get; set; }
Visual Basic (Declaration)
Public Overridable Property GroupIds As String
Visual C++
public:
virtual property String^ GroupIds {
    String^ get ();
    void set (String^ value);
}

参见

Employee 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

Employee 类
WpimSystem.Domain 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
姓名

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

参见

Employee 类
WpimSystem.Domain 命名空间


Status Property

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
状态

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Status { get; set; }
Visual Basic (Declaration)
Public Overridable Property Status As Integer
Visual C++
public:
virtual property int Status {
    int get ();
    void set (int value);
}

参见

Employee 类
WpimSystem.Domain 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
Employee 类 参见
即时通号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As Integer
Visual C++
public:
virtual property int Uin {
    int get ();
    void set (int value);
}

参见

Employee 类
WpimSystem.Domain 命名空间


LoginRecord Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[登录记录]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class LoginRecord
Visual Basic (Declaration)
Public Class LoginRecord
Visual C++
public ref class LoginRecord

继承层次结构

System..::.Object
WpimSystem.Domain..::.LoginRecord

参见

LoginRecord 成员
WpimSystem.Domain 命名空间


LoginRecord Members

[image] [image]

伟鹏即时通讯Web Service说明文档
LoginRecord 类 构造函数 属性 参见

LoginRecord 类型暴露了以下成员.

构造函数

名称 | 说明
LoginRecord | Initializes a new instance of the LoginRecord class

属性

名称 | 说明
ClientType | 客户端类型
Id | 自动编号
IP | 登录IP
LoginTime | 登录时间
OnlineStatus | 连线状态
Uin | 即时通号

参见

LoginRecord 类
WpimSystem.Domain 命名空间


LoginRecord Constructor

[image]

伟鹏即时通讯Web Service说明文档
LoginRecord 类 参见
Initializes a new instance of the LoginRecord class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public LoginRecord()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoginRecord()

参见

LoginRecord 类
WpimSystem.Domain 命名空间


LoginRecord Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
LoginRecord 类 参见

LoginRecord 类型暴露了以下属性.

属性

名称 | 说明
ClientType | 客户端类型
Id | 自动编号
IP | 登录IP
LoginTime | 登录时间
OnlineStatus | 连线状态
Uin | 即时通号

参见

LoginRecord 类
WpimSystem.Domain 命名空间


ClientType Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecord 类 参见
客户端类型

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int ClientType { get; set; }
Visual Basic (Declaration)
Public Overridable Property ClientType As Integer
Visual C++
public:
virtual property int ClientType {
    int get ();
    void set (int value);
}

参见

LoginRecord 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecord 类 参见
自动编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

LoginRecord 类
WpimSystem.Domain 命名空间


IP Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecord 类 参见
登录IP

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string IP { get; set; }
Visual Basic (Declaration)
Public Overridable Property IP As String
Visual C++
public:
virtual property String^ IP {
    String^ get ();
    void set (String^ value);
}

参见

LoginRecord 类
WpimSystem.Domain 命名空间


LoginTime Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecord 类 参见
登录时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime LoginTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property LoginTime As DateTime
Visual C++
public:
virtual property DateTime LoginTime {
    DateTime get ();
    void set (DateTime value);
}

参见

LoginRecord 类
WpimSystem.Domain 命名空间


OnlineStatus Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecord 类 参见
连线状态

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int OnlineStatus { get; set; }
Visual Basic (Declaration)
Public Overridable Property OnlineStatus As Integer
Visual C++
public:
virtual property int OnlineStatus {
    int get ();
    void set (int value);
}

参见

LoginRecord 类
WpimSystem.Domain 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecord 类 参见
即时通号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As Integer
Visual C++
public:
virtual property int Uin {
    int get ();
    void set (int value);
}

参见

LoginRecord 类
WpimSystem.Domain 命名空间


MiniNews Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[迷你新闻]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class MiniNews
Visual Basic (Declaration)
Public Class MiniNews
Visual C++
public ref class MiniNews

继承层次结构

System..::.Object
WpimSystem.Domain..::.MiniNews

参见

MiniNews 成员
WpimSystem.Domain 命名空间


MiniNews Members

[image] [image]

伟鹏即时通讯Web Service说明文档
MiniNews 类 构造函数 属性 参见

MiniNews 类型暴露了以下成员.

构造函数

名称 | 说明
MiniNews | Initializes a new instance of the MiniNews class

属性

名称 | 说明
Id | 编号
State | 状态
Text | 内容
Title | 标题

参见

MiniNews 类
WpimSystem.Domain 命名空间


MiniNews Constructor

[image]

伟鹏即时通讯Web Service说明文档
MiniNews 类 参见
Initializes a new instance of the MiniNews class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public MiniNews()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MiniNews()

参见

MiniNews 类
WpimSystem.Domain 命名空间


MiniNews Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
MiniNews 类 参见

MiniNews 类型暴露了以下属性.

属性

名称 | 说明
Id | 编号
State | 状态
Text | 内容
Title | 标题

参见

MiniNews 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
MiniNews 类 参见
编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

MiniNews 类
WpimSystem.Domain 命名空间


State Property

[image]

伟鹏即时通讯Web Service说明文档
MiniNews 类 参见
状态

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int State { get; set; }
Visual Basic (Declaration)
Public Overridable Property State As Integer
Visual C++
public:
virtual property int State {
    int get ();
    void set (int value);
}

参见

MiniNews 类
WpimSystem.Domain 命名空间


Text Property

[image]

伟鹏即时通讯Web Service说明文档
MiniNews 类 参见
内容

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Text { get; set; }
Visual Basic (Declaration)
Public Overridable Property Text As String
Visual C++
public:
virtual property String^ Text {
    String^ get ();
    void set (String^ value);
}

参见

MiniNews 类
WpimSystem.Domain 命名空间


Title Property

[image]

伟鹏即时通讯Web Service说明文档
MiniNews 类 参见
标题

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Title { get; set; }
Visual Basic (Declaration)
Public Overridable Property Title As String
Visual C++
public:
virtual property String^ Title {
    String^ get ();
    void set (String^ value);
}

参见

MiniNews 类
WpimSystem.Domain 命名空间


OnlineBroad Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[在线广播]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class OnlineBroad
Visual Basic (Declaration)
Public Class OnlineBroad
Visual C++
public ref class OnlineBroad

继承层次结构

System..::.Object
WpimSystem.Domain..::.OnlineBroad

参见

OnlineBroad 成员
WpimSystem.Domain 命名空间


OnlineBroad Members

[image] [image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 构造函数 属性 参见

OnlineBroad 类型暴露了以下成员.

构造函数

名称 | 说明
OnlineBroad | Initializes a new instance of the OnlineBroad class

属性

名称 | 说明
AddTime | 添加时间
Author | 发由作者
Content | 广播内容
Id | 编号
StartTime | 开始时间
StopTime | 结束时间
Summary | 摘要
Title | 广播标题
UserId | 管理员iD

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


OnlineBroad Constructor

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见
Initializes a new instance of the OnlineBroad class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public OnlineBroad()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OnlineBroad()

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


OnlineBroad Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见

OnlineBroad 类型暴露了以下属性.

属性

名称 | 说明
AddTime | 添加时间
Author | 发由作者
Content | 广播内容
Id | 编号
StartTime | 开始时间
StopTime | 结束时间
Summary | 摘要
Title | 广播标题
UserId | 管理员iD

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


AddTime Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见
添加时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime AddTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property AddTime As DateTime
Visual C++
public:
virtual property DateTime AddTime {
    DateTime get ();
    void set (DateTime value);
}

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


Author Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见
发由作者

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Author { get; set; }
Visual Basic (Declaration)
Public Overridable Property Author As String
Visual C++
public:
virtual property String^ Author {
    String^ get ();
    void set (String^ value);
}

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


Content Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见
广播内容

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Content { get; set; }
Visual Basic (Declaration)
Public Overridable Property Content As String
Visual C++
public:
virtual property String^ Content {
    String^ get ();
    void set (String^ value);
}

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见
编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


StartTime Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见
开始时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime StartTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property StartTime As DateTime
Visual C++
public:
virtual property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


StopTime Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见
结束时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime StopTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property StopTime As DateTime
Visual C++
public:
virtual property DateTime StopTime {
    DateTime get ();
    void set (DateTime value);
}

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


Summary Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见
摘要

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Summary { get; set; }
Visual Basic (Declaration)
Public Overridable Property Summary As String
Visual C++
public:
virtual property String^ Summary {
    String^ get ();
    void set (String^ value);
}

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


Title Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见
广播标题

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Title { get; set; }
Visual Basic (Declaration)
Public Overridable Property Title As String
Visual C++
public:
virtual property String^ Title {
    String^ get ();
    void set (String^ value);
}

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


UserId Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroad 类 参见
管理员iD

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string UserId { get; set; }
Visual Basic (Declaration)
Public Overridable Property UserId As String
Visual C++
public:
virtual property String^ UserId {
    String^ get ();
    void set (String^ value);
}

参见

OnlineBroad 类
WpimSystem.Domain 命名空间


Panel Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[频道]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class Panel
Visual Basic (Declaration)
Public Class Panel
Visual C++
public ref class Panel

继承层次结构

System..::.Object
WpimSystem.Domain..::.Panel

参见

Panel 成员
WpimSystem.Domain 命名空间


Panel Members

[image] [image]

伟鹏即时通讯Web Service说明文档
Panel 类 构造函数 属性 参见

Panel 类型暴露了以下成员.

构造函数

名称 | 说明
Panel | Initializes a new instance of the Panel class

属性

名称 | 说明
IcoId | IcoId
Id | Id
IsButton | IsButton
Name | Name
Owner | Owner
Uin | Uin
URL | URL

参见

Panel 类
WpimSystem.Domain 命名空间


Panel Constructor

[image]

伟鹏即时通讯Web Service说明文档
Panel 类 参见
Initializes a new instance of the Panel class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public Panel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Panel()

参见

Panel 类
WpimSystem.Domain 命名空间


Panel Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
Panel 类 参见

Panel 类型暴露了以下属性.

属性

名称 | 说明
IcoId | IcoId
Id | Id
IsButton | IsButton
Name | Name
Owner | Owner
Uin | Uin
URL | URL

参见

Panel 类
WpimSystem.Domain 命名空间


IcoId Property

[image]

伟鹏即时通讯Web Service说明文档
Panel 类 参见
IcoId

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string IcoId { get; set; }
Visual Basic (Declaration)
Public Overridable Property IcoId As String
Visual C++
public:
virtual property String^ IcoId {
    String^ get ();
    void set (String^ value);
}

参见

Panel 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
Panel 类 参见
Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

Panel 类
WpimSystem.Domain 命名空间


IsButton Property

[image]

伟鹏即时通讯Web Service说明文档
Panel 类 参见
IsButton

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual bool IsButton { get; set; }
Visual Basic (Declaration)
Public Overridable Property IsButton As Boolean
Visual C++
public:
virtual property bool IsButton {
    bool get ();
    void set (bool value);
}

参见

Panel 类
WpimSystem.Domain 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
Panel 类 参见
Name

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

参见

Panel 类
WpimSystem.Domain 命名空间


Owner Property

[image]

伟鹏即时通讯Web Service说明文档
Panel 类 参见
Owner

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Owner { get; set; }
Visual Basic (Declaration)
Public Overridable Property Owner As Integer
Visual C++
public:
virtual property int Owner {
    int get ();
    void set (int value);
}

参见

Panel 类
WpimSystem.Domain 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
Panel 类 参见
Uin

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As Integer
Visual C++
public:
virtual property int Uin {
    int get ();
    void set (int value);
}

参见

Panel 类
WpimSystem.Domain 命名空间


URL Property

[image]

伟鹏即时通讯Web Service说明文档
Panel 类 参见
URL

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string URL { get; set; }
Visual Basic (Declaration)
Public Overridable Property URL As String
Visual C++
public:
virtual property String^ URL {
    String^ get ();
    void set (String^ value);
}

参见

Panel 类
WpimSystem.Domain 命名空间


TblAdv Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[TblAdv]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class TblAdv
Visual Basic (Declaration)
Public Class TblAdv
Visual C++
public ref class TblAdv

继承层次结构

System..::.Object
WpimSystem.Domain..::.TblAdv

参见

TblAdv 成员
WpimSystem.Domain 命名空间


TblAdv Members

[image] [image]

伟鹏即时通讯Web Service说明文档
TblAdv 类 构造函数 属性 参见

TblAdv 类型暴露了以下成员.

构造函数

名称 | 说明
TblAdv | Initializes a new instance of the TblAdv class

属性

名称 | 说明
AdvID | AdvID
Id | Id
Msg | Msg
SDescription | SDescription
Type | Type

参见

TblAdv 类
WpimSystem.Domain 命名空间


TblAdv Constructor

[image]

伟鹏即时通讯Web Service说明文档
TblAdv 类 参见
Initializes a new instance of the TblAdv class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public TblAdv()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TblAdv()

参见

TblAdv 类
WpimSystem.Domain 命名空间


TblAdv Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
TblAdv 类 参见

TblAdv 类型暴露了以下属性.

属性

名称 | 说明
AdvID | AdvID
Id | Id
Msg | Msg
SDescription | SDescription
Type | Type

参见

TblAdv 类
WpimSystem.Domain 命名空间


AdvID Property

[image]

伟鹏即时通讯Web Service说明文档
TblAdv 类 参见
AdvID

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int AdvID { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdvID As Integer
Visual C++
public:
virtual property int AdvID {
    int get ();
    void set (int value);
}

参见

TblAdv 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
TblAdv 类 参见
Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

TblAdv 类
WpimSystem.Domain 命名空间


Msg Property

[image]

伟鹏即时通讯Web Service说明文档
TblAdv 类 参见
Msg

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Msg { get; set; }
Visual Basic (Declaration)
Public Overridable Property Msg As String
Visual C++
public:
virtual property String^ Msg {
    String^ get ();
    void set (String^ value);
}

参见

TblAdv 类
WpimSystem.Domain 命名空间


SDescription Property

[image]

伟鹏即时通讯Web Service说明文档
TblAdv 类 参见
SDescription

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string SDescription { get; set; }
Visual Basic (Declaration)
Public Overridable Property SDescription As String
Visual C++
public:
virtual property String^ SDescription {
    String^ get ();
    void set (String^ value);
}

参见

TblAdv 类
WpimSystem.Domain 命名空间


Type Property

[image]

伟鹏即时通讯Web Service说明文档
TblAdv 类 参见
Type

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Type { get; set; }
Visual Basic (Declaration)
Public Overridable Property Type As Integer
Visual C++
public:
virtual property int Type {
    int get ();
    void set (int value);
}

参见

TblAdv 类
WpimSystem.Domain 命名空间


UserBrief Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[UserBrief]伟鹏即时通用户简要信息

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
[SerializableAttribute]
public class UserBrief
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class UserBrief
Visual C++
[SerializableAttribute]
public ref class UserBrief

继承层次结构

System..::.Object
WpimSystem.Domain..::.UserBrief

参见

UserBrief 成员
WpimSystem.Domain 命名空间


UserBrief Members

[image] [image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 构造函数 属性 参见

UserBrief 类型暴露了以下成员.

构造函数

名称 | 说明
UserBrief | Initializes a new instance of the UserBrief class

属性

名称 | 说明
Age | 年龄
Answer | 安全问题答案
City | 城市
ClientVer | 客户端版本
CompanyId | 所属公司编号
Country | 国家
DepartmentId | 所属部门编号
Email | 邮件地址
ExpireTime | 过期时间
IconId | 头像编号
Id | Id
IId | 集成其他用户的唯一标识
LastClientType | 最后登录的客户端类型
LastLoginTime | 最后登录时间
LoginTimes | 登录次数
Mobile | 手机
Money | 金额
NeedAuth | 添加好友是否需要验证
NExpireTime | nExpireTime
Nickname | 昵称
OnlineStatus | 在线状态
OnlineTime | 在线时长
Password | 密码
Points | 点
Province | 省份
Question | 安全问题
RegisterTime | nRegisterTime
RegTime | 注册时间
Sex | 性别
Sign | 签名
SmsCount | 短信条数
Uin | 即时通号码
UserName | 用户名
UserStatus | 用户状态
UserType | 用户类型

参见

UserBrief 类
WpimSystem.Domain 命名空间


UserBrief Constructor

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
Initializes a new instance of the UserBrief class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserBrief()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserBrief()

参见

UserBrief 类
WpimSystem.Domain 命名空间


UserBrief Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见

UserBrief 类型暴露了以下属性.

属性

名称 | 说明
Age | 年龄
Answer | 安全问题答案
City | 城市
ClientVer | 客户端版本
CompanyId | 所属公司编号
Country | 国家
DepartmentId | 所属部门编号
Email | 邮件地址
ExpireTime | 过期时间
IconId | 头像编号
Id | Id
IId | 集成其他用户的唯一标识
LastClientType | 最后登录的客户端类型
LastLoginTime | 最后登录时间
LoginTimes | 登录次数
Mobile | 手机
Money | 金额
NeedAuth | 添加好友是否需要验证
NExpireTime | nExpireTime
Nickname | 昵称
OnlineStatus | 在线状态
OnlineTime | 在线时长
Password | 密码
Points | 点
Province | 省份
Question | 安全问题
RegisterTime | nRegisterTime
RegTime | 注册时间
Sex | 性别
Sign | 签名
SmsCount | 短信条数
Uin | 即时通号码
UserName | 用户名
UserStatus | 用户状态
UserType | 用户类型

参见

UserBrief 类
WpimSystem.Domain 命名空间


Age Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
年龄

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Age { get; set; }
Visual Basic (Declaration)
Public Overridable Property Age As Integer
Visual C++
public:
virtual property int Age {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Answer Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
安全问题答案

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Answer { get; set; }
Visual Basic (Declaration)
Public Overridable Property Answer As String
Visual C++
public:
virtual property String^ Answer {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


City Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
城市

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string City { get; set; }
Visual Basic (Declaration)
Public Overridable Property City As String
Visual C++
public:
virtual property String^ City {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


ClientVer Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
客户端版本

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string ClientVer { get; set; }
Visual Basic (Declaration)
Public Property ClientVer As String
Visual C++
public:
property String^ ClientVer {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


CompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
所属公司编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int CompanyId { get; set; }
Visual Basic (Declaration)
Public Property CompanyId As Integer
Visual C++
public:
property int CompanyId {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Country Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
国家

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Country { get; set; }
Visual Basic (Declaration)
Public Overridable Property Country As String
Visual C++
public:
virtual property String^ Country {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


DepartmentId Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
所属部门编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int DepartmentId { get; set; }
Visual Basic (Declaration)
Public Property DepartmentId As Integer
Visual C++
public:
property int DepartmentId {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Email Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
邮件地址

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Email { get; set; }
Visual Basic (Declaration)
Public Overridable Property Email As String
Visual C++
public:
virtual property String^ Email {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


ExpireTime Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
过期时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public Object ExpireTime { get; set; }
Visual Basic (Declaration)
Public Property ExpireTime As Object
Visual C++
public:
property Object^ ExpireTime {
    Object^ get ();
    void set (Object^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


IconId Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
头像编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int IconId { get; set; }
Visual Basic (Declaration)
Public Overridable Property IconId As Integer
Visual C++
public:
virtual property int IconId {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
Id

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


IId Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
集成其他用户的唯一标识

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string IId { get; set; }
Visual Basic (Declaration)
Public Property IId As String
Visual C++
public:
property String^ IId {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


LastClientType Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
最后登录的客户端类型

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int LastClientType { get; set; }
Visual Basic (Declaration)
Public Property LastClientType As Integer
Visual C++
public:
property int LastClientType {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


LastLoginTime Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
最后登录时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime LastLoginTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property LastLoginTime As DateTime
Visual C++
public:
virtual property DateTime LastLoginTime {
    DateTime get ();
    void set (DateTime value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


LoginTimes Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
登录次数

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int LoginTimes { get; set; }
Visual Basic (Declaration)
Public Overridable Property LoginTimes As Integer
Visual C++
public:
virtual property int LoginTimes {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Mobile Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
手机

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Mobile { get; set; }
Visual Basic (Declaration)
Public Overridable Property Mobile As String
Visual C++
public:
virtual property String^ Mobile {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Money Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
金额

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Money { get; set; }
Visual Basic (Declaration)
Public Overridable Property Money As Integer
Visual C++
public:
virtual property int Money {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


NeedAuth Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
添加好友是否需要验证

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int NeedAuth { get; set; }
Visual Basic (Declaration)
Public Overridable Property NeedAuth As Integer
Visual C++
public:
virtual property int NeedAuth {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


NExpireTime Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
nExpireTime

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int NExpireTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property NExpireTime As Integer
Visual C++
public:
virtual property int NExpireTime {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Nickname Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
昵称

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Nickname { get; set; }
Visual Basic (Declaration)
Public Overridable Property Nickname As String
Visual C++
public:
virtual property String^ Nickname {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


OnlineStatus Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
在线状态

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int OnlineStatus { get; set; }
Visual Basic (Declaration)
Public Overridable Property OnlineStatus As Integer
Visual C++
public:
virtual property int OnlineStatus {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


OnlineTime Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
在线时长

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int OnlineTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property OnlineTime As Integer
Visual C++
public:
virtual property int OnlineTime {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Password Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
密码

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Password { get; set; }
Visual Basic (Declaration)
Public Overridable Property Password As String
Visual C++
public:
virtual property String^ Password {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Points Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
点

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Points { get; set; }
Visual Basic (Declaration)
Public Overridable Property Points As Integer
Visual C++
public:
virtual property int Points {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Province Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
省份

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Province { get; set; }
Visual Basic (Declaration)
Public Overridable Property Province As String
Visual C++
public:
virtual property String^ Province {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Question Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
安全问题

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Question { get; set; }
Visual Basic (Declaration)
Public Overridable Property Question As String
Visual C++
public:
virtual property String^ Question {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


RegisterTime Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
nRegisterTime

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int RegisterTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property RegisterTime As Integer
Visual C++
public:
virtual property int RegisterTime {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


RegTime Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
注册时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime RegTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property RegTime As DateTime
Visual C++
public:
virtual property DateTime RegTime {
    DateTime get ();
    void set (DateTime value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Sex Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
性别

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual bool Sex { get; set; }
Visual Basic (Declaration)
Public Overridable Property Sex As Boolean
Visual C++
public:
virtual property bool Sex {
    bool get ();
    void set (bool value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Sign Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
签名

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Sign { get; set; }
Visual Basic (Declaration)
Public Overridable Property Sign As String
Visual C++
public:
virtual property String^ Sign {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


SmsCount Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
短信条数

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int SmsCount { get; set; }
Visual Basic (Declaration)
Public Property SmsCount As Integer
Visual C++
public:
property int SmsCount {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
即时通号码

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As Integer
Visual C++
public:
virtual property int Uin {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


UserName Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
用户名

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string UserName { get; set; }
Visual Basic (Declaration)
Public Overridable Property UserName As String
Visual C++
public:
virtual property String^ UserName {
    String^ get ();
    void set (String^ value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


UserStatus Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
用户状态

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int UserStatus { get; set; }
Visual Basic (Declaration)
Public Overridable Property UserStatus As Integer
Visual C++
public:
virtual property int UserStatus {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


UserType Property

[image]

伟鹏即时通讯Web Service说明文档
UserBrief 类 参见
用户类型

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int UserType { get; set; }
Visual Basic (Declaration)
Public Overridable Property UserType As Integer
Visual C++
public:
virtual property int UserType {
    int get ();
    void set (int value);
}

参见

UserBrief 类
WpimSystem.Domain 命名空间


UserDetail Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[用户详情]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class UserDetail
Visual Basic (Declaration)
Public Class UserDetail
Visual C++
public ref class UserDetail

继承层次结构

System..::.Object
WpimSystem.Domain..::.UserDetail

参见

UserDetail 成员
WpimSystem.Domain 命名空间


UserDetail Members

[image] [image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 构造函数 属性 参见

UserDetail 类型暴露了以下成员.

构造函数

名称 | 说明
UserDetail | Initializes a new instance of the UserDetail class

属性

名称 | 说明
Address | 地址
AnimalSign | 生肖
BloodGroup |
Comment | 个人介绍
Company1 | 公司名1
Company2 | 公司名2
Constellation | 星座
Department | 所在部门
Edu | 学历
Fax | 传真
Hobby | 爱好
Id | 自动编号
IdCard | 身份证
Job | 行业
Mobile | 手机
MSN | Msn
Name | 名字
Picpath | 图片路径
Post | 职位
Postcode | 邮编
Product | 产品
QQ | QQ号
School | 毕业学校
Tel | 电话
Uin | 帐号
WebSite | 主页

参见

UserDetail 类
WpimSystem.Domain 命名空间


UserDetail Constructor

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
Initializes a new instance of the UserDetail class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserDetail()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserDetail()

参见

UserDetail 类
WpimSystem.Domain 命名空间


UserDetail Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见

UserDetail 类型暴露了以下属性.

属性

名称 | 说明
Address | 地址
AnimalSign | 生肖
BloodGroup |
Comment | 个人介绍
Company1 | 公司名1
Company2 | 公司名2
Constellation | 星座
Department | 所在部门
Edu | 学历
Fax | 传真
Hobby | 爱好
Id | 自动编号
IdCard | 身份证
Job | 行业
Mobile | 手机
MSN | Msn
Name | 名字
Picpath | 图片路径
Post | 职位
Postcode | 邮编
Product | 产品
QQ | QQ号
School | 毕业学校
Tel | 电话
Uin | 帐号
WebSite | 主页

参见

UserDetail 类
WpimSystem.Domain 命名空间


Address Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
地址

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Address { get; set; }
Visual Basic (Declaration)
Public Overridable Property Address As String
Visual C++
public:
virtual property String^ Address {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


AnimalSign Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
生肖

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string AnimalSign { get; set; }
Visual Basic (Declaration)
Public Property AnimalSign As String
Visual C++
public:
property String^ AnimalSign {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


BloodGroup Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string BloodGroup { get; set; }
Visual Basic (Declaration)
Public Property BloodGroup As String
Visual C++
public:
property String^ BloodGroup {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Comment Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
个人介绍

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Comment { get; set; }
Visual Basic (Declaration)
Public Overridable Property Comment As String
Visual C++
public:
virtual property String^ Comment {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Company1 Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
公司名1

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Company1 { get; set; }
Visual Basic (Declaration)
Public Overridable Property Company1 As String
Visual C++
public:
virtual property String^ Company1 {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Company2 Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
公司名2

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Company2 { get; set; }
Visual Basic (Declaration)
Public Overridable Property Company2 As String
Visual C++
public:
virtual property String^ Company2 {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Constellation Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
星座

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Constellation { get; set; }
Visual Basic (Declaration)
Public Overridable Property Constellation As String
Visual C++
public:
virtual property String^ Constellation {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Department Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
所在部门

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Department { get; set; }
Visual Basic (Declaration)
Public Overridable Property Department As String
Visual C++
public:
virtual property String^ Department {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Edu Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
学历

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Edu { get; set; }
Visual Basic (Declaration)
Public Overridable Property Edu As String
Visual C++
public:
virtual property String^ Edu {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Fax Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
传真

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Fax { get; set; }
Visual Basic (Declaration)
Public Overridable Property Fax As String
Visual C++
public:
virtual property String^ Fax {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Hobby Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
爱好

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Hobby { get; set; }
Visual Basic (Declaration)
Public Overridable Property Hobby As String
Visual C++
public:
virtual property String^ Hobby {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
自动编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


IdCard Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
身份证

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string IdCard { get; set; }
Visual Basic (Declaration)
Public Overridable Property IdCard As String
Visual C++
public:
virtual property String^ IdCard {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Job Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
行业

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Job { get; set; }
Visual Basic (Declaration)
Public Overridable Property Job As String
Visual C++
public:
virtual property String^ Job {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Mobile Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
手机

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string Mobile { get; set; }
Visual Basic (Declaration)
Public Property Mobile As String
Visual C++
public:
property String^ Mobile {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


MSN Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
Msn

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string MSN { get; set; }
Visual Basic (Declaration)
Public Overridable Property MSN As String
Visual C++
public:
virtual property String^ MSN {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
名字

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Picpath Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
图片路径

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Picpath { get; set; }
Visual Basic (Declaration)
Public Overridable Property Picpath As String
Visual C++
public:
virtual property String^ Picpath {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Post Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
职位

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Post { get; set; }
Visual Basic (Declaration)
Public Overridable Property Post As String
Visual C++
public:
virtual property String^ Post {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Postcode Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
邮编

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Postcode { get; set; }
Visual Basic (Declaration)
Public Overridable Property Postcode As String
Visual C++
public:
virtual property String^ Postcode {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Product Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
产品

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Product { get; set; }
Visual Basic (Declaration)
Public Overridable Property Product As String
Visual C++
public:
virtual property String^ Product {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


QQ Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
QQ号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string QQ { get; set; }
Visual Basic (Declaration)
Public Overridable Property QQ As String
Visual C++
public:
virtual property String^ QQ {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


School Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
毕业学校

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string School { get; set; }
Visual Basic (Declaration)
Public Overridable Property School As String
Visual C++
public:
virtual property String^ School {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Tel Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
电话

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Tel { get; set; }
Visual Basic (Declaration)
Public Overridable Property Tel As String
Visual C++
public:
virtual property String^ Tel {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
帐号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As Integer
Visual C++
public:
virtual property int Uin {
    int get ();
    void set (int value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


WebSite Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetail 类 参见
主页

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string WebSite { get; set; }
Visual Basic (Declaration)
Public Overridable Property WebSite As String
Visual C++
public:
virtual property String^ WebSite {
    String^ get ();
    void set (String^ value);
}

参见

UserDetail 类
WpimSystem.Domain 命名空间


UserFile Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[用户文件]领域类

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class UserFile
Visual Basic (Declaration)
Public Class UserFile
Visual C++
public ref class UserFile

继承层次结构

System..::.Object
WpimSystem.Domain..::.UserFile

参见

UserFile 成员
WpimSystem.Domain 命名空间


UserFile Members

[image] [image]

伟鹏即时通讯Web Service说明文档
UserFile 类 构造函数 属性 参见

UserFile 类型暴露了以下成员.

构造函数

名称 | 说明
UserFile | Initializes a new instance of the UserFile class

属性

名称 | 说明
CreateDate | 创建时间
Expire | 有效期
Extension | 扩展名
Guid | Guid
Id | 自动编号
Name | 文件名称
Size | 文件大小
ToUin | 接收人
Type | 类型
Uin | 号码
Url | 路径

参见

UserFile 类
WpimSystem.Domain 命名空间


UserFile Constructor

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
Initializes a new instance of the UserFile class

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserFile()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserFile()

参见

UserFile 类
WpimSystem.Domain 命名空间


UserFile Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见

UserFile 类型暴露了以下属性.

属性

名称 | 说明
CreateDate | 创建时间
Expire | 有效期
Extension | 扩展名
Guid | Guid
Id | 自动编号
Name | 文件名称
Size | 文件大小
ToUin | 接收人
Type | 类型
Uin | 号码
Url | 路径

参见

UserFile 类
WpimSystem.Domain 命名空间


CreateDate Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
创建时间

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime CreateDate { get; set; }
Visual Basic (Declaration)
Public Overridable Property CreateDate As DateTime
Visual C++
public:
virtual property DateTime CreateDate {
    DateTime get ();
    void set (DateTime value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


Expire Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
有效期

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual DateTime Expire { get; set; }
Visual Basic (Declaration)
Public Overridable Property Expire As DateTime
Visual C++
public:
virtual property DateTime Expire {
    DateTime get ();
    void set (DateTime value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


Extension Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
扩展名

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Extension { get; set; }
Visual Basic (Declaration)
Public Overridable Property Extension As String
Visual C++
public:
virtual property String^ Extension {
    String^ get ();
    void set (String^ value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


Guid Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
Guid

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Guid { get; set; }
Visual Basic (Declaration)
Public Overridable Property Guid As String
Visual C++
public:
virtual property String^ Guid {
    String^ get ();
    void set (String^ value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
自动编号

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As Integer
Visual C++
public:
virtual property int Id {
    int get ();
    void set (int value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
文件名称

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


Size Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
文件大小

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Size { get; set; }
Visual Basic (Declaration)
Public Overridable Property Size As Integer
Visual C++
public:
virtual property int Size {
    int get ();
    void set (int value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


ToUin Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
接收人

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int ToUin { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToUin As Integer
Visual C++
public:
virtual property int ToUin {
    int get ();
    void set (int value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


Type Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
类型

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Type { get; set; }
Visual Basic (Declaration)
Public Overridable Property Type As Integer
Visual C++
public:
virtual property int Type {
    int get ();
    void set (int value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
号码

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual int Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As Integer
Visual C++
public:
virtual property int Uin {
    int get ();
    void set (int value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


Url Property

[image]

伟鹏即时通讯Web Service说明文档
UserFile 类 参见
路径

命名空间： WpimSystem.Domain
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual string Url { get; set; }
Visual Basic (Declaration)
Public Overridable Property Url As String
Visual C++
public:
virtual property String^ Url {
    String^ get ();
    void set (String^ value);
}

参见

UserFile 类
WpimSystem.Domain 命名空间


WpimSystem.Filter Namespace

[image]

伟鹏即时通讯Web Service说明文档

类

类 | 说明
AdFilter | [Ad]过滤类
CommunityFilter | [群组]过滤类
CommunityMemberFilter | [群用户]过滤类
CommunityMsgRecordFilter | [群消息记录]过滤类
CompanyFilter | [公司]过滤类
CompanyGatheringFilter | [企业收款登记]过滤类
DepartmentFilter | [部门]过滤类
EmployeeFilter | [员工]过滤类
LoginRecordFilter | [登录记录]过滤类
MiniNewsFilter | [MiniNews]过滤类
OnlineBroadFilter | [OnlineBroad]过滤类
PanelFilter | [Panel]过滤类
TblAdvFilter | [TblAdv]过滤类
UserBriefFilter | [UserBrief]过滤类
UserDetailFilter | [用户详情]过滤类
UserFileFilter | [用户文件]过滤类


AdFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[Ad]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class AdFilter
Visual Basic (Declaration)
Public Class AdFilter
Visual C++
public ref class AdFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.AdFilter

参见

AdFilter 成员
WpimSystem.Filter 命名空间


AdFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 构造函数 属性 参见

AdFilter 类型暴露了以下成员.

构造函数

名称 | 说明
AdFilter | Initializes a new instance of the AdFilter class

属性

名称 | 说明
AdCreaTime | 创建时间
AdDescription | 广告说明，只用于后台显示
AdEditTime | 编辑时间
AdHttpUrl | 链接地址
AdImgUrl | 图片路径
AdName | 广告名称
AdType | 广告类型
Id | 自动编号
State | 广告状态

参见

AdFilter 类
WpimSystem.Filter 命名空间


AdFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见
Initializes a new instance of the AdFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public AdFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdFilter()

参见

AdFilter 类
WpimSystem.Filter 命名空间


AdFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见

AdFilter 类型暴露了以下属性.

属性

名称 | 说明
AdCreaTime | 创建时间
AdDescription | 广告说明，只用于后台显示
AdEditTime | 编辑时间
AdHttpUrl | 链接地址
AdImgUrl | 图片路径
AdName | 广告名称
AdType | 广告类型
Id | 自动编号
State | 广告状态

参见

AdFilter 类
WpimSystem.Filter 命名空间


AdCreaTime Property

[image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见
创建时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime AdCreaTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdCreaTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ AdCreaTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

AdFilter 类
WpimSystem.Filter 命名空间


AdDescription Property

[image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见
广告说明，只用于后台显示

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar AdDescription { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdDescription As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ AdDescription {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

AdFilter 类
WpimSystem.Filter 命名空间


AdEditTime Property

[image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见
编辑时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime AdEditTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdEditTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ AdEditTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

AdFilter 类
WpimSystem.Filter 命名空间


AdHttpUrl Property

[image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见
链接地址

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar AdHttpUrl { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdHttpUrl As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ AdHttpUrl {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

AdFilter 类
WpimSystem.Filter 命名空间


AdImgUrl Property

[image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见
图片路径

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar AdImgUrl { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdImgUrl As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ AdImgUrl {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

AdFilter 类
WpimSystem.Filter 命名空间


AdName Property

[image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见
广告名称

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar AdName { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdName As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ AdName {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

AdFilter 类
WpimSystem.Filter 命名空间


AdType Property

[image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见
广告类型

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt AdType { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdType As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ AdType {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

AdFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见
自动编号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

AdFilter 类
WpimSystem.Filter 命名空间


State Property

[image]

伟鹏即时通讯Web Service说明文档
AdFilter 类 参见
广告状态

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt State { get; set; }
Visual Basic (Declaration)
Public Overridable Property State As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ State {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

AdFilter 类
WpimSystem.Filter 命名空间


CommunityFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[群组]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class CommunityFilter
Visual Basic (Declaration)
Public Class CommunityFilter
Visual C++
public ref class CommunityFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.CommunityFilter

参见

CommunityFilter 成员
WpimSystem.Filter 命名空间


CommunityFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 构造函数 属性 参见

CommunityFilter 类型暴露了以下成员.

构造函数

名称 | 说明
CommunityFilter | Initializes a new instance of the CommunityFilter class

属性

名称 | 说明
AdminUins | 管理员
BeginTime | 开始日期
Billboard | 公告
CommunityType | 群类型
CreaterUin | 创建人
Descr | 描述
EndTime | 结束日期
Id | Id
MaxMember | 最大用户数
Name | 名称
Password | 密码
Status | 状态

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


CommunityFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
Initializes a new instance of the CommunityFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public CommunityFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CommunityFilter()

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


CommunityFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见

CommunityFilter 类型暴露了以下属性.

属性

名称 | 说明
AdminUins | 管理员
BeginTime | 开始日期
Billboard | 公告
CommunityType | 群类型
CreaterUin | 创建人
Descr | 描述
EndTime | 结束日期
Id | Id
MaxMember | 最大用户数
Name | 名称
Password | 密码
Status | 状态

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


AdminUins Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
管理员

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar AdminUins { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdminUins As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ AdminUins {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


BeginTime Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
开始日期

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime BeginTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property BeginTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ BeginTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


Billboard Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
公告

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Billboard { get; set; }
Visual Basic (Declaration)
Public Overridable Property Billboard As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Billboard {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


CommunityType Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
群类型

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt CommunityType { get; set; }
Visual Basic (Declaration)
Public Overridable Property CommunityType As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ CommunityType {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


CreaterUin Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
创建人

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt CreaterUin { get; set; }
Visual Basic (Declaration)
Public Overridable Property CreaterUin As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ CreaterUin {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


Descr Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
描述

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Descr { get; set; }
Visual Basic (Declaration)
Public Overridable Property Descr As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Descr {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


EndTime Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
结束日期

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime EndTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property EndTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ EndTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
Id

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


MaxMember Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
最大用户数

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt MaxMember { get; set; }
Visual Basic (Declaration)
Public Overridable Property MaxMember As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ MaxMember {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
名称

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Name {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


Password Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
密码

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Password { get; set; }
Visual Basic (Declaration)
Public Overridable Property Password As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Password {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


Status Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityFilter 类 参见
状态

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Status { get; set; }
Visual Basic (Declaration)
Public Overridable Property Status As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Status {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityFilter 类
WpimSystem.Filter 命名空间


CommunityMemberFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[群用户]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class CommunityMemberFilter
Visual Basic (Declaration)
Public Class CommunityMemberFilter
Visual C++
public ref class CommunityMemberFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.CommunityMemberFilter

参见

CommunityMemberFilter 成员
WpimSystem.Filter 命名空间


CommunityMemberFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityMemberFilter 类 构造函数 属性 参见

CommunityMemberFilter 类型暴露了以下成员.

构造函数

名称 | 说明
CommunityMemberFilter | Initializes a new instance of the CommunityMemberFilter class

属性

名称 | 说明
BeginTime | 开始时间
CommunityId | 群Id
EndTime | 结束时间
Id | Id
Status | 状态
Uin | 即时通号

参见

CommunityMemberFilter 类
WpimSystem.Filter 命名空间


CommunityMemberFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
CommunityMemberFilter 类 参见
Initializes a new instance of the CommunityMemberFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public CommunityMemberFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CommunityMemberFilter()

参见

CommunityMemberFilter 类
WpimSystem.Filter 命名空间


CommunityMemberFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityMemberFilter 类 参见

CommunityMemberFilter 类型暴露了以下属性.

属性

名称 | 说明
BeginTime | 开始时间
CommunityId | 群Id
EndTime | 结束时间
Id | Id
Status | 状态
Uin | 即时通号

参见

CommunityMemberFilter 类
WpimSystem.Filter 命名空间


BeginTime Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMemberFilter 类 参见
开始时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime BeginTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property BeginTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ BeginTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

CommunityMemberFilter 类
WpimSystem.Filter 命名空间


CommunityId Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMemberFilter 类 参见
群Id

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt CommunityId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CommunityId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ CommunityId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMemberFilter 类
WpimSystem.Filter 命名空间


EndTime Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMemberFilter 类 参见
结束时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime EndTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property EndTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ EndTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

CommunityMemberFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMemberFilter 类 参见
Id

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMemberFilter 类
WpimSystem.Filter 命名空间


Status Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMemberFilter 类 参见
状态

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Status { get; set; }
Visual Basic (Declaration)
Public Overridable Property Status As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Status {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMemberFilter 类
WpimSystem.Filter 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMemberFilter 类 参见
即时通号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Uin {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMemberFilter 类
WpimSystem.Filter 命名空间


CommunityMsgRecordFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[群消息记录]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class CommunityMsgRecordFilter : BaseFilter
Visual Basic (Declaration)
Public Class CommunityMsgRecordFilter _
    Inherits BaseFilter
Visual C++
public ref class CommunityMsgRecordFilter : public BaseFilter

继承层次结构

System..::.Object
BaseFilter
WpimSystem.Filter..::.CommunityMsgRecordFilter

参见

CommunityMsgRecordFilter 成员
WpimSystem.Filter 命名空间


CommunityMsgRecordFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 构造函数 方法 属性 参见

CommunityMsgRecordFilter 类型暴露了以下成员.

构造函数

名称 | 说明
CommunityMsgRecordFilter | Initializes a new instance of the CommunityMsgRecordFilter class

方法

名称 | 说明
AddSqlWhere | (从BaseFilter继承。)
GetAppendSqlWhere | (从BaseFilter继承。)

属性

名称 | 说明
AtTime | 时间
CommunityId | 群Id
CommunityType | 群类别
FromUin | 发送人即时通号码
FromUserCompanyId | 发送用户公司Id
FromUserIp | 发送人IP
FromUserNickname | 发送人昵称
Id | 自动编号
IsFromGuest | 是否来源于访客
Msg | 消息内容
ToUin | 接收人即时通号
ToUserCompanyId | 接收用户公司Id
ToUserIp | 接收人IP
ToUserNickname | 接收人昵称

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


CommunityMsgRecordFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
Initializes a new instance of the CommunityMsgRecordFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public CommunityMsgRecordFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CommunityMsgRecordFilter()

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


CommunityMsgRecordFilter Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见

CommunityMsgRecordFilter 类型暴露了以下方法.

方法

名称 | 说明
AddSqlWhere | (从BaseFilter继承。)
GetAppendSqlWhere | (从BaseFilter继承。)

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


CommunityMsgRecordFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见

CommunityMsgRecordFilter 类型暴露了以下属性.

属性

名称 | 说明
AtTime | 时间
CommunityId | 群Id
CommunityType | 群类别
FromUin | 发送人即时通号码
FromUserCompanyId | 发送用户公司Id
FromUserIp | 发送人IP
FromUserNickname | 发送人昵称
Id | 自动编号
IsFromGuest | 是否来源于访客
Msg | 消息内容
ToUin | 接收人即时通号
ToUserCompanyId | 接收用户公司Id
ToUserIp | 接收人IP
ToUserNickname | 接收人昵称

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


AtTime Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime AtTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property AtTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ AtTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


CommunityId Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
群Id

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt CommunityId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CommunityId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ CommunityId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


CommunityType Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
群类别

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt CommunityType { get; set; }
Visual Basic (Declaration)
Public Overridable Property CommunityType As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ CommunityType {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


FromUin Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
发送人即时通号码

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt FromUin { get; set; }
Visual Basic (Declaration)
Public Overridable Property FromUin As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ FromUin {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


FromUserCompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
发送用户公司Id

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt FromUserCompanyId { get; set; }
Visual Basic (Declaration)
Public Overridable Property FromUserCompanyId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ FromUserCompanyId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


FromUserIp Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
发送人IP

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar FromUserIp { get; set; }
Visual Basic (Declaration)
Public Overridable Property FromUserIp As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ FromUserIp {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


FromUserNickname Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
发送人昵称

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar FromUserNickname { get; set; }
Visual Basic (Declaration)
Public Overridable Property FromUserNickname As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ FromUserNickname {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
自动编号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


IsFromGuest Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
是否来源于访客

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereBool IsFromGuest { get; set; }
Visual Basic (Declaration)
Public Overridable Property IsFromGuest As SqlWhereBool
Visual C++
public:
virtual property SqlWhereBool^ IsFromGuest {
    SqlWhereBool^ get ();
    void set (SqlWhereBool^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


Msg Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
消息内容

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Msg { get; set; }
Visual Basic (Declaration)
Public Overridable Property Msg As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Msg {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


ToUin Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
接收人即时通号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt ToUin { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToUin As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ ToUin {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


ToUserCompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
接收用户公司Id

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt ToUserCompanyId { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToUserCompanyId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ ToUserCompanyId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


ToUserIp Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
接收人IP

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar ToUserIp { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToUserIp As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ ToUserIp {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


ToUserNickname Property

[image]

伟鹏即时通讯Web Service说明文档
CommunityMsgRecordFilter 类 参见
接收人昵称

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar ToUserNickname { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToUserNickname As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ ToUserNickname {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CommunityMsgRecordFilter 类
WpimSystem.Filter 命名空间


CompanyFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[公司]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class CompanyFilter : BaseFilter
Visual Basic (Declaration)
Public Class CompanyFilter _
    Inherits BaseFilter
Visual C++
public ref class CompanyFilter : public BaseFilter

继承层次结构

System..::.Object
BaseFilter
WpimSystem.Filter..::.CompanyFilter

参见

CompanyFilter 成员
WpimSystem.Filter 命名空间


CompanyFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 构造函数 方法 属性 参见

CompanyFilter 类型暴露了以下成员.

构造函数

名称 | 说明
CompanyFilter | Initializes a new instance of the CompanyFilter class

方法

名称 | 说明
AddSqlWhere | (从BaseFilter继承。)
GetAppendSqlWhere | (从BaseFilter继承。)

属性

名称 | 说明
Account | 帐号
City | 城市
CommunityId | 状态
Country | 国家
CreateTime | 创建时间
Email | 电子邮件
EmployeeLimitNumber | 职员限制数
Fax | 传真
Id | Id
License | 执照编号
LicenseImage | 执照照片
Linkman | 联系人
Mobile | 手机
MSN | MSN
Name | 名称
Password | 密码
Province | 省份
QQ | QQ
Status | 状态
Tel | 电话
Web | 网站

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


CompanyFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
Initializes a new instance of the CompanyFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public CompanyFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompanyFilter()

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


CompanyFilter Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见

CompanyFilter 类型暴露了以下方法.

方法

名称 | 说明
AddSqlWhere | (从BaseFilter继承。)
GetAppendSqlWhere | (从BaseFilter继承。)

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


CompanyFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见

CompanyFilter 类型暴露了以下属性.

属性

名称 | 说明
Account | 帐号
City | 城市
CommunityId | 状态
Country | 国家
CreateTime | 创建时间
Email | 电子邮件
EmployeeLimitNumber | 职员限制数
Fax | 传真
Id | Id
License | 执照编号
LicenseImage | 执照照片
Linkman | 联系人
Mobile | 手机
MSN | MSN
Name | 名称
Password | 密码
Province | 省份
QQ | QQ
Status | 状态
Tel | 电话
Web | 网站

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Account Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
帐号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Account { get; set; }
Visual Basic (Declaration)
Public Overridable Property Account As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Account {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


City Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
城市

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar City { get; set; }
Visual Basic (Declaration)
Public Overridable Property City As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ City {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


CommunityId Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
状态

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt CommunityId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CommunityId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ CommunityId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Country Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
国家

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Country { get; set; }
Visual Basic (Declaration)
Public Overridable Property Country As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Country {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


CreateTime Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
创建时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime CreateTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property CreateTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ CreateTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Email Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
电子邮件

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Email { get; set; }
Visual Basic (Declaration)
Public Overridable Property Email As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Email {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


EmployeeLimitNumber Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
职员限制数

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt EmployeeLimitNumber { get; set; }
Visual Basic (Declaration)
Public Overridable Property EmployeeLimitNumber As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ EmployeeLimitNumber {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Fax Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
传真

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Fax { get; set; }
Visual Basic (Declaration)
Public Overridable Property Fax As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Fax {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
Id

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


License Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
执照编号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar License { get; set; }
Visual Basic (Declaration)
Public Overridable Property License As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ License {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


LicenseImage Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
执照照片

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar LicenseImage { get; set; }
Visual Basic (Declaration)
Public Overridable Property LicenseImage As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ LicenseImage {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Linkman Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
联系人

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Linkman { get; set; }
Visual Basic (Declaration)
Public Overridable Property Linkman As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Linkman {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Mobile Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
手机

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Mobile { get; set; }
Visual Basic (Declaration)
Public Overridable Property Mobile As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Mobile {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


MSN Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
MSN

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar MSN { get; set; }
Visual Basic (Declaration)
Public Overridable Property MSN As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ MSN {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
名称

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Name {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Password Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
密码

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Password { get; set; }
Visual Basic (Declaration)
Public Overridable Property Password As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Password {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Province Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
省份

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Province { get; set; }
Visual Basic (Declaration)
Public Overridable Property Province As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Province {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


QQ Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
QQ

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar QQ { get; set; }
Visual Basic (Declaration)
Public Overridable Property QQ As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ QQ {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Status Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
状态

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Status { get; set; }
Visual Basic (Declaration)
Public Overridable Property Status As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Status {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Tel Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
电话

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Tel { get; set; }
Visual Basic (Declaration)
Public Overridable Property Tel As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Tel {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


Web Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyFilter 类 参见
网站

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Web { get; set; }
Visual Basic (Declaration)
Public Overridable Property Web As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Web {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyFilter 类
WpimSystem.Filter 命名空间


CompanyGatheringFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[企业收款登记]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class CompanyGatheringFilter
Visual Basic (Declaration)
Public Class CompanyGatheringFilter
Visual C++
public ref class CompanyGatheringFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.CompanyGatheringFilter

参见

CompanyGatheringFilter 成员
WpimSystem.Filter 命名空间


CompanyGatheringFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 构造函数 属性 参见

CompanyGatheringFilter 类型暴露了以下成员.

构造函数

名称 | 说明
CompanyGatheringFilter | Initializes a new instance of the CompanyGatheringFilter class

属性

名称 | 说明
CompanyAccount | 企业帐号
CompanyId | 企业ID
Id | 自动编号
InputTime | 记帐日期
ModifTime | 修改时间
Modifyer | 修改人
Money | 金额
Payee | 收款人
PayeeAccount | 收款帐号
PayeeBank | 收款银行
PayeeTime | 收款日期
Payer | 付款人
PayerAccount | 付款帐号
PayerBank | 付款银行
PaymentMethod | 收款方式
Recorder | 记帐人
Rmark | 备注
Summary | 收款摘要

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


CompanyGatheringFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
Initializes a new instance of the CompanyGatheringFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public CompanyGatheringFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompanyGatheringFilter()

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


CompanyGatheringFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见

CompanyGatheringFilter 类型暴露了以下属性.

属性

名称 | 说明
CompanyAccount | 企业帐号
CompanyId | 企业ID
Id | 自动编号
InputTime | 记帐日期
ModifTime | 修改时间
Modifyer | 修改人
Money | 金额
Payee | 收款人
PayeeAccount | 收款帐号
PayeeBank | 收款银行
PayeeTime | 收款日期
Payer | 付款人
PayerAccount | 付款帐号
PayerBank | 付款银行
PaymentMethod | 收款方式
Recorder | 记帐人
Rmark | 备注
Summary | 收款摘要

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


CompanyAccount Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
企业帐号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar CompanyAccount { get; set; }
Visual Basic (Declaration)
Public Overridable Property CompanyAccount As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ CompanyAccount {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


CompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
企业ID

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt CompanyId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CompanyId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ CompanyId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
自动编号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


InputTime Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
记帐日期

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime InputTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property InputTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ InputTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


ModifTime Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
修改时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime ModifTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property ModifTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ ModifTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


Modifyer Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
修改人

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Modifyer { get; set; }
Visual Basic (Declaration)
Public Overridable Property Modifyer As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Modifyer {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


Money Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
金额

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Money { get; set; }
Visual Basic (Declaration)
Public Overridable Property Money As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Money {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


Payee Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
收款人

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Payee { get; set; }
Visual Basic (Declaration)
Public Overridable Property Payee As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Payee {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


PayeeAccount Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
收款帐号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar PayeeAccount { get; set; }
Visual Basic (Declaration)
Public Overridable Property PayeeAccount As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ PayeeAccount {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


PayeeBank Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
收款银行

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar PayeeBank { get; set; }
Visual Basic (Declaration)
Public Overridable Property PayeeBank As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ PayeeBank {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


PayeeTime Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
收款日期

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime PayeeTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property PayeeTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ PayeeTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


Payer Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
付款人

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Payer { get; set; }
Visual Basic (Declaration)
Public Overridable Property Payer As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Payer {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


PayerAccount Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
付款帐号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar PayerAccount { get; set; }
Visual Basic (Declaration)
Public Overridable Property PayerAccount As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ PayerAccount {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


PayerBank Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
付款银行

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar PayerBank { get; set; }
Visual Basic (Declaration)
Public Overridable Property PayerBank As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ PayerBank {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


PaymentMethod Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
收款方式

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar PaymentMethod { get; set; }
Visual Basic (Declaration)
Public Overridable Property PaymentMethod As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ PaymentMethod {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


Recorder Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
记帐人

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Recorder { get; set; }
Visual Basic (Declaration)
Public Overridable Property Recorder As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Recorder {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


Rmark Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
备注

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Rmark { get; set; }
Visual Basic (Declaration)
Public Overridable Property Rmark As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Rmark {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


Summary Property

[image]

伟鹏即时通讯Web Service说明文档
CompanyGatheringFilter 类 参见
收款摘要

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Summary { get; set; }
Visual Basic (Declaration)
Public Overridable Property Summary As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Summary {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

CompanyGatheringFilter 类
WpimSystem.Filter 命名空间


DepartmentFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[部门]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class DepartmentFilter
Visual Basic (Declaration)
Public Class DepartmentFilter
Visual C++
public ref class DepartmentFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.DepartmentFilter

参见

DepartmentFilter 成员
WpimSystem.Filter 命名空间


DepartmentFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
DepartmentFilter 类 构造函数 属性 参见

DepartmentFilter 类型暴露了以下成员.

构造函数

名称 | 说明
DepartmentFilter | Initializes a new instance of the DepartmentFilter class

属性

名称 | 说明
CompanyId | CompanyId
Id | 自动编号
Name | 名称
Ordering | 排序
ParentId | 上级部门

参见

DepartmentFilter 类
WpimSystem.Filter 命名空间


DepartmentFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
DepartmentFilter 类 参见
Initializes a new instance of the DepartmentFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public DepartmentFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DepartmentFilter()

参见

DepartmentFilter 类
WpimSystem.Filter 命名空间


DepartmentFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
DepartmentFilter 类 参见

DepartmentFilter 类型暴露了以下属性.

属性

名称 | 说明
CompanyId | CompanyId
Id | 自动编号
Name | 名称
Ordering | 排序
ParentId | 上级部门

参见

DepartmentFilter 类
WpimSystem.Filter 命名空间


CompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
DepartmentFilter 类 参见
CompanyId

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt CompanyId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CompanyId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ CompanyId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

DepartmentFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
DepartmentFilter 类 参见
自动编号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

DepartmentFilter 类
WpimSystem.Filter 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
DepartmentFilter 类 参见
名称

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Name {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

DepartmentFilter 类
WpimSystem.Filter 命名空间


Ordering Property

[image]

伟鹏即时通讯Web Service说明文档
DepartmentFilter 类 参见
排序

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Ordering { get; set; }
Visual Basic (Declaration)
Public Overridable Property Ordering As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Ordering {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

DepartmentFilter 类
WpimSystem.Filter 命名空间


ParentId Property

[image]

伟鹏即时通讯Web Service说明文档
DepartmentFilter 类 参见
上级部门

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt ParentId { get; set; }
Visual Basic (Declaration)
Public Overridable Property ParentId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ ParentId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

DepartmentFilter 类
WpimSystem.Filter 命名空间


EmployeeFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[员工]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class EmployeeFilter
Visual Basic (Declaration)
Public Class EmployeeFilter
Visual C++
public ref class EmployeeFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.EmployeeFilter

参见

EmployeeFilter 成员
WpimSystem.Filter 命名空间


EmployeeFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 构造函数 属性 参见

EmployeeFilter 类型暴露了以下成员.

构造函数

名称 | 说明
EmployeeFilter | Initializes a new instance of the EmployeeFilter class

属性

名称 | 说明
Company | 公司名称
CompanyId | 所属公司
CreateTime | 创建时间
GroupIds | 加入的群组
Id | Id
Name | 姓名
Status | 状态
Uin | 即时通号

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


EmployeeFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 参见
Initializes a new instance of the EmployeeFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public EmployeeFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EmployeeFilter()

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


EmployeeFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 参见

EmployeeFilter 类型暴露了以下属性.

属性

名称 | 说明
Company | 公司名称
CompanyId | 所属公司
CreateTime | 创建时间
GroupIds | 加入的群组
Id | Id
Name | 姓名
Status | 状态
Uin | 即时通号

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


Company Property

[image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 参见
公司名称

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Company { get; set; }
Visual Basic (Declaration)
Public Overridable Property Company As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Company {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


CompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 参见
所属公司

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt CompanyId { get; set; }
Visual Basic (Declaration)
Public Overridable Property CompanyId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ CompanyId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


CreateTime Property

[image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 参见
创建时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime CreateTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property CreateTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ CreateTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


GroupIds Property

[image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 参见
加入的群组

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar GroupIds { get; set; }
Visual Basic (Declaration)
Public Overridable Property GroupIds As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ GroupIds {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 参见
Id

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 参见
姓名

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Name {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


Status Property

[image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 参见
状态

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Status { get; set; }
Visual Basic (Declaration)
Public Overridable Property Status As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Status {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
EmployeeFilter 类 参见
即时通号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Uin {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

EmployeeFilter 类
WpimSystem.Filter 命名空间


LoginRecordFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[登录记录]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class LoginRecordFilter
Visual Basic (Declaration)
Public Class LoginRecordFilter
Visual C++
public ref class LoginRecordFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.LoginRecordFilter

参见

LoginRecordFilter 成员
WpimSystem.Filter 命名空间


LoginRecordFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
LoginRecordFilter 类 构造函数 属性 参见

LoginRecordFilter 类型暴露了以下成员.

构造函数

名称 | 说明
LoginRecordFilter | Initializes a new instance of the LoginRecordFilter class

属性

名称 | 说明
ClientType | 客户端类型
Id | 自动编号
IP | 登录IP
LoginTime | 登录时间
OnlineStatus | 连线状态
Uin | 即时通号
UserCompanyId | 用户所属公司

参见

LoginRecordFilter 类
WpimSystem.Filter 命名空间


LoginRecordFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
LoginRecordFilter 类 参见
Initializes a new instance of the LoginRecordFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public LoginRecordFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LoginRecordFilter()

参见

LoginRecordFilter 类
WpimSystem.Filter 命名空间


LoginRecordFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
LoginRecordFilter 类 参见

LoginRecordFilter 类型暴露了以下属性.

属性

名称 | 说明
ClientType | 客户端类型
Id | 自动编号
IP | 登录IP
LoginTime | 登录时间
OnlineStatus | 连线状态
Uin | 即时通号
UserCompanyId | 用户所属公司

参见

LoginRecordFilter 类
WpimSystem.Filter 命名空间


ClientType Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecordFilter 类 参见
客户端类型

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt ClientType { get; set; }
Visual Basic (Declaration)
Public Overridable Property ClientType As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ ClientType {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

LoginRecordFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecordFilter 类 参见
自动编号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

LoginRecordFilter 类
WpimSystem.Filter 命名空间


IP Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecordFilter 类 参见
登录IP

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar IP { get; set; }
Visual Basic (Declaration)
Public Overridable Property IP As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ IP {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

LoginRecordFilter 类
WpimSystem.Filter 命名空间


LoginTime Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecordFilter 类 参见
登录时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime LoginTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property LoginTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ LoginTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

LoginRecordFilter 类
WpimSystem.Filter 命名空间


OnlineStatus Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecordFilter 类 参见
连线状态

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt OnlineStatus { get; set; }
Visual Basic (Declaration)
Public Overridable Property OnlineStatus As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ OnlineStatus {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

LoginRecordFilter 类
WpimSystem.Filter 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecordFilter 类 参见
即时通号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Uin {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

LoginRecordFilter 类
WpimSystem.Filter 命名空间


UserCompanyId Property

[image]

伟鹏即时通讯Web Service说明文档
LoginRecordFilter 类 参见
用户所属公司

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt UserCompanyId { get; set; }
Visual Basic (Declaration)
Public Overridable Property UserCompanyId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ UserCompanyId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

LoginRecordFilter 类
WpimSystem.Filter 命名空间


MiniNewsFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[MiniNews]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class MiniNewsFilter
Visual Basic (Declaration)
Public Class MiniNewsFilter
Visual C++
public ref class MiniNewsFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.MiniNewsFilter

参见

MiniNewsFilter 成员
WpimSystem.Filter 命名空间


MiniNewsFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
MiniNewsFilter 类 构造函数 属性 参见

MiniNewsFilter 类型暴露了以下成员.

构造函数

名称 | 说明
MiniNewsFilter | Initializes a new instance of the MiniNewsFilter class

属性

名称 | 说明
Id | 编号
State | 状态
Text | 内容
Title | 标题

参见

MiniNewsFilter 类
WpimSystem.Filter 命名空间


MiniNewsFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
MiniNewsFilter 类 参见
Initializes a new instance of the MiniNewsFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public MiniNewsFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MiniNewsFilter()

参见

MiniNewsFilter 类
WpimSystem.Filter 命名空间


MiniNewsFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
MiniNewsFilter 类 参见

MiniNewsFilter 类型暴露了以下属性.

属性

名称 | 说明
Id | 编号
State | 状态
Text | 内容
Title | 标题

参见

MiniNewsFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
MiniNewsFilter 类 参见
编号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

MiniNewsFilter 类
WpimSystem.Filter 命名空间


State Property

[image]

伟鹏即时通讯Web Service说明文档
MiniNewsFilter 类 参见
状态

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt State { get; set; }
Visual Basic (Declaration)
Public Overridable Property State As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ State {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

MiniNewsFilter 类
WpimSystem.Filter 命名空间


Text Property

[image]

伟鹏即时通讯Web Service说明文档
MiniNewsFilter 类 参见
内容

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Text { get; set; }
Visual Basic (Declaration)
Public Overridable Property Text As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Text {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

MiniNewsFilter 类
WpimSystem.Filter 命名空间


Title Property

[image]

伟鹏即时通讯Web Service说明文档
MiniNewsFilter 类 参见
标题

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Title { get; set; }
Visual Basic (Declaration)
Public Overridable Property Title As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Title {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

MiniNewsFilter 类
WpimSystem.Filter 命名空间


OnlineBroadFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[OnlineBroad]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class OnlineBroadFilter
Visual Basic (Declaration)
Public Class OnlineBroadFilter
Visual C++
public ref class OnlineBroadFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.OnlineBroadFilter

参见

OnlineBroadFilter 成员
WpimSystem.Filter 命名空间


OnlineBroadFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 构造函数 属性 参见

OnlineBroadFilter 类型暴露了以下成员.

构造函数

名称 | 说明
OnlineBroadFilter | Initializes a new instance of the OnlineBroadFilter class

属性

名称 | 说明
AddTime | 添加时间
Author | 发由作者
Content | 广播内容
Id | 编号
StartTime | 开始时间
StopTime | 结束时间
Summary | 摘要
Title | 广播标题
UserId | 管理员iD

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


OnlineBroadFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见
Initializes a new instance of the OnlineBroadFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public OnlineBroadFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OnlineBroadFilter()

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


OnlineBroadFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见

OnlineBroadFilter 类型暴露了以下属性.

属性

名称 | 说明
AddTime | 添加时间
Author | 发由作者
Content | 广播内容
Id | 编号
StartTime | 开始时间
StopTime | 结束时间
Summary | 摘要
Title | 广播标题
UserId | 管理员iD

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


AddTime Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见
添加时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime AddTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property AddTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ AddTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


Author Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见
发由作者

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Author { get; set; }
Visual Basic (Declaration)
Public Overridable Property Author As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Author {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


Content Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见
广播内容

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Content { get; set; }
Visual Basic (Declaration)
Public Overridable Property Content As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Content {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见
编号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


StartTime Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见
开始时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime StartTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property StartTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ StartTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


StopTime Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见
结束时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime StopTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property StopTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ StopTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


Summary Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见
摘要

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Summary { get; set; }
Visual Basic (Declaration)
Public Overridable Property Summary As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Summary {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


Title Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见
广播标题

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Title { get; set; }
Visual Basic (Declaration)
Public Overridable Property Title As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Title {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


UserId Property

[image]

伟鹏即时通讯Web Service说明文档
OnlineBroadFilter 类 参见
管理员iD

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar UserId { get; set; }
Visual Basic (Declaration)
Public Overridable Property UserId As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ UserId {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

OnlineBroadFilter 类
WpimSystem.Filter 命名空间


PanelFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[Panel]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class PanelFilter
Visual Basic (Declaration)
Public Class PanelFilter
Visual C++
public ref class PanelFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.PanelFilter

参见

PanelFilter 成员
WpimSystem.Filter 命名空间


PanelFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
PanelFilter 类 构造函数 属性 参见

PanelFilter 类型暴露了以下成员.

构造函数

名称 | 说明
PanelFilter | Initializes a new instance of the PanelFilter class

属性

名称 | 说明
IcoId | IcoId
Id | Id
IsButton | IsButton
Name | Name
Owner | Owner
Uin | Uin
URL | URL

参见

PanelFilter 类
WpimSystem.Filter 命名空间


PanelFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
PanelFilter 类 参见
Initializes a new instance of the PanelFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public PanelFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PanelFilter()

参见

PanelFilter 类
WpimSystem.Filter 命名空间


PanelFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
PanelFilter 类 参见

PanelFilter 类型暴露了以下属性.

属性

名称 | 说明
IcoId | IcoId
Id | Id
IsButton | IsButton
Name | Name
Owner | Owner
Uin | Uin
URL | URL

参见

PanelFilter 类
WpimSystem.Filter 命名空间


IcoId Property

[image]

伟鹏即时通讯Web Service说明文档
PanelFilter 类 参见
IcoId

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar IcoId { get; set; }
Visual Basic (Declaration)
Public Overridable Property IcoId As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ IcoId {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

PanelFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
PanelFilter 类 参见
Id

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

PanelFilter 类
WpimSystem.Filter 命名空间


IsButton Property

[image]

伟鹏即时通讯Web Service说明文档
PanelFilter 类 参见
IsButton

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereBool IsButton { get; set; }
Visual Basic (Declaration)
Public Overridable Property IsButton As SqlWhereBool
Visual C++
public:
virtual property SqlWhereBool^ IsButton {
    SqlWhereBool^ get ();
    void set (SqlWhereBool^ value);
}

参见

PanelFilter 类
WpimSystem.Filter 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
PanelFilter 类 参见
Name

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Name {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

PanelFilter 类
WpimSystem.Filter 命名空间


Owner Property

[image]

伟鹏即时通讯Web Service说明文档
PanelFilter 类 参见
Owner

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Owner { get; set; }
Visual Basic (Declaration)
Public Overridable Property Owner As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Owner {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

PanelFilter 类
WpimSystem.Filter 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
PanelFilter 类 参见
Uin

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Uin {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

PanelFilter 类
WpimSystem.Filter 命名空间


URL Property

[image]

伟鹏即时通讯Web Service说明文档
PanelFilter 类 参见
URL

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar URL { get; set; }
Visual Basic (Declaration)
Public Overridable Property URL As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ URL {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

PanelFilter 类
WpimSystem.Filter 命名空间


TblAdvFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[TblAdv]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class TblAdvFilter
Visual Basic (Declaration)
Public Class TblAdvFilter
Visual C++
public ref class TblAdvFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.TblAdvFilter

参见

TblAdvFilter 成员
WpimSystem.Filter 命名空间


TblAdvFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
TblAdvFilter 类 构造函数 属性 参见

TblAdvFilter 类型暴露了以下成员.

构造函数

名称 | 说明
TblAdvFilter | Initializes a new instance of the TblAdvFilter class

属性

名称 | 说明
AdvID | AdvID
Id | Id
Msg | Msg
SDescription | SDescription
Type | Type

参见

TblAdvFilter 类
WpimSystem.Filter 命名空间


TblAdvFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
TblAdvFilter 类 参见
Initializes a new instance of the TblAdvFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public TblAdvFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TblAdvFilter()

参见

TblAdvFilter 类
WpimSystem.Filter 命名空间


TblAdvFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
TblAdvFilter 类 参见

TblAdvFilter 类型暴露了以下属性.

属性

名称 | 说明
AdvID | AdvID
Id | Id
Msg | Msg
SDescription | SDescription
Type | Type

参见

TblAdvFilter 类
WpimSystem.Filter 命名空间


AdvID Property

[image]

伟鹏即时通讯Web Service说明文档
TblAdvFilter 类 参见
AdvID

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt AdvID { get; set; }
Visual Basic (Declaration)
Public Overridable Property AdvID As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ AdvID {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

TblAdvFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
TblAdvFilter 类 参见
Id

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

TblAdvFilter 类
WpimSystem.Filter 命名空间


Msg Property

[image]

伟鹏即时通讯Web Service说明文档
TblAdvFilter 类 参见
Msg

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Msg { get; set; }
Visual Basic (Declaration)
Public Overridable Property Msg As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Msg {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

TblAdvFilter 类
WpimSystem.Filter 命名空间


SDescription Property

[image]

伟鹏即时通讯Web Service说明文档
TblAdvFilter 类 参见
SDescription

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar SDescription { get; set; }
Visual Basic (Declaration)
Public Overridable Property SDescription As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ SDescription {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

TblAdvFilter 类
WpimSystem.Filter 命名空间


Type Property

[image]

伟鹏即时通讯Web Service说明文档
TblAdvFilter 类 参见
Type

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Type { get; set; }
Visual Basic (Declaration)
Public Overridable Property Type As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Type {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

TblAdvFilter 类
WpimSystem.Filter 命名空间


UserBriefFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[UserBrief]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class UserBriefFilter
Visual Basic (Declaration)
Public Class UserBriefFilter
Visual C++
public ref class UserBriefFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.UserBriefFilter

参见

UserBriefFilter 成员
WpimSystem.Filter 命名空间


UserBriefFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 构造函数 属性 参见

UserBriefFilter 类型暴露了以下成员.

构造函数

名称 | 说明
UserBriefFilter | Initializes a new instance of the UserBriefFilter class

属性

名称 | 说明
Age | Age
Answer | Answer
City | City
ClientVer | ClientVer
Country | Country
Email | Email
ExpireTime | ExpireTime
IconId | IconId
ID | ID
IId | Password
LastLoginTime | LastLoginTime
LoginTimes | LoginTimes
Mobile | Mobile
NeedAuth | NeedAuth
Nickname | Nickname
OnlineStatus | OnlineStatus
OnlineTime | OnlineTime
Password | Password
Points | Points
Province | Province
Question | Question
RegTime | RegTime
Sex | Sex
Sign | Sign
SmsCount | SmsCount
UIN | UIN
UserName | UserName
UserStatus | UserStatus
UserType | UserType

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


UserBriefFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Initializes a new instance of the UserBriefFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserBriefFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserBriefFilter()

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


UserBriefFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见

UserBriefFilter 类型暴露了以下属性.

属性

名称 | 说明
Age | Age
Answer | Answer
City | City
ClientVer | ClientVer
Country | Country
Email | Email
ExpireTime | ExpireTime
IconId | IconId
ID | ID
IId | Password
LastLoginTime | LastLoginTime
LoginTimes | LoginTimes
Mobile | Mobile
NeedAuth | NeedAuth
Nickname | Nickname
OnlineStatus | OnlineStatus
OnlineTime | OnlineTime
Password | Password
Points | Points
Province | Province
Question | Question
RegTime | RegTime
Sex | Sex
Sign | Sign
SmsCount | SmsCount
UIN | UIN
UserName | UserName
UserStatus | UserStatus
UserType | UserType

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Age Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Age

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Age { get; set; }
Visual Basic (Declaration)
Public Overridable Property Age As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Age {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Answer Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Answer

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Answer { get; set; }
Visual Basic (Declaration)
Public Overridable Property Answer As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Answer {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


City Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
City

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar City { get; set; }
Visual Basic (Declaration)
Public Overridable Property City As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ City {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


ClientVer Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
ClientVer

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar ClientVer { get; set; }
Visual Basic (Declaration)
Public Overridable Property ClientVer As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ ClientVer {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Country Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Country

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Country { get; set; }
Visual Basic (Declaration)
Public Overridable Property Country As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Country {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Email Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Email

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Email { get; set; }
Visual Basic (Declaration)
Public Overridable Property Email As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Email {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


ExpireTime Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
ExpireTime

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt ExpireTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property ExpireTime As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ ExpireTime {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


IconId Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
IconId

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt IconId { get; set; }
Visual Basic (Declaration)
Public Overridable Property IconId As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ IconId {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


ID Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
ID

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt ID { get; set; }
Visual Basic (Declaration)
Public Overridable Property ID As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ ID {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


IId Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Password

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar IId { get; set; }
Visual Basic (Declaration)
Public Overridable Property IId As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ IId {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


LastLoginTime Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
LastLoginTime

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime LastLoginTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property LastLoginTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ LastLoginTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


LoginTimes Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
LoginTimes

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt LoginTimes { get; set; }
Visual Basic (Declaration)
Public Overridable Property LoginTimes As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ LoginTimes {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Mobile Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Mobile

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Mobile { get; set; }
Visual Basic (Declaration)
Public Overridable Property Mobile As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Mobile {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


NeedAuth Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
NeedAuth

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt NeedAuth { get; set; }
Visual Basic (Declaration)
Public Overridable Property NeedAuth As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ NeedAuth {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Nickname Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Nickname

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Nickname { get; set; }
Visual Basic (Declaration)
Public Overridable Property Nickname As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Nickname {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


OnlineStatus Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
OnlineStatus

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt OnlineStatus { get; set; }
Visual Basic (Declaration)
Public Overridable Property OnlineStatus As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ OnlineStatus {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


OnlineTime Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
OnlineTime

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt OnlineTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property OnlineTime As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ OnlineTime {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Password Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Password

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Password { get; set; }
Visual Basic (Declaration)
Public Overridable Property Password As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Password {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Points Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Points

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Points { get; set; }
Visual Basic (Declaration)
Public Overridable Property Points As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Points {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Province Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Province

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Province { get; set; }
Visual Basic (Declaration)
Public Overridable Property Province As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Province {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Question Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Question

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Question { get; set; }
Visual Basic (Declaration)
Public Overridable Property Question As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Question {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


RegTime Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
RegTime

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime RegTime { get; set; }
Visual Basic (Declaration)
Public Overridable Property RegTime As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ RegTime {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Sex Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Sex

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereBool Sex { get; set; }
Visual Basic (Declaration)
Public Overridable Property Sex As SqlWhereBool
Visual C++
public:
virtual property SqlWhereBool^ Sex {
    SqlWhereBool^ get ();
    void set (SqlWhereBool^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


Sign Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
Sign

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Sign { get; set; }
Visual Basic (Declaration)
Public Overridable Property Sign As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Sign {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


SmsCount Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
SmsCount

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt SmsCount { get; set; }
Visual Basic (Declaration)
Public Overridable Property SmsCount As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ SmsCount {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


UIN Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
UIN

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt UIN { get; set; }
Visual Basic (Declaration)
Public Overridable Property UIN As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ UIN {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


UserName Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
UserName

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar UserName { get; set; }
Visual Basic (Declaration)
Public Overridable Property UserName As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ UserName {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


UserStatus Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
UserStatus

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt UserStatus { get; set; }
Visual Basic (Declaration)
Public Overridable Property UserStatus As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ UserStatus {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


UserType Property

[image]

伟鹏即时通讯Web Service说明文档
UserBriefFilter 类 参见
UserType

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt UserType { get; set; }
Visual Basic (Declaration)
Public Overridable Property UserType As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ UserType {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserBriefFilter 类
WpimSystem.Filter 命名空间


UserDetailFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[用户详情]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class UserDetailFilter
Visual Basic (Declaration)
Public Class UserDetailFilter
Visual C++
public ref class UserDetailFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.UserDetailFilter

参见

UserDetailFilter 成员
WpimSystem.Filter 命名空间


UserDetailFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 构造函数 属性 参见

UserDetailFilter 类型暴露了以下成员.

构造函数

名称 | 说明
UserDetailFilter | Initializes a new instance of the UserDetailFilter class

属性

名称 | 说明
Address | 地址
Comment | 个人介绍
Company1 | 公司名1
Company2 | 公司名2
Constellation | 星座
Department | 所在部门
Edu | 学历
Fax | 传真
Hobby | 爱好
Id | 自动编号
IdCard | 身份证
Job | 行业
MSN | Msn
Name | 名字
Picpath | 图片路径
Postcode | 邮编
Product | 产品
QQ | QQ号
School | 毕业学校
Tel | 电话
Title | 职位
UIN | 帐号
Url | 主页

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


UserDetailFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
Initializes a new instance of the UserDetailFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserDetailFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserDetailFilter()

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


UserDetailFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见

UserDetailFilter 类型暴露了以下属性.

属性

名称 | 说明
Address | 地址
Comment | 个人介绍
Company1 | 公司名1
Company2 | 公司名2
Constellation | 星座
Department | 所在部门
Edu | 学历
Fax | 传真
Hobby | 爱好
Id | 自动编号
IdCard | 身份证
Job | 行业
MSN | Msn
Name | 名字
Picpath | 图片路径
Postcode | 邮编
Product | 产品
QQ | QQ号
School | 毕业学校
Tel | 电话
Title | 职位
UIN | 帐号
Url | 主页

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Address Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
地址

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Address { get; set; }
Visual Basic (Declaration)
Public Overridable Property Address As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Address {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Comment Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
个人介绍

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Comment { get; set; }
Visual Basic (Declaration)
Public Overridable Property Comment As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Comment {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Company1 Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
公司名1

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Company1 { get; set; }
Visual Basic (Declaration)
Public Overridable Property Company1 As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Company1 {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Company2 Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
公司名2

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Company2 { get; set; }
Visual Basic (Declaration)
Public Overridable Property Company2 As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Company2 {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Constellation Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
星座

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Constellation { get; set; }
Visual Basic (Declaration)
Public Overridable Property Constellation As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Constellation {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Department Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
所在部门

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Department { get; set; }
Visual Basic (Declaration)
Public Overridable Property Department As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Department {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Edu Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
学历

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Edu { get; set; }
Visual Basic (Declaration)
Public Overridable Property Edu As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Edu {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Fax Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
传真

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Fax { get; set; }
Visual Basic (Declaration)
Public Overridable Property Fax As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Fax {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Hobby Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
爱好

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Hobby { get; set; }
Visual Basic (Declaration)
Public Overridable Property Hobby As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Hobby {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
自动编号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


IdCard Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
身份证

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar IdCard { get; set; }
Visual Basic (Declaration)
Public Overridable Property IdCard As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ IdCard {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Job Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
行业

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Job { get; set; }
Visual Basic (Declaration)
Public Overridable Property Job As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Job {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


MSN Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
Msn

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar MSN { get; set; }
Visual Basic (Declaration)
Public Overridable Property MSN As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ MSN {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
名字

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Name {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Picpath Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
图片路径

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Picpath { get; set; }
Visual Basic (Declaration)
Public Overridable Property Picpath As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Picpath {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Postcode Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
邮编

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Postcode { get; set; }
Visual Basic (Declaration)
Public Overridable Property Postcode As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Postcode {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Product Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
产品

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Product { get; set; }
Visual Basic (Declaration)
Public Overridable Property Product As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Product {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


QQ Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
QQ号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt QQ { get; set; }
Visual Basic (Declaration)
Public Overridable Property QQ As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ QQ {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


School Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
毕业学校

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar School { get; set; }
Visual Basic (Declaration)
Public Overridable Property School As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ School {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Tel Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
电话

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Tel { get; set; }
Visual Basic (Declaration)
Public Overridable Property Tel As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Tel {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Title Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
职位

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Title { get; set; }
Visual Basic (Declaration)
Public Overridable Property Title As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Title {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


UIN Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
帐号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt UIN { get; set; }
Visual Basic (Declaration)
Public Overridable Property UIN As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ UIN {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


Url Property

[image]

伟鹏即时通讯Web Service说明文档
UserDetailFilter 类 参见
主页

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Url { get; set; }
Visual Basic (Declaration)
Public Overridable Property Url As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Url {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserDetailFilter 类
WpimSystem.Filter 命名空间


UserFileFilter Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[用户文件]过滤类

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class UserFileFilter
Visual Basic (Declaration)
Public Class UserFileFilter
Visual C++
public ref class UserFileFilter

继承层次结构

System..::.Object
WpimSystem.Filter..::.UserFileFilter

参见

UserFileFilter 成员
WpimSystem.Filter 命名空间


UserFileFilter Members

[image] [image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 构造函数 属性 参见

UserFileFilter 类型暴露了以下成员.

构造函数

名称 | 说明
UserFileFilter | Initializes a new instance of the UserFileFilter class

属性

名称 | 说明
CreateDate | 创建时间
Expire | 有效期
Extension | 扩展名
Guid | Guid
Id | 自动编号
Name | 文件名称
Size | 文件大小
ToUin | 接收人
Type | 类型
Uin | 号码
Url | 路径

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


UserFileFilter Constructor

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
Initializes a new instance of the UserFileFilter class

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserFileFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserFileFilter()

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


UserFileFilter Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见

UserFileFilter 类型暴露了以下属性.

属性

名称 | 说明
CreateDate | 创建时间
Expire | 有效期
Extension | 扩展名
Guid | Guid
Id | 自动编号
Name | 文件名称
Size | 文件大小
ToUin | 接收人
Type | 类型
Uin | 号码
Url | 路径

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


CreateDate Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
创建时间

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime CreateDate { get; set; }
Visual Basic (Declaration)
Public Overridable Property CreateDate As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ CreateDate {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


Expire Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
有效期

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereDateTime Expire { get; set; }
Visual Basic (Declaration)
Public Overridable Property Expire As SqlWhereDateTime
Visual C++
public:
virtual property SqlWhereDateTime^ Expire {
    SqlWhereDateTime^ get ();
    void set (SqlWhereDateTime^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


Extension Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
扩展名

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Extension { get; set; }
Visual Basic (Declaration)
Public Overridable Property Extension As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Extension {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


Guid Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
Guid

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Guid { get; set; }
Visual Basic (Declaration)
Public Overridable Property Guid As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Guid {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
自动编号

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Id { get; set; }
Visual Basic (Declaration)
Public Overridable Property Id As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Id {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
文件名称

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Name { get; set; }
Visual Basic (Declaration)
Public Overridable Property Name As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Name {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


Size Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
文件大小

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Size { get; set; }
Visual Basic (Declaration)
Public Overridable Property Size As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Size {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


ToUin Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
接收人

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt ToUin { get; set; }
Visual Basic (Declaration)
Public Overridable Property ToUin As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ ToUin {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


Type Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
类型

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Type { get; set; }
Visual Basic (Declaration)
Public Overridable Property Type As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Type {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


Uin Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
号码

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereInt Uin { get; set; }
Visual Basic (Declaration)
Public Overridable Property Uin As SqlWhereInt
Visual C++
public:
virtual property SqlWhereInt^ Uin {
    SqlWhereInt^ get ();
    void set (SqlWhereInt^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


Url Property

[image]

伟鹏即时通讯Web Service说明文档
UserFileFilter 类 参见
路径

命名空间： WpimSystem.Filter
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public virtual SqlWhereChar Url { get; set; }
Visual Basic (Declaration)
Public Overridable Property Url As SqlWhereChar
Visual C++
public:
virtual property SqlWhereChar^ Url {
    SqlWhereChar^ get ();
    void set (SqlWhereChar^ value);
}

参见

UserFileFilter 类
WpimSystem.Filter 命名空间


WpimSystem.Interface Namespace

[image]

伟鹏即时通讯Web Service说明文档

接口

接口 | 说明
IDBAdManager | [Ad]管理类接口
IDBCommunityManager | [群组]管理类接口
IDBCommunityMemberManager | [群用户]管理类接口
IDBCommunityMsgRecordManager | [群消息记录]管理类接口
IDBCompanyGatheringManager | [企业收款登记]管理类接口
IDBCompanyManager | [公司]管理类接口
IDBDepartmentManager | [部门]管理类接口
IDBEmployeeManager | [员工]管理类接口
IDBLoginRecordManager | [登录记录]管理类接口
IDBMiniNewsManager | [MiniNews]管理类接口
IDBOnlineBroadManager | [OnlineBroad]管理类接口
IDBPanelManager | [Panel]管理类接口
IDBTblAdvManager | [TblAdv]管理类接口
IDBUserBriefManager | [UserBrief]管理类接口
IDBUserDetailManager | [用户详情]管理类接口
IDBUserFileManager | [用户文件]管理类接口


IDBAdManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[Ad]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBAdManager
Visual Basic (Declaration)
Public Interface IDBAdManager
Visual C++
public interface class IDBAdManager

参见

IDBAdManager 成员
WpimSystem.Interface 命名空间


IDBAdManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBAdManager 接口 方法 参见

IDBAdManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[]
Delete | 重载。
Read | 读取[]
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
Update | 更新[]

参见

IDBAdManager 接口
WpimSystem.Interface 命名空间


IDBAdManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBAdManager 接口 参见

IDBAdManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[]
Delete | 重载。
Read | 读取[]
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
Update | 更新[]

参见

IDBAdManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBAdManager 接口 参见
创建[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    Ad ad
)
Visual Basic (Declaration)
Function Create ( _
    ad As Ad _
) As DBReturn
Visual C++
DBReturn^ Create(
    Ad^ ad
)

参数

ad
类型：WpimSystem.Domain..::.Ad

返回值

DBReturn

参见

IDBAdManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBAdManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[]
Delete(Int32) | 删除[]

参见

IDBAdManager 接口
IDBAdManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBAdManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

Ad

参见

IDBAdManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBAdManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Ad

参见

IDBAdManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBAdManager 接口 参见
读取[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
Ad Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As Ad
Visual C++
Ad^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Ad

参见

IDBAdManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBAdManager 接口 参见
读取列表[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    AdFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As AdFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    AdFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.AdFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBAdManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBAdManager 接口 参见
读取分页数据[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    AdFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As AdFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    AdFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.AdFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBAdManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBAdManager 接口 参见
更新[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    Ad ad
)
Visual Basic (Declaration)
Function Update ( _
    ad As Ad _
) As DBReturn
Visual C++
DBReturn^ Update(
    Ad^ ad
)

参数

ad
类型：WpimSystem.Domain..::.Ad

返回值

DBReturn

参见

IDBAdManager 接口
WpimSystem.Interface 命名空间


IDBCommunityManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[群组]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBCommunityManager
Visual Basic (Declaration)
Public Interface IDBCommunityManager
Visual C++
public interface class IDBCommunityManager

参见

IDBCommunityManager 成员
WpimSystem.Interface 命名空间


IDBCommunityManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCommunityManager 接口 方法 参见

IDBCommunityManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[群组]
Delete | 重载。
Read | 读取[群组]
ReadList | 读取列表[群组]
ReadPageData | 读取分页数据[群组]
Update | 更新[群组]

参见

IDBCommunityManager 接口
WpimSystem.Interface 命名空间


IDBCommunityManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCommunityManager 接口 参见

IDBCommunityManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[群组]
Delete | 重载。
Read | 读取[群组]
ReadList | 读取列表[群组]
ReadPageData | 读取分页数据[群组]
Update | 更新[群组]

参见

IDBCommunityManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityManager 接口 参见
创建[群组]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    Community community
)
Visual Basic (Declaration)
Function Create ( _
    community As Community _
) As DBReturn
Visual C++
DBReturn^ Create(
    Community^ community
)

参数

community
类型：WpimSystem.Domain..::.Community
群组

返回值

DBReturn

参见

IDBCommunityManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCommunityManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[群组]
Delete(Int32) | 删除[群组]

参见

IDBCommunityManager 接口
IDBCommunityManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityManager 接口 参见
删除[群组]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

Community

参见

IDBCommunityManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityManager 接口 参见
删除[群组]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Community

参见

IDBCommunityManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityManager 接口 参见
读取[群组]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
Community Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As Community
Visual C++
Community^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Community

参见

IDBCommunityManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityManager 接口 参见
读取列表[群组]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    CommunityFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As CommunityFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    CommunityFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.CommunityFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBCommunityManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityManager 接口 参见
读取分页数据[群组]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    CommunityFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As CommunityFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    CommunityFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.CommunityFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBCommunityManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityManager 接口 参见
更新[群组]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    Community community
)
Visual Basic (Declaration)
Function Update ( _
    community As Community _
) As DBReturn
Visual C++
DBReturn^ Update(
    Community^ community
)

参数

community
类型：WpimSystem.Domain..::.Community
群组

返回值

DBReturn

参见

IDBCommunityManager 接口
WpimSystem.Interface 命名空间


IDBCommunityMemberManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[群用户]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBCommunityMemberManager
Visual Basic (Declaration)
Public Interface IDBCommunityMemberManager
Visual C++
public interface class IDBCommunityMemberManager

参见

IDBCommunityMemberManager 成员
WpimSystem.Interface 命名空间


IDBCommunityMemberManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 方法 参见

IDBCommunityMemberManager 类型暴露了以下成员.

方法

名称 | 说明
AddMember | 添加成员
Create | 创建[群用户]
Delete | 重载。
Read | 读取[群用户]
ReadList | 读取列表[群用户]
ReadPageData | 读取分页数据[群用户]
RemoveMember | 删除群成员
Update | 更新[群用户]

参见

IDBCommunityMemberManager 接口
WpimSystem.Interface 命名空间


IDBCommunityMemberManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见

IDBCommunityMemberManager 类型暴露了以下方法.

方法

名称 | 说明
AddMember | 添加成员
Create | 创建[群用户]
Delete | 重载。
Read | 读取[群用户]
ReadList | 读取列表[群用户]
ReadPageData | 读取分页数据[群用户]
RemoveMember | 删除群成员
Update | 更新[群用户]

参见

IDBCommunityMemberManager 接口
WpimSystem.Interface 命名空间


AddMember Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见
添加成员

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn AddMember(
    int uin,
    string communityId
)
Visual Basic (Declaration)
Function AddMember ( _
    uin As Integer, _
    communityId As String _
) As DBReturn
Visual C++
DBReturn^ AddMember(
    int uin,
    String^ communityId
)

参数

uin
类型：System..::.Int32
communityId
类型：System..::.String

返回值

参见

IDBCommunityMemberManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见
创建[群用户]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    CommunityMember communityMember
)
Visual Basic (Declaration)
Function Create ( _
    communityMember As CommunityMember _
) As DBReturn
Visual C++
DBReturn^ Create(
    CommunityMember^ communityMember
)

参数

communityMember
类型：WpimSystem.Domain..::.CommunityMember
群用户

返回值

DBReturn

参见

IDBCommunityMemberManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[群用户]
Delete(Int32) | 删除[群用户]

参见

IDBCommunityMemberManager 接口
IDBCommunityMemberManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见
删除[群用户]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

CommunityMember

参见

IDBCommunityMemberManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见
删除[群用户]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

CommunityMember

参见

IDBCommunityMemberManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见
读取[群用户]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
CommunityMember Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As CommunityMember
Visual C++
CommunityMember^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

CommunityMember

参见

IDBCommunityMemberManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见
读取列表[群用户]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    CommunityMemberFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As CommunityMemberFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    CommunityMemberFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.CommunityMemberFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBCommunityMemberManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见
读取分页数据[群用户]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    CommunityMemberFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As CommunityMemberFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    CommunityMemberFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.CommunityMemberFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBCommunityMemberManager 接口
WpimSystem.Interface 命名空间


RemoveMember Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见
删除群成员

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn RemoveMember(
    int uin,
    string communityId
)
Visual Basic (Declaration)
Function RemoveMember ( _
    uin As Integer, _
    communityId As String _
) As DBReturn
Visual C++
DBReturn^ RemoveMember(
    int uin,
    String^ communityId
)

参数

uin
类型：System..::.Int32
communityId
类型：System..::.String

返回值

参见

IDBCommunityMemberManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMemberManager 接口 参见
更新[群用户]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    CommunityMember communityMember
)
Visual Basic (Declaration)
Function Update ( _
    communityMember As CommunityMember _
) As DBReturn
Visual C++
DBReturn^ Update(
    CommunityMember^ communityMember
)

参数

communityMember
类型：WpimSystem.Domain..::.CommunityMember
群用户

返回值

DBReturn

参见

IDBCommunityMemberManager 接口
WpimSystem.Interface 命名空间


IDBCommunityMsgRecordManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[群消息记录]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBCommunityMsgRecordManager
Visual Basic (Declaration)
Public Interface IDBCommunityMsgRecordManager
Visual C++
public interface class IDBCommunityMsgRecordManager

参见

IDBCommunityMsgRecordManager 成员
WpimSystem.Interface 命名空间


IDBCommunityMsgRecordManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 方法 参见

IDBCommunityMsgRecordManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[群消息记录]
Delete | 重载。
GetFromCompanyMsgCount | 回复消息总数
GetToCompanyMsgCount | 回复消息总数
Read | 读取[群消息记录]
ReadList | 读取列表[群消息记录]
ReadPageData | 读取分页数据[群消息记录]
Update | 更新[群消息记录]

参见

IDBCommunityMsgRecordManager 接口
WpimSystem.Interface 命名空间


IDBCommunityMsgRecordManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见

IDBCommunityMsgRecordManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[群消息记录]
Delete | 重载。
GetFromCompanyMsgCount | 回复消息总数
GetToCompanyMsgCount | 回复消息总数
Read | 读取[群消息记录]
ReadList | 读取列表[群消息记录]
ReadPageData | 读取分页数据[群消息记录]
Update | 更新[群消息记录]

参见

IDBCommunityMsgRecordManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见
创建[群消息记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    CommunityMsgRecord communityMsgRecord
)
Visual Basic (Declaration)
Function Create ( _
    communityMsgRecord As CommunityMsgRecord _
) As DBReturn
Visual C++
DBReturn^ Create(
    CommunityMsgRecord^ communityMsgRecord
)

参数

communityMsgRecord
类型：WpimSystem.Domain..::.CommunityMsgRecord
群消息记录

返回值

DBReturn

参见

IDBCommunityMsgRecordManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[群消息记录]
Delete(Int32) | 删除[群消息记录]

参见

IDBCommunityMsgRecordManager 接口
IDBCommunityMsgRecordManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见
删除[群消息记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

CommunityMsgRecord

参见

IDBCommunityMsgRecordManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见
删除[群消息记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

CommunityMsgRecord

参见

IDBCommunityMsgRecordManager 接口
Delete 重载
WpimSystem.Interface 命名空间


GetFromCompanyMsgCount Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见
回复消息总数

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
int GetFromCompanyMsgCount(
    int companyId,
    DateTime start,
    DateTime end
)
Visual Basic (Declaration)
Function GetFromCompanyMsgCount ( _
    companyId As Integer, _
    start As DateTime, _
    end As DateTime _
) As Integer
Visual C++
int GetFromCompanyMsgCount(
    int companyId,
    DateTime start,
    DateTime end
)

参数

companyId
类型：System..::.Int32
公司Id
start
类型：System..::.DateTime
end
类型：System..::.DateTime

返回值

参见

IDBCommunityMsgRecordManager 接口
WpimSystem.Interface 命名空间


GetToCompanyMsgCount Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见
回复消息总数

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
int GetToCompanyMsgCount(
    int companyId,
    DateTime start,
    DateTime end
)
Visual Basic (Declaration)
Function GetToCompanyMsgCount ( _
    companyId As Integer, _
    start As DateTime, _
    end As DateTime _
) As Integer
Visual C++
int GetToCompanyMsgCount(
    int companyId,
    DateTime start,
    DateTime end
)

参数

companyId
类型：System..::.Int32
公司Id
start
类型：System..::.DateTime
end
类型：System..::.DateTime

返回值

参见

IDBCommunityMsgRecordManager 接口
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见
读取[群消息记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
CommunityMsgRecord Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As CommunityMsgRecord
Visual C++
CommunityMsgRecord^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

CommunityMsgRecord

参见

IDBCommunityMsgRecordManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见
读取列表[群消息记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    CommunityMsgRecordFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As CommunityMsgRecordFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    CommunityMsgRecordFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.CommunityMsgRecordFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBCommunityMsgRecordManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见
读取分页数据[群消息记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    CommunityMsgRecordFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As CommunityMsgRecordFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    CommunityMsgRecordFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.CommunityMsgRecordFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBCommunityMsgRecordManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCommunityMsgRecordManager 接口 参见
更新[群消息记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    CommunityMsgRecord communityMsgRecord
)
Visual Basic (Declaration)
Function Update ( _
    communityMsgRecord As CommunityMsgRecord _
) As DBReturn
Visual C++
DBReturn^ Update(
    CommunityMsgRecord^ communityMsgRecord
)

参数

communityMsgRecord
类型：WpimSystem.Domain..::.CommunityMsgRecord
群消息记录

返回值

DBReturn

参见

IDBCommunityMsgRecordManager 接口
WpimSystem.Interface 命名空间


IDBCompanyGatheringManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[企业收款登记]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBCompanyGatheringManager
Visual Basic (Declaration)
Public Interface IDBCompanyGatheringManager
Visual C++
public interface class IDBCompanyGatheringManager

参见

IDBCompanyGatheringManager 成员
WpimSystem.Interface 命名空间


IDBCompanyGatheringManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 方法 参见

IDBCompanyGatheringManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[企业收款登记]
Delete | 重载。
Read | 读取[企业收款登记]
ReadList | 读取列表[企业收款登记]
ReadPageData | 读取分页数据[企业收款登记]
ReadPageData2 | 读取分页数据[企业收款登记]
Update | 更新[企业收款登记]

参见

IDBCompanyGatheringManager 接口
WpimSystem.Interface 命名空间


IDBCompanyGatheringManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 参见

IDBCompanyGatheringManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[企业收款登记]
Delete | 重载。
Read | 读取[企业收款登记]
ReadList | 读取列表[企业收款登记]
ReadPageData | 读取分页数据[企业收款登记]
ReadPageData2 | 读取分页数据[企业收款登记]
Update | 更新[企业收款登记]

参见

IDBCompanyGatheringManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 参见
创建[企业收款登记]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    CompanyGathering companyGathering
)
Visual Basic (Declaration)
Function Create ( _
    companyGathering As CompanyGathering _
) As DBReturn
Visual C++
DBReturn^ Create(
    CompanyGathering^ companyGathering
)

参数

companyGathering
类型：WpimSystem.Domain..::.CompanyGathering
企业收款登记

返回值

DBReturn

参见

IDBCompanyGatheringManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[企业收款登记]
Delete(Int32) | 删除[企业收款登记]

参见

IDBCompanyGatheringManager 接口
IDBCompanyGatheringManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 参见
删除[企业收款登记]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

CompanyGathering

参见

IDBCompanyGatheringManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 参见
删除[企业收款登记]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

CompanyGathering

参见

IDBCompanyGatheringManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 参见
读取[企业收款登记]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
CompanyGathering Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As CompanyGathering
Visual C++
CompanyGathering^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

CompanyGathering

参见

IDBCompanyGatheringManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 参见
读取列表[企业收款登记]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    CompanyGatheringFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As CompanyGatheringFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    CompanyGatheringFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.CompanyGatheringFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBCompanyGatheringManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 参见
读取分页数据[企业收款登记]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    CompanyGatheringFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As CompanyGatheringFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    CompanyGatheringFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.CompanyGatheringFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBCompanyGatheringManager 接口
WpimSystem.Interface 命名空间


ReadPageData2 Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 参见
读取分页数据[企业收款登记]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData2(
    CompanyGatheringFilter filter,
    string empty,
    int pageSize,
    int pageIndex
)
Visual Basic (Declaration)
Function ReadPageData2 ( _
    filter As CompanyGatheringFilter, _
    empty As String, _
    pageSize As Integer, _
    pageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData2(
    CompanyGatheringFilter^ filter,
    String^ empty,
    int pageSize,
    int pageIndex
)

参数

filter
类型：WpimSystem.Filter..::.CompanyGatheringFilter
过滤器
empty
类型：System..::.String
pageSize
类型：System..::.Int32
页面尺寸
pageIndex
类型：System..::.Int32

返回值

PageData列表

参见

IDBCompanyGatheringManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyGatheringManager 接口 参见
更新[企业收款登记]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    CompanyGathering companyGathering
)
Visual Basic (Declaration)
Function Update ( _
    companyGathering As CompanyGathering _
) As DBReturn
Visual C++
DBReturn^ Update(
    CompanyGathering^ companyGathering
)

参数

companyGathering
类型：WpimSystem.Domain..::.CompanyGathering
企业收款登记

返回值

DBReturn

参见

IDBCompanyGatheringManager 接口
WpimSystem.Interface 命名空间


IDBCompanyManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[公司]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBCompanyManager
Visual Basic (Declaration)
Public Interface IDBCompanyManager
Visual C++
public interface class IDBCompanyManager

参见

IDBCompanyManager 成员
WpimSystem.Interface 命名空间


IDBCompanyManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 方法 参见

IDBCompanyManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[公司]
Delete | 重载。
Read | 读取[公司]
ReadByAccount | 根据帐号读取公司信息
ReadByEmail | 根据Email读取公司信息
ReadList | 读取列表[公司]
ReadPageData | 读取分页数据[公司]
Update | 更新[公司]
UpdatePassword | 修改密码

参见

IDBCompanyManager 接口
WpimSystem.Interface 命名空间


IDBCompanyManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见

IDBCompanyManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[公司]
Delete | 重载。
Read | 读取[公司]
ReadByAccount | 根据帐号读取公司信息
ReadByEmail | 根据Email读取公司信息
ReadList | 读取列表[公司]
ReadPageData | 读取分页数据[公司]
Update | 更新[公司]
UpdatePassword | 修改密码

参见

IDBCompanyManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见
创建[公司]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    Company company
)
Visual Basic (Declaration)
Function Create ( _
    company As Company _
) As DBReturn
Visual C++
DBReturn^ Create(
    Company^ company
)

参数

company
类型：WpimSystem.Domain..::.Company
公司

返回值

DBReturn

参见

IDBCompanyManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[公司]
Delete(Int32) | 删除[公司]

参见

IDBCompanyManager 接口
IDBCompanyManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见
删除[公司]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

Company

参见

IDBCompanyManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见
删除[公司]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Company

参见

IDBCompanyManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见
读取[公司]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
Company Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As Company
Visual C++
Company^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Company

参见

IDBCompanyManager 接口
WpimSystem.Interface 命名空间


ReadByAccount Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见
根据帐号读取公司信息

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
Company ReadByAccount(
    string account
)
Visual Basic (Declaration)
Function ReadByAccount ( _
    account As String _
) As Company
Visual C++
Company^ ReadByAccount(
    String^ account
)

参数

account
类型：System..::.String
帐号

返回值

参见

IDBCompanyManager 接口
WpimSystem.Interface 命名空间


ReadByEmail Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见
根据Email读取公司信息

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
Company ReadByEmail(
    string email
)
Visual Basic (Declaration)
Function ReadByEmail ( _
    email As String _
) As Company
Visual C++
Company^ ReadByEmail(
    String^ email
)

参数

email
类型：System..::.String

返回值

参见

IDBCompanyManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见
读取列表[公司]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    CompanyFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As CompanyFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    CompanyFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.CompanyFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBCompanyManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见
读取分页数据[公司]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    CompanyFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As CompanyFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    CompanyFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.CompanyFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBCompanyManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见
更新[公司]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    Company company
)
Visual Basic (Declaration)
Function Update ( _
    company As Company _
) As DBReturn
Visual C++
DBReturn^ Update(
    Company^ company
)

参数

company
类型：WpimSystem.Domain..::.Company
公司

返回值

DBReturn

参见

IDBCompanyManager 接口
WpimSystem.Interface 命名空间


UpdatePassword Method

[image]

伟鹏即时通讯Web Service说明文档
IDBCompanyManager 接口 参见
修改密码

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn UpdatePassword(
    string account,
    string newPwd
)
Visual Basic (Declaration)
Function UpdatePassword ( _
    account As String, _
    newPwd As String _
) As DBReturn
Visual C++
DBReturn^ UpdatePassword(
    String^ account,
    String^ newPwd
)

参数

account
类型：System..::.String
帐号
newPwd
类型：System..::.String
新密码

返回值

参见

IDBCompanyManager 接口
WpimSystem.Interface 命名空间


IDBDepartmentManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[部门]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBDepartmentManager
Visual Basic (Declaration)
Public Interface IDBDepartmentManager
Visual C++
public interface class IDBDepartmentManager

参见

IDBDepartmentManager 成员
WpimSystem.Interface 命名空间


IDBDepartmentManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBDepartmentManager 接口 方法 参见

IDBDepartmentManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[部门]
Delete | 重载。
Read | 读取[部门]
ReadList | 读取列表[部门]
ReadPageData | 读取分页数据[部门]
Update | 更新[部门]

参见

IDBDepartmentManager 接口
WpimSystem.Interface 命名空间


IDBDepartmentManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBDepartmentManager 接口 参见

IDBDepartmentManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[部门]
Delete | 重载。
Read | 读取[部门]
ReadList | 读取列表[部门]
ReadPageData | 读取分页数据[部门]
Update | 更新[部门]

参见

IDBDepartmentManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBDepartmentManager 接口 参见
创建[部门]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    Department department
)
Visual Basic (Declaration)
Function Create ( _
    department As Department _
) As DBReturn
Visual C++
DBReturn^ Create(
    Department^ department
)

参数

department
类型：WpimSystem.Domain..::.Department
部门

返回值

DBReturn

参见

IDBDepartmentManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBDepartmentManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[部门]
Delete(Int32) | 删除[部门]

参见

IDBDepartmentManager 接口
IDBDepartmentManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBDepartmentManager 接口 参见
删除[部门]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

Department

参见

IDBDepartmentManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBDepartmentManager 接口 参见
删除[部门]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Department

参见

IDBDepartmentManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBDepartmentManager 接口 参见
读取[部门]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
Department Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As Department
Visual C++
Department^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Department

参见

IDBDepartmentManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBDepartmentManager 接口 参见
读取列表[部门]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    DepartmentFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As DepartmentFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    DepartmentFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.DepartmentFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBDepartmentManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBDepartmentManager 接口 参见
读取分页数据[部门]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    DepartmentFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As DepartmentFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    DepartmentFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.DepartmentFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBDepartmentManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBDepartmentManager 接口 参见
更新[部门]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    Department department
)
Visual Basic (Declaration)
Function Update ( _
    department As Department _
) As DBReturn
Visual C++
DBReturn^ Update(
    Department^ department
)

参数

department
类型：WpimSystem.Domain..::.Department
部门

返回值

DBReturn

参见

IDBDepartmentManager 接口
WpimSystem.Interface 命名空间


IDBEmployeeManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[员工]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBEmployeeManager
Visual Basic (Declaration)
Public Interface IDBEmployeeManager
Visual C++
public interface class IDBEmployeeManager

参见

IDBEmployeeManager 成员
WpimSystem.Interface 命名空间


IDBEmployeeManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 方法 参见

IDBEmployeeManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[员工]
Delete | 重载。
DeleteByCompany | 删除所属公司的职业
GetEmployeeCount | 员工统计
Read | 读取[员工]
ReadList | 读取列表[员工]
ReadPageData | 读取分页数据[员工]
Update | 更新[员工]

参见

IDBEmployeeManager 接口
WpimSystem.Interface 命名空间


IDBEmployeeManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见

IDBEmployeeManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[员工]
Delete | 重载。
DeleteByCompany | 删除所属公司的职业
GetEmployeeCount | 员工统计
Read | 读取[员工]
ReadList | 读取列表[员工]
ReadPageData | 读取分页数据[员工]
Update | 更新[员工]

参见

IDBEmployeeManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见
创建[员工]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    Employee employee
)
Visual Basic (Declaration)
Function Create ( _
    employee As Employee _
) As DBReturn
Visual C++
DBReturn^ Create(
    Employee^ employee
)

参数

employee
类型：WpimSystem.Domain..::.Employee
员工

返回值

DBReturn

参见

IDBEmployeeManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[员工]
Delete(Int32) | 删除[员工]

参见

IDBEmployeeManager 接口
IDBEmployeeManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见
删除[员工]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

Employee

参见

IDBEmployeeManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见
删除[员工]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Employee

参见

IDBEmployeeManager 接口
Delete 重载
WpimSystem.Interface 命名空间


DeleteByCompany Method

[image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见
删除所属公司的职业

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn DeleteByCompany(
    string[] idList,
    int companyId
)
Visual Basic (Declaration)
Function DeleteByCompany ( _
    idList As String(), _
    companyId As Integer _
) As DBReturn
Visual C++
DBReturn^ DeleteByCompany(
    array<String^>^ idList,
    int companyId
)

参数

idList
类型：array< System..::.String >[]()[]
id集合
companyId
类型：System..::.Int32
公司id

返回值

参见

IDBEmployeeManager 接口
WpimSystem.Interface 命名空间


GetEmployeeCount Method

[image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见
员工统计

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
int GetEmployeeCount(
    int companyId
)
Visual Basic (Declaration)
Function GetEmployeeCount ( _
    companyId As Integer _
) As Integer
Visual C++
int GetEmployeeCount(
    int companyId
)

参数

companyId
类型：System..::.Int32
公司Id

返回值

参见

IDBEmployeeManager 接口
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见
读取[员工]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
Employee Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As Employee
Visual C++
Employee^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Employee

参见

IDBEmployeeManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见
读取列表[员工]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    EmployeeFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As EmployeeFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    EmployeeFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.EmployeeFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBEmployeeManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见
读取分页数据[员工]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    EmployeeFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As EmployeeFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    EmployeeFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.EmployeeFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBEmployeeManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBEmployeeManager 接口 参见
更新[员工]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    Employee employee
)
Visual Basic (Declaration)
Function Update ( _
    employee As Employee _
) As DBReturn
Visual C++
DBReturn^ Update(
    Employee^ employee
)

参数

employee
类型：WpimSystem.Domain..::.Employee
员工

返回值

DBReturn

参见

IDBEmployeeManager 接口
WpimSystem.Interface 命名空间


IDBLoginRecordManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[登录记录]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBLoginRecordManager
Visual Basic (Declaration)
Public Interface IDBLoginRecordManager
Visual C++
public interface class IDBLoginRecordManager

参见

IDBLoginRecordManager 成员
WpimSystem.Interface 命名空间


IDBLoginRecordManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 方法 参见

IDBLoginRecordManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[登录记录]
Delete | 重载。
GetTodayLoginCount | 统计今天登陆的员工数
Read | 读取[登录记录]
ReadList | 读取列表[登录记录]
ReadPageData | 读取分页数据[登录记录]
Update | 更新[登录记录]

参见

IDBLoginRecordManager 接口
WpimSystem.Interface 命名空间


IDBLoginRecordManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 参见

IDBLoginRecordManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[登录记录]
Delete | 重载。
GetTodayLoginCount | 统计今天登陆的员工数
Read | 读取[登录记录]
ReadList | 读取列表[登录记录]
ReadPageData | 读取分页数据[登录记录]
Update | 更新[登录记录]

参见

IDBLoginRecordManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 参见
创建[登录记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    LoginRecord loginRecord
)
Visual Basic (Declaration)
Function Create ( _
    loginRecord As LoginRecord _
) As DBReturn
Visual C++
DBReturn^ Create(
    LoginRecord^ loginRecord
)

参数

loginRecord
类型：WpimSystem.Domain..::.LoginRecord
登录记录

返回值

DBReturn

参见

IDBLoginRecordManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[登录记录]
Delete(Int32) | 删除[登录记录]

参见

IDBLoginRecordManager 接口
IDBLoginRecordManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 参见
删除[登录记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

LoginRecord

参见

IDBLoginRecordManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 参见
删除[登录记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

LoginRecord

参见

IDBLoginRecordManager 接口
Delete 重载
WpimSystem.Interface 命名空间


GetTodayLoginCount Method

[image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 参见
统计今天登陆的员工数

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
int GetTodayLoginCount(
    int companyId
)
Visual Basic (Declaration)
Function GetTodayLoginCount ( _
    companyId As Integer _
) As Integer
Visual C++
int GetTodayLoginCount(
    int companyId
)

参数

companyId
类型：System..::.Int32
公司Id

返回值

参见

IDBLoginRecordManager 接口
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 参见
读取[登录记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
LoginRecord Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As LoginRecord
Visual C++
LoginRecord^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

LoginRecord

参见

IDBLoginRecordManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 参见
读取列表[登录记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    LoginRecordFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As LoginRecordFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    LoginRecordFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.LoginRecordFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBLoginRecordManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 参见
读取分页数据[登录记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    LoginRecordFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As LoginRecordFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    LoginRecordFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.LoginRecordFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBLoginRecordManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBLoginRecordManager 接口 参见
更新[登录记录]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    LoginRecord loginRecord
)
Visual Basic (Declaration)
Function Update ( _
    loginRecord As LoginRecord _
) As DBReturn
Visual C++
DBReturn^ Update(
    LoginRecord^ loginRecord
)

参数

loginRecord
类型：WpimSystem.Domain..::.LoginRecord
登录记录

返回值

DBReturn

参见

IDBLoginRecordManager 接口
WpimSystem.Interface 命名空间


IDBMiniNewsManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[MiniNews]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBMiniNewsManager
Visual Basic (Declaration)
Public Interface IDBMiniNewsManager
Visual C++
public interface class IDBMiniNewsManager

参见

IDBMiniNewsManager 成员
WpimSystem.Interface 命名空间


IDBMiniNewsManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBMiniNewsManager 接口 方法 参见

IDBMiniNewsManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[]
Delete | 重载。
Read | 读取[]
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
Update | 更新[]

参见

IDBMiniNewsManager 接口
WpimSystem.Interface 命名空间


IDBMiniNewsManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBMiniNewsManager 接口 参见

IDBMiniNewsManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[]
Delete | 重载。
Read | 读取[]
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
Update | 更新[]

参见

IDBMiniNewsManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBMiniNewsManager 接口 参见
创建[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    MiniNews miniNews
)
Visual Basic (Declaration)
Function Create ( _
    miniNews As MiniNews _
) As DBReturn
Visual C++
DBReturn^ Create(
    MiniNews^ miniNews
)

参数

miniNews
类型：WpimSystem.Domain..::.MiniNews

返回值

DBReturn

参见

IDBMiniNewsManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBMiniNewsManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[]
Delete(Int32) | 删除[]

参见

IDBMiniNewsManager 接口
IDBMiniNewsManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBMiniNewsManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

MiniNews

参见

IDBMiniNewsManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBMiniNewsManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

MiniNews

参见

IDBMiniNewsManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBMiniNewsManager 接口 参见
读取[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
MiniNews Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As MiniNews
Visual C++
MiniNews^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

MiniNews

参见

IDBMiniNewsManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBMiniNewsManager 接口 参见
读取列表[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    MiniNewsFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As MiniNewsFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    MiniNewsFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.MiniNewsFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBMiniNewsManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBMiniNewsManager 接口 参见
读取分页数据[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    MiniNewsFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As MiniNewsFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    MiniNewsFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.MiniNewsFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBMiniNewsManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBMiniNewsManager 接口 参见
更新[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    MiniNews miniNews
)
Visual Basic (Declaration)
Function Update ( _
    miniNews As MiniNews _
) As DBReturn
Visual C++
DBReturn^ Update(
    MiniNews^ miniNews
)

参数

miniNews
类型：WpimSystem.Domain..::.MiniNews

返回值

DBReturn

参见

IDBMiniNewsManager 接口
WpimSystem.Interface 命名空间


IDBOnlineBroadManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[OnlineBroad]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBOnlineBroadManager
Visual Basic (Declaration)
Public Interface IDBOnlineBroadManager
Visual C++
public interface class IDBOnlineBroadManager

参见

IDBOnlineBroadManager 成员
WpimSystem.Interface 命名空间


IDBOnlineBroadManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBOnlineBroadManager 接口 方法 参见

IDBOnlineBroadManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[]
Delete | 重载。
Read | 读取[]
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
Update | 更新[]

参见

IDBOnlineBroadManager 接口
WpimSystem.Interface 命名空间


IDBOnlineBroadManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBOnlineBroadManager 接口 参见

IDBOnlineBroadManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[]
Delete | 重载。
Read | 读取[]
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
Update | 更新[]

参见

IDBOnlineBroadManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBOnlineBroadManager 接口 参见
创建[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    OnlineBroad onlineBroad
)
Visual Basic (Declaration)
Function Create ( _
    onlineBroad As OnlineBroad _
) As DBReturn
Visual C++
DBReturn^ Create(
    OnlineBroad^ onlineBroad
)

参数

onlineBroad
类型：WpimSystem.Domain..::.OnlineBroad

返回值

DBReturn

参见

IDBOnlineBroadManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBOnlineBroadManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[]
Delete(Int32) | 删除[]

参见

IDBOnlineBroadManager 接口
IDBOnlineBroadManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBOnlineBroadManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

OnlineBroad

参见

IDBOnlineBroadManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBOnlineBroadManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

OnlineBroad

参见

IDBOnlineBroadManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBOnlineBroadManager 接口 参见
读取[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
OnlineBroad Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As OnlineBroad
Visual C++
OnlineBroad^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

OnlineBroad

参见

IDBOnlineBroadManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBOnlineBroadManager 接口 参见
读取列表[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    OnlineBroadFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As OnlineBroadFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    OnlineBroadFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.OnlineBroadFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBOnlineBroadManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBOnlineBroadManager 接口 参见
读取分页数据[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    OnlineBroadFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As OnlineBroadFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    OnlineBroadFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.OnlineBroadFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBOnlineBroadManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBOnlineBroadManager 接口 参见
更新[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    OnlineBroad onlineBroad
)
Visual Basic (Declaration)
Function Update ( _
    onlineBroad As OnlineBroad _
) As DBReturn
Visual C++
DBReturn^ Update(
    OnlineBroad^ onlineBroad
)

参数

onlineBroad
类型：WpimSystem.Domain..::.OnlineBroad

返回值

DBReturn

参见

IDBOnlineBroadManager 接口
WpimSystem.Interface 命名空间


IDBPanelManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[Panel]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBPanelManager
Visual Basic (Declaration)
Public Interface IDBPanelManager
Visual C++
public interface class IDBPanelManager

参见

IDBPanelManager 成员
WpimSystem.Interface 命名空间


IDBPanelManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBPanelManager 接口 方法 参见

IDBPanelManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[]
Delete | 重载。
Read | 读取[]
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
Update | 更新[]

参见

IDBPanelManager 接口
WpimSystem.Interface 命名空间


IDBPanelManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBPanelManager 接口 参见

IDBPanelManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[]
Delete | 重载。
Read | 读取[]
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
Update | 更新[]

参见

IDBPanelManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBPanelManager 接口 参见
创建[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    Panel panel
)
Visual Basic (Declaration)
Function Create ( _
    panel As Panel _
) As DBReturn
Visual C++
DBReturn^ Create(
    Panel^ panel
)

参数

panel
类型：WpimSystem.Domain..::.Panel

返回值

DBReturn

参见

IDBPanelManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBPanelManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[]
Delete(Int32) | 删除[]

参见

IDBPanelManager 接口
IDBPanelManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBPanelManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

Panel

参见

IDBPanelManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBPanelManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Panel

参见

IDBPanelManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBPanelManager 接口 参见
读取[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
Panel Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As Panel
Visual C++
Panel^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

Panel

参见

IDBPanelManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBPanelManager 接口 参见
读取列表[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    PanelFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As PanelFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    PanelFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.PanelFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBPanelManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBPanelManager 接口 参见
读取分页数据[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    PanelFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As PanelFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    PanelFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.PanelFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBPanelManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBPanelManager 接口 参见
更新[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    Panel panel
)
Visual Basic (Declaration)
Function Update ( _
    panel As Panel _
) As DBReturn
Visual C++
DBReturn^ Update(
    Panel^ panel
)

参数

panel
类型：WpimSystem.Domain..::.Panel

返回值

DBReturn

参见

IDBPanelManager 接口
WpimSystem.Interface 命名空间


IDBTblAdvManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[TblAdv]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBTblAdvManager
Visual Basic (Declaration)
Public Interface IDBTblAdvManager
Visual C++
public interface class IDBTblAdvManager

参见

IDBTblAdvManager 成员
WpimSystem.Interface 命名空间


IDBTblAdvManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBTblAdvManager 接口 方法 参见

IDBTblAdvManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[]
Delete | 重载。
Read | 读取[]
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
Update | 更新[]

参见

IDBTblAdvManager 接口
WpimSystem.Interface 命名空间


IDBTblAdvManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBTblAdvManager 接口 参见

IDBTblAdvManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[]
Delete | 重载。
Read | 读取[]
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
Update | 更新[]

参见

IDBTblAdvManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBTblAdvManager 接口 参见
创建[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    TblAdv tblAdv
)
Visual Basic (Declaration)
Function Create ( _
    tblAdv As TblAdv _
) As DBReturn
Visual C++
DBReturn^ Create(
    TblAdv^ tblAdv
)

参数

tblAdv
类型：WpimSystem.Domain..::.TblAdv

返回值

DBReturn

参见

IDBTblAdvManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBTblAdvManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[]
Delete(Int32) | 删除[]

参见

IDBTblAdvManager 接口
IDBTblAdvManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBTblAdvManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

TblAdv

参见

IDBTblAdvManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBTblAdvManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

TblAdv

参见

IDBTblAdvManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBTblAdvManager 接口 参见
读取[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
TblAdv Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As TblAdv
Visual C++
TblAdv^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

TblAdv

参见

IDBTblAdvManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBTblAdvManager 接口 参见
读取列表[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    TblAdvFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As TblAdvFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    TblAdvFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.TblAdvFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBTblAdvManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBTblAdvManager 接口 参见
读取分页数据[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    TblAdvFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As TblAdvFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    TblAdvFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.TblAdvFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBTblAdvManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBTblAdvManager 接口 参见
更新[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    TblAdv tblAdv
)
Visual Basic (Declaration)
Function Update ( _
    tblAdv As TblAdv _
) As DBReturn
Visual C++
DBReturn^ Update(
    TblAdv^ tblAdv
)

参数

tblAdv
类型：WpimSystem.Domain..::.TblAdv

返回值

DBReturn

参见

IDBTblAdvManager 接口
WpimSystem.Interface 命名空间


IDBUserBriefManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[UserBrief]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBUserBriefManager
Visual Basic (Declaration)
Public Interface IDBUserBriefManager
Visual C++
public interface class IDBUserBriefManager

参见

IDBUserBriefManager 成员
WpimSystem.Interface 命名空间


IDBUserBriefManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 方法 参见

IDBUserBriefManager 类型暴露了以下成员.

方法

名称 | 说明
AddsUser |
CheckUser |
Create | 创建[]
Delete | 重载。
GetMaxUin | 获取最大的号码
Read | 读取[]
ReadByEmail | 读取用户
ReadByUin | 读取用户
ReadByUsername | 读取用户
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
SelectUserGroup |
Update | 更新[]

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


IDBUserBriefManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见

IDBUserBriefManager 类型暴露了以下方法.

方法

名称 | 说明
AddsUser |
CheckUser |
Create | 创建[]
Delete | 重载。
GetMaxUin | 获取最大的号码
Read | 读取[]
ReadByEmail | 读取用户
ReadByUin | 读取用户
ReadByUsername | 读取用户
ReadList | 读取列表[]
ReadPageData | 读取分页数据[]
SelectUserGroup |
Update | 更新[]

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


AddsUser Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
bool AddsUser(
    int star,
    int count,
    string name,
    string pwd,
    DateTime s,
    DateTime ss
)
Visual Basic (Declaration)
Function AddsUser ( _
    star As Integer, _
    count As Integer, _
    name As String, _
    pwd As String, _
    s As DateTime, _
    ss As DateTime _
) As Boolean
Visual C++
bool AddsUser(
    int star,
    int count,
    String^ name,
    String^ pwd,
    DateTime s,
    DateTime ss
)

参数

star
类型：System..::.Int32
count
类型：System..::.Int32
name
类型：System..::.String
pwd
类型：System..::.String
s
类型：System..::.DateTime
ss
类型：System..::.DateTime

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


CheckUser Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn CheckUser(
    UserBrief userBrief
)
Visual Basic (Declaration)
Function CheckUser ( _
    userBrief As UserBrief _
) As DBReturn
Visual C++
DBReturn^ CheckUser(
    UserBrief^ userBrief
)

参数

userBrief
类型：WpimSystem.Domain..::.UserBrief

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
创建[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    UserBrief userBrief
)
Visual Basic (Declaration)
Function Create ( _
    userBrief As UserBrief _
) As DBReturn
Visual C++
DBReturn^ Create(
    UserBrief^ userBrief
)

参数

userBrief
类型：WpimSystem.Domain..::.UserBrief

返回值

DBReturn

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[]
Delete(Int32) | 删除[]

参见

IDBUserBriefManager 接口
IDBUserBriefManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

UserBrief

参见

IDBUserBriefManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
删除[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

UserBrief

参见

IDBUserBriefManager 接口
Delete 重载
WpimSystem.Interface 命名空间


GetMaxUin Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
获取最大的号码

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
int GetMaxUin()
Visual Basic (Declaration)
Function GetMaxUin As Integer
Visual C++
int GetMaxUin()

返回值

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
读取[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
UserBrief Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As UserBrief
Visual C++
UserBrief^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

UserBrief

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


ReadByEmail Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
读取用户

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
UserBrief ReadByEmail(
    string email
)
Visual Basic (Declaration)
Function ReadByEmail ( _
    email As String _
) As UserBrief
Visual C++
UserBrief^ ReadByEmail(
    String^ email
)

参数

email
类型：System..::.String

返回值

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


ReadByUin Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
读取用户

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
UserBrief ReadByUin(
    int uin
)
Visual Basic (Declaration)
Function ReadByUin ( _
    uin As Integer _
) As UserBrief
Visual C++
UserBrief^ ReadByUin(
    int uin
)

参数

uin
类型：System..::.Int32

返回值

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


ReadByUsername Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
读取用户

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
UserBrief ReadByUsername(
    string userName
)
Visual Basic (Declaration)
Function ReadByUsername ( _
    userName As String _
) As UserBrief
Visual C++
UserBrief^ ReadByUsername(
    String^ userName
)

参数

userName
类型：System..::.String

返回值

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
读取列表[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    UserBriefFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As UserBriefFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    UserBriefFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.UserBriefFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
读取分页数据[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    UserBriefFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As UserBriefFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    UserBriefFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.UserBriefFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


SelectUserGroup Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
bool SelectUserGroup(
    int start,
    int end
)
Visual Basic (Declaration)
Function SelectUserGroup ( _
    start As Integer, _
    end As Integer _
) As Boolean
Visual C++
bool SelectUserGroup(
    int start,
    int end
)

参数

start
类型：System..::.Int32
end
类型：System..::.Int32

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserBriefManager 接口 参见
更新[]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    UserBrief userBrief
)
Visual Basic (Declaration)
Function Update ( _
    userBrief As UserBrief _
) As DBReturn
Visual C++
DBReturn^ Update(
    UserBrief^ userBrief
)

参数

userBrief
类型：WpimSystem.Domain..::.UserBrief

返回值

DBReturn

参见

IDBUserBriefManager 接口
WpimSystem.Interface 命名空间


IDBUserDetailManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[用户详情]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBUserDetailManager
Visual Basic (Declaration)
Public Interface IDBUserDetailManager
Visual C++
public interface class IDBUserDetailManager

参见

IDBUserDetailManager 成员
WpimSystem.Interface 命名空间


IDBUserDetailManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBUserDetailManager 接口 方法 参见

IDBUserDetailManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[用户详情]
Delete | 重载。
Read | 读取[用户详情]
ReadList | 读取列表[用户详情]
Update | 更新[用户详情]
UpdateUserOnlineStatus |

参见

IDBUserDetailManager 接口
WpimSystem.Interface 命名空间


IDBUserDetailManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBUserDetailManager 接口 参见

IDBUserDetailManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[用户详情]
Delete | 重载。
Read | 读取[用户详情]
ReadList | 读取列表[用户详情]
Update | 更新[用户详情]
UpdateUserOnlineStatus |

参见

IDBUserDetailManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserDetailManager 接口 参见
创建[用户详情]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    UserDetail userDetail
)
Visual Basic (Declaration)
Function Create ( _
    userDetail As UserDetail _
) As DBReturn
Visual C++
DBReturn^ Create(
    UserDetail^ userDetail
)

参数

userDetail
类型：WpimSystem.Domain..::.UserDetail
用户详情

返回值

DBReturn

参见

IDBUserDetailManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBUserDetailManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[用户详情]
Delete(Int32) | 删除[用户详情]

参见

IDBUserDetailManager 接口
IDBUserDetailManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBUserDetailManager 接口 参见
删除[用户详情]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

UserDetail

参见

IDBUserDetailManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBUserDetailManager 接口 参见
删除[用户详情]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

UserDetail

参见

IDBUserDetailManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserDetailManager 接口 参见
读取[用户详情]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
UserDetail Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As UserDetail
Visual C++
UserDetail^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

UserDetail

参见

IDBUserDetailManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserDetailManager 接口 参见
读取列表[用户详情]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    UserDetailFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As UserDetailFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    UserDetailFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.UserDetailFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBUserDetailManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserDetailManager 接口 参见
更新[用户详情]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    UserDetail userDetail
)
Visual Basic (Declaration)
Function Update ( _
    userDetail As UserDetail _
) As DBReturn
Visual C++
DBReturn^ Update(
    UserDetail^ userDetail
)

参数

userDetail
类型：WpimSystem.Domain..::.UserDetail
用户详情

返回值

DBReturn

参见

IDBUserDetailManager 接口
WpimSystem.Interface 命名空间


UpdateUserOnlineStatus Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserDetailManager 接口 参见

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn UpdateUserOnlineStatus(
    string uin,
    int onlineStatus
)
Visual Basic (Declaration)
Function UpdateUserOnlineStatus ( _
    uin As String, _
    onlineStatus As Integer _
) As DBReturn
Visual C++
DBReturn^ UpdateUserOnlineStatus(
    String^ uin,
    int onlineStatus
)

参数

uin
类型：System..::.String
onlineStatus
类型：System..::.Int32

参见

IDBUserDetailManager 接口
WpimSystem.Interface 命名空间


IDBUserFileManager Interface

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
[用户文件]管理类接口

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public interface IDBUserFileManager
Visual Basic (Declaration)
Public Interface IDBUserFileManager
Visual C++
public interface class IDBUserFileManager

参见

IDBUserFileManager 成员
WpimSystem.Interface 命名空间


IDBUserFileManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBUserFileManager 接口 方法 参见

IDBUserFileManager 类型暴露了以下成员.

方法

名称 | 说明
Create | 创建[用户文件]
Delete | 重载。
Read | 读取[用户文件]
ReadList | 读取列表[用户文件]
ReadPageData | 读取分页数据[用户文件]
Update | 更新[用户文件]

参见

IDBUserFileManager 接口
WpimSystem.Interface 命名空间


IDBUserFileManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBUserFileManager 接口 参见

IDBUserFileManager 类型暴露了以下方法.

方法

名称 | 说明
Create | 创建[用户文件]
Delete | 重载。
Read | 读取[用户文件]
ReadList | 读取列表[用户文件]
ReadPageData | 读取分页数据[用户文件]
Update | 更新[用户文件]

参见

IDBUserFileManager 接口
WpimSystem.Interface 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserFileManager 接口 参见
创建[用户文件]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Create(
    UserFile userFile
)
Visual Basic (Declaration)
Function Create ( _
    userFile As UserFile _
) As DBReturn
Visual C++
DBReturn^ Create(
    UserFile^ userFile
)

参数

userFile
类型：WpimSystem.Domain..::.UserFile
用户文件

返回值

DBReturn

参见

IDBUserFileManager 接口
WpimSystem.Interface 命名空间


Delete Method

[image] [image]

伟鹏即时通讯Web Service说明文档
IDBUserFileManager 接口 参见

重载列表

名称 | 说明
Delete(IList) | 删除[用户文件]
Delete(Int32) | 删除[用户文件]

参见

IDBUserFileManager 接口
IDBUserFileManager 成员
WpimSystem.Interface 命名空间


Delete Method (IList)

[image]

伟鹏即时通讯Web Service说明文档
IDBUserFileManager 接口 参见
删除[用户文件]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    IList idList
)
Visual Basic (Declaration)
Function Delete ( _
    idList As IList _
) As DBReturn
Visual C++
DBReturn^ Delete(
    IList^ idList
)

参数

idList
类型：System.Collections..::.IList
自动编号列表

返回值

UserFile

参见

IDBUserFileManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Delete Method (Int32)

[image]

伟鹏即时通讯Web Service说明文档
IDBUserFileManager 接口 参见
删除[用户文件]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Delete(
    int id
)
Visual Basic (Declaration)
Function Delete ( _
    id As Integer _
) As DBReturn
Visual C++
DBReturn^ Delete(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

UserFile

参见

IDBUserFileManager 接口
Delete 重载
WpimSystem.Interface 命名空间


Read Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserFileManager 接口 参见
读取[用户文件]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
UserFile Read(
    int id
)
Visual Basic (Declaration)
Function Read ( _
    id As Integer _
) As UserFile
Visual C++
UserFile^ Read(
    int id
)

参数

id
类型：System..::.Int32
自动编号

返回值

UserFile

参见

IDBUserFileManager 接口
WpimSystem.Interface 命名空间


ReadList Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserFileManager 接口 参见
读取列表[用户文件]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
IList ReadList(
    UserFileFilter filter,
    string orderStr
)
Visual Basic (Declaration)
Function ReadList ( _
    filter As UserFileFilter, _
    orderStr As String _
) As IList
Visual C++
IList^ ReadList(
    UserFileFilter^ filter,
    String^ orderStr
)

参数

filter
类型：WpimSystem.Filter..::.UserFileFilter
过滤器
orderStr
类型：System..::.String

返回值

IList列表

参见

IDBUserFileManager 接口
WpimSystem.Interface 命名空间


ReadPageData Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserFileManager 接口 参见
读取分页数据[用户文件]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
PageData ReadPageData(
    UserFileFilter filter,
    string orderStr,
    int pageSize,
    int currentPageIndex
)
Visual Basic (Declaration)
Function ReadPageData ( _
    filter As UserFileFilter, _
    orderStr As String, _
    pageSize As Integer, _
    currentPageIndex As Integer _
) As PageData
Visual C++
PageData^ ReadPageData(
    UserFileFilter^ filter,
    String^ orderStr,
    int pageSize,
    int currentPageIndex
)

参数

filter
类型：WpimSystem.Filter..::.UserFileFilter
过滤器
orderStr
类型：System..::.String
排序Sql语句
pageSize
类型：System..::.Int32
页面尺寸
currentPageIndex
类型：System..::.Int32
当前页面

返回值

PageData列表

参见

IDBUserFileManager 接口
WpimSystem.Interface 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
IDBUserFileManager 接口 参见
更新[用户文件]

命名空间： WpimSystem.Interface
程序集： WpimSystem (in WpimSystem.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
DBReturn Update(
    UserFile userFile
)
Visual Basic (Declaration)
Function Update ( _
    userFile As UserFile _
) As DBReturn
Visual C++
DBReturn^ Update(
    UserFile^ userFile
)

参数

userFile
类型：WpimSystem.Domain..::.UserFile
用户文件

返回值

DBReturn

参见

IDBUserFileManager 接口
WpimSystem.Interface 命名空间


WpimWebService Namespace

[image]

伟鹏即时通讯Web Service说明文档
伟鹏即时通讯Web Service

类

类 | 说明
MemberAction | 提供会员创建，修改，查询等相关功能,该类实现的方法均以POST数据方式通过ProcessRequest执行。其中的方法为Public目的为了注释书写，建议不要直接调用。 数据提交采用JSON格式提交到接口站点/MemberAction.ashx页面。
MemberManager | 伟鹏即时通讯Web Service会员管理类,实现会员是否存在检查，会员新增，修改资料，修改密码，等会员资料的相关操作。大部分方法和函数需要提供安全验证标记，并验证成功才能返回正确结果。
TempUser | 简单测试对象
WebServiceTest | WebServiceTest 伟鹏即时通Web Service 测试类


MemberAction Class

[image]

伟鹏即时通讯Web Service说明文档
成员 示例 参见
提供会员创建，修改，查询等相关功能,该类实现的方法均以POST数据方式通过ProcessRequest执行。其中的方法为Public目的为了注释书写，建议不要直接调用。
数据提交采用JSON格式提交到接口站点/MemberAction.ashx页面。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class MemberAction : IHttpHandler
Visual Basic (Declaration)
Public Class MemberAction _
    Implements IHttpHandler
Visual C++
public ref class MemberAction : IHttpHandler

示例

提交数据格式如：
{"Token":"111","Action":"UsernameIsExist","Username":"test111"}
      "Token":为安全码，如需修改请在接口站点配置文件更改。
      "Action":设定执行功能
      其他参数根据具体函数方法而设定

继承层次结构

System..::.Object
WpimWebService..::.MemberAction

参见

MemberAction 成员
WpimWebService 命名空间


MemberAction Members

[image] [image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 构造函数 方法 属性 参见

MemberAction 类型暴露了以下成员.

构造函数

名称 | 说明
MemberAction | Initializes a new instance of the MemberAction class

方法

名称 | 说明
ChangePassword | 修改用户密码,修改时需要提供旧密码。
Create | 创建（注册）一个新用户
OnlineStatus | 查询会员在线状态
ProcessRequest |
ReadByEmail | 根据邮件地址读取用户信息
ReadByIId | 根据集成用户Id读取用户信息
ReadByUin | 根据即时通号读取用户信息
ReadByUsername | 根据用户名读取用户信息
Update | 修改指定用户的个人信息
UsernameIsExist | 检查会员帐号是否存在。

属性

名称 | 说明
IsReusable |

参见

MemberAction 类
WpimWebService 命名空间


MemberAction Constructor

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见
Initializes a new instance of the MemberAction class

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public MemberAction()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberAction()

参见

MemberAction 类
WpimWebService 命名空间


MemberAction Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见

MemberAction 类型暴露了以下方法.

方法

名称 | 说明
ChangePassword | 修改用户密码,修改时需要提供旧密码。
Create | 创建（注册）一个新用户
OnlineStatus | 查询会员在线状态
ProcessRequest |
ReadByEmail | 根据邮件地址读取用户信息
ReadByIId | 根据集成用户Id读取用户信息
ReadByUin | 根据即时通号读取用户信息
ReadByUsername | 根据用户名读取用户信息
Update | 修改指定用户的个人信息
UsernameIsExist | 检查会员帐号是否存在。

参见

MemberAction 类
WpimWebService 命名空间


ChangePassword Method

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见
修改用户密码,修改时需要提供旧密码。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public void ChangePassword(
    string username,
    string oldPassword,
    string newPassword,
    JavaScriptObject result
)
Visual Basic (Declaration)
Public Sub ChangePassword ( _
    username As String, _
    oldPassword As String, _
    newPassword As String, _
    result As JavaScriptObject _
)
Visual C++
public:
void ChangePassword(
    String^ username,
    String^ oldPassword,
    String^ newPassword,
    JavaScriptObject^ result
)

参数

username
类型：System..::.String
用户名
oldPassword
类型：System..::.String
旧密码
newPassword
类型：System..::.String
新密码
result
类型：JavaScriptObject

返回值

  Code： 值说明
      1、修改成功；
      0、修改失败（主要原因可能是数据库）；
      -1、反序列化失败；
      -2、权限验证失败；
      -3、用户不存在；
      -4、旧密码验证失败；

Result： 结果
      0：修改成功
      1：修改失败

备注

提交：
  Token：安全码
  Action："ChangePassword"
  Username：用户名
  OldPassword：旧密码
  NewPassword：新密码

参见

MemberAction 类
WpimWebService 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见
创建（注册）一个新用户

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public void Create(
    Object user,
    JavaScriptObject result
)
Visual Basic (Declaration)
Public Sub Create ( _
    user As Object, _
    result As JavaScriptObject _
)
Visual C++
public:
void Create(
    Object^ user,
    JavaScriptObject^ result
)

参数

user
类型：System..::.Object
result
类型：JavaScriptObject

返回值

  Code 值说明:
      1、创建成功；
      0、创建失败（主要原因可能是数据库）；
      -1、反序列化失败；
      -2、权限验证失败；
      -3、用户数据为空；
      -4、用户名已经存在；
      -5、邮件地址已经存在；

  UserBrief 新用户信息
      Id：内部Id请不要使用
      Uin：即时通号码

备注

提交：
  Token：安全码
  Action："Create"
  UserBrief： 查询的邮件地址

参见

MemberAction 类
WpimWebService 命名空间


OnlineStatus Method

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见
查询会员在线状态

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public void OnlineStatus(
    int uin,
    JavaScriptObject result
)
Visual Basic (Declaration)
Public Sub OnlineStatus ( _
    uin As Integer, _
    result As JavaScriptObject _
)
Visual C++
public:
void OnlineStatus(
    int uin,
    JavaScriptObject^ result
)

参数

uin
类型：System..::.Int32
会员即时通号
result
类型：JavaScriptObject

返回值

  Code： 值说明
      1、查询成功；
      0、查询失败（用户不存在或是数据库查询错误）；
      -1、反序列化失败；
      -2、权限验证失败；

Result： 在线状态
      0、Offline - 离线
      1、Online - 在线
      2、Invisible - 隐身
      3、Busy - 忙碌
      4、Away - 离开

备注

提交：
  Token：安全码
  Action："OnlineStatus"
        Uin：即时通号

参见

MemberAction 类
WpimWebService 命名空间


ProcessRequest Method

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public void ProcessRequest(
    HttpContext context
)
Visual Basic (Declaration)
Public Sub ProcessRequest ( _
    context As HttpContext _
)
Visual C++
public:
virtual void ProcessRequest(
    HttpContext^ context
) sealed

参数

context
类型：System.Web..::.HttpContext

实现

IHttpHandler..::.ProcessRequest(HttpContext)

参见

MemberAction 类
WpimWebService 命名空间


ReadByEmail Method

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见
根据邮件地址读取用户信息

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserBrief ReadByEmail(
    string email,
    JavaScriptObject result
)
Visual Basic (Declaration)
Public Function ReadByEmail ( _
    email As String, _
    result As JavaScriptObject _
) As UserBrief
Visual C++
public:
UserBrief^ ReadByEmail(
    String^ email,
    JavaScriptObject^ result
)

参数

email
类型：System..::.String
result
类型：JavaScriptObject

返回值

  Code： 值说明
      1、读取成功；
      0、用户不存在；
      -1、反序列化失败；
      -2、权限验证失败；

UserBrief： 用户信息
      Id：内部Id请不要使用
      Uin：即时通号码

备注

提交：
  Token：安全码
  Action："ReadByEmail"
  Email： 查询的邮件地址

参见

MemberAction 类
WpimWebService 命名空间


ReadByIId Method

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见
根据集成用户Id读取用户信息

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserBrief ReadByIId(
    string iid,
    JavaScriptObject result
)
Visual Basic (Declaration)
Public Function ReadByIId ( _
    iid As String, _
    result As JavaScriptObject _
) As UserBrief
Visual C++
public:
UserBrief^ ReadByIId(
    String^ iid,
    JavaScriptObject^ result
)

参数

iid
类型：System..::.String
result
类型：JavaScriptObject

返回值

  Code： 值说明
      1、读取成功；
      0、用户不存在；
      -1、反序列化失败；
      -2、权限验证失败；
  UserBrief： 用户信息
      Id：内部Id请不要使用
      Uin：即时通号码

备注

提交：
  Token：安全码
  Action："ReadByIId"
IId： 集成用户Id

参见

MemberAction 类
WpimWebService 命名空间


ReadByUin Method

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见
根据即时通号读取用户信息

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserBrief ReadByUin(
    string uin,
    JavaScriptObject result
)
Visual Basic (Declaration)
Public Function ReadByUin ( _
    uin As String, _
    result As JavaScriptObject _
) As UserBrief
Visual C++
public:
UserBrief^ ReadByUin(
    String^ uin,
    JavaScriptObject^ result
)

参数

uin
类型：System..::.String
result
类型：JavaScriptObject

返回值

  Code： 值说明
      1、读取成功；
      0、用户不存在；
      -1、反序列化失败；
      -2、权限验证失败；

UserBrief： 用户信息
      Id：内部Id请不要使用
      Uin：即时通号码

备注

提交：
  Token：安全码
  Action："ReadByUin"
  Uin： 即时通号

参见

MemberAction 类
WpimWebService 命名空间


ReadByUsername Method

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见
根据用户名读取用户信息

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserBrief ReadByUsername(
    string username,
    JavaScriptObject result
)
Visual Basic (Declaration)
Public Function ReadByUsername ( _
    username As String, _
    result As JavaScriptObject _
) As UserBrief
Visual C++
public:
UserBrief^ ReadByUsername(
    String^ username,
    JavaScriptObject^ result
)

参数

username
类型：System..::.String
result
类型：JavaScriptObject

返回值

  Code： 值说明
      1、读取成功；
      0、用户不存在；
      -1、反序列化失败；
      -2、权限验证失败；
  UserBrief： 用户信息
      Id：内部Id请不要使用
      Uin：即时通号码

备注

提交：
  Token：安全码
  Action："ReadByUsername"
Username： 用户名

参见

MemberAction 类
WpimWebService 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见
修改指定用户的个人信息

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public void Update(
    JavaScriptObject data,
    JavaScriptObject result
)
Visual Basic (Declaration)
Public Sub Update ( _
    data As JavaScriptObject, _
    result As JavaScriptObject _
)
Visual C++
public:
void Update(
    JavaScriptObject^ data,
    JavaScriptObject^ result
)

参数

data
类型：JavaScriptObject
result
类型：JavaScriptObject

返回值

  Code： 值说明
      1、修改成功；
      0、修改失败（主要原因可能是数据库）；
      -1、反序列化失败；
      -2、权限验证失败；
      -3、用户数据为空；
      -4、用户不存在；
      -5、用户名已经存在；
      -6、邮件地址已经存在。

  UserBrief： 修改后的用户信息
      Id：内部Id请不要使用
      Uin：即时通号码

备注

提交：
  Token：安全码
  Action："Update"
  UserBrief： 用户信息
  UpdateMode：修改模式（可省略）
      0、默认值，只修改提交的字段，未提交的字段保留原来的值；
      1、修改所有字段，未提交的字段设为系统默认值或空值。

参见

MemberAction 类
WpimWebService 命名空间


UsernameIsExist Method

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见
检查会员帐号是否存在。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public void UsernameIsExist(
    string username,
    JavaScriptObject result
)
Visual Basic (Declaration)
Public Sub UsernameIsExist ( _
    username As String, _
    result As JavaScriptObject _
)
Visual C++
public:
void UsernameIsExist(
    String^ username,
    JavaScriptObject^ result
)

参数

username
类型：System..::.String
会员帐号
result
类型：JavaScriptObject

返回值

  Code： 值说明
      1、查询成功；
      0、查询失败（用户不存在或是数据库查询错误）；
      -1、反序列化失败；
      -2、权限验证失败；

Result： 结果
      0：不存在
      1：存在

备注

提交：
  Token：安全码
  Action："UsernameIsExist"
        Username：用户名

参见

MemberAction 类
WpimWebService 命名空间


MemberAction Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见

MemberAction 类型暴露了以下属性.

属性

名称 | 说明
IsReusable |

参见

MemberAction 类
WpimWebService 命名空间


IsReusable Property

[image]

伟鹏即时通讯Web Service说明文档
MemberAction 类 参见

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public bool IsReusable { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReusable As Boolean
Visual C++
public:
virtual property bool IsReusable {
    bool get () sealed;
}

实现

IHttpHandler..::.IsReusable

参见

MemberAction 类
WpimWebService 命名空间


MemberManager Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
伟鹏即时通讯Web Service会员管理类,实现会员是否存在检查，会员新增，修改资料，修改密码，等会员资料的相关操作。大部分方法和函数需要提供安全验证标记，并验证成功才能返回正确结果。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class MemberManager : WebService
Visual Basic (Declaration)
Public Class MemberManager _
    Inherits WebService
Visual C++
public ref class MemberManager : public WebService

继承层次结构

System..::.Object
System.ComponentModel..::.MarshalByValueComponent
System.Web.Services..::.WebService
WpimWebService..::.MemberManager

参见

MemberManager 成员
WpimWebService 命名空间


MemberManager Members

[image] [image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 构造函数 方法 参见

MemberManager 类型暴露了以下成员.

构造函数

名称 | 说明
MemberManager | Initializes a new instance of the MemberManager class

方法

名称 | 说明
ChangePassword | 修改用户密码,修改时需要提供旧密码。
Create | 新增加会员。
CreateByJson | 创建会员(Json格式)
EmailIsExist | 检查Email是否存在。
OnlineStatus | 查询会员在线状态
ReadByEmail | 根据会员Email读取会员简要信息。
ReadByUsername | 根据会员用户名读取会员简要信息。
Update | 修改会员简要信息。
UsernameIsExist | 检查会员帐号是否存在。

参见

MemberManager 类
WpimWebService 命名空间


MemberManager Constructor

[image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见
Initializes a new instance of the MemberManager class

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public MemberManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MemberManager()

参见

MemberManager 类
WpimWebService 命名空间


MemberManager Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见

MemberManager 类型暴露了以下方法.

方法

名称 | 说明
ChangePassword | 修改用户密码,修改时需要提供旧密码。
Create | 新增加会员。
CreateByJson | 创建会员(Json格式)
EmailIsExist | 检查Email是否存在。
OnlineStatus | 查询会员在线状态
ReadByEmail | 根据会员Email读取会员简要信息。
ReadByUsername | 根据会员用户名读取会员简要信息。
Update | 修改会员简要信息。
UsernameIsExist | 检查会员帐号是否存在。

参见

MemberManager 类
WpimWebService 命名空间


ChangePassword Method

[image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见
修改用户密码,修改时需要提供旧密码。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int ChangePassword(
    string token,
    string username,
    string oldPassword,
    string newPassword
)
Visual Basic (Declaration)
Public Function ChangePassword ( _
    token As String, _
    username As String, _
    oldPassword As String, _
    newPassword As String _
) As Integer
Visual C++
public:
int ChangePassword(
    String^ token,
    String^ username,
    String^ oldPassword,
    String^ newPassword
)

参数

token
类型：System..::.String
安全验证标记
username
类型：System..::.String
用户名
oldPassword
类型：System..::.String
旧密码
newPassword
类型：System..::.String
新密码

返回值

是否修改成功。返回值:1、修改成功,0、数据库处理错误,-1、安全验证错误,-2、用户不存在,-3、旧密码错误。

参见

MemberManager 类
WpimWebService 命名空间


Create Method

[image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见
新增加会员。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int Create(
    string token,
    ref UserBrief userBrief
)
Visual Basic (Declaration)
Public Function Create ( _
    token As String, _
    ByRef userBrief As UserBrief _
) As Integer
Visual C++
public:
int Create(
    String^ token,
    UserBrief^% userBrief
)

参数

token
类型：System..::.String
安全验证标记
userBrief
类型： WpimSystem.Domain..::.UserBrief %
会员简要信息

返回值

是否增加成功。返回值:1、新增加成功,0、数据处理错误,-1、安全验证错误,-2、用户名已经存在,-3、邮件地址已经存在

备注

新增加会员会员时如果用户名和电子邮件已经存在则不能成功的加入

参见

MemberManager 类
WpimWebService 命名空间


CreateByJson Method

[image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见
创建会员(Json格式)

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string CreateByJson(
    string token,
    string userBriefJson
)
Visual Basic (Declaration)
Public Function CreateByJson ( _
    token As String, _
    userBriefJson As String _
) As String
Visual C++
public:
String^ CreateByJson(
    String^ token,
    String^ userBriefJson
)

参数

token
类型：System..::.String
安全验证标记
userBriefJson
类型：System..::.String

返回值

参见

MemberManager 类
WpimWebService 命名空间


EmailIsExist Method

[image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见
检查Email是否存在。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int EmailIsExist(
    string token,
    string username
)
Visual Basic (Declaration)
Public Function EmailIsExist ( _
    token As String, _
    username As String _
) As Integer
Visual C++
public:
int EmailIsExist(
    String^ token,
    String^ username
)

参数

token
类型：System..::.String
安全验证标记
username
类型：System..::.String
Email

返回值

是否存在。返回值:1、Email存在,0、Email不存在,-1、安全验证错误

参见

MemberManager 类
WpimWebService 命名空间


OnlineStatus Method

[image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见
查询会员在线状态

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int OnlineStatus(
    string token,
    string username
)
Visual Basic (Declaration)
Public Function OnlineStatus ( _
    token As String, _
    username As String _
) As Integer
Visual C++
public:
int OnlineStatus(
    String^ token,
    String^ username
)

参数

token
类型：System..::.String
安全验证标记
username
类型：System..::.String
会员帐号

返回值

在线状态:0、Offline - 离线,1、Online - 在线,2、Invisible - 隐身,3、Busy - 忙碌,4、Away - 离开

参见

MemberManager 类
WpimWebService 命名空间


ReadByEmail Method

[image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见
根据会员Email读取会员简要信息。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserBrief ReadByEmail(
    string token,
    string email
)
Visual Basic (Declaration)
Public Function ReadByEmail ( _
    token As String, _
    email As String _
) As UserBrief
Visual C++
public:
UserBrief^ ReadByEmail(
    String^ token,
    String^ email
)

参数

token
类型：System..::.String
安全验证标记
email
类型：System..::.String
用户名

返回值

会员简要信息

参见

MemberManager 类
WpimWebService 命名空间


ReadByUsername Method

[image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见
根据会员用户名读取会员简要信息。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public UserBrief ReadByUsername(
    string token,
    string username
)
Visual Basic (Declaration)
Public Function ReadByUsername ( _
    token As String, _
    username As String _
) As UserBrief
Visual C++
public:
UserBrief^ ReadByUsername(
    String^ token,
    String^ username
)

参数

token
类型：System..::.String
安全验证标记
username
类型：System..::.String
用户名

返回值

会员简要信息

参见

MemberManager 类
WpimWebService 命名空间


Update Method

[image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见
修改会员简要信息。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int Update(
    string token,
    UserBrief userBrief
)
Visual Basic (Declaration)
Public Function Update ( _
    token As String, _
    userBrief As UserBrief _
) As Integer
Visual C++
public:
int Update(
    String^ token,
    UserBrief^ userBrief
)

参数

token
类型：System..::.String
安全验证标记
userBrief
类型：WpimSystem.Domain..::.UserBrief
会员简要信息

返回值

是否修改成功。返回值:1、修改成功,0、数据库处理错误,-1、安全验证错误,-2、用户不存在。

备注

修改会员资料时为保证用户名和电子邮件的唯一性，该函数不能修改会员的用户名和电子邮件

参见

MemberManager 类
WpimWebService 命名空间


UsernameIsExist Method

[image]

伟鹏即时通讯Web Service说明文档
MemberManager 类 参见
检查会员帐号是否存在。

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int UsernameIsExist(
    string token,
    string username
)
Visual Basic (Declaration)
Public Function UsernameIsExist ( _
    token As String, _
    username As String _
) As Integer
Visual C++
public:
int UsernameIsExist(
    String^ token,
    String^ username
)

参数

token
类型：System..::.String
安全验证标记
username
类型：System..::.String
会员帐号

返回值

是否存在。返回值:1、用户名存在,0、用户名不存在,-1、安全验证错误

参见

MemberManager 类
WpimWebService 命名空间


TempUser Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
简单测试对象

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
[SerializableAttribute]
public class TempUser
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class TempUser
Visual C++
[SerializableAttribute]
public ref class TempUser

继承层次结构

System..::.Object
WpimWebService..::.TempUser

参见

TempUser 成员
WpimWebService 命名空间


TempUser Members

[image] [image]

伟鹏即时通讯Web Service说明文档
TempUser 类 构造函数 属性 参见

TempUser 类型暴露了以下成员.

构造函数

名称 | 说明
TempUser | Initializes a new instance of the TempUser class

属性

名称 | 说明
Id |
Name |

参见

TempUser 类
WpimWebService 命名空间


TempUser Constructor

[image]

伟鹏即时通讯Web Service说明文档
TempUser 类 参见
Initializes a new instance of the TempUser class

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public TempUser()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TempUser()

参见

TempUser 类
WpimWebService 命名空间


TempUser Properties

[image] [image]

伟鹏即时通讯Web Service说明文档
TempUser 类 参见

TempUser 类型暴露了以下属性.

属性

名称 | 说明
Id |
Name |

参见

TempUser 类
WpimWebService 命名空间


Id Property

[image]

伟鹏即时通讯Web Service说明文档
TempUser 类 参见

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public int Id { get; set; }
Visual Basic (Declaration)
Public Property Id As Integer
Visual C++
public:
property int Id {
    int get ();
    void set (int value);
}

参见

TempUser 类
WpimWebService 命名空间


Name Property

[image]

伟鹏即时通讯Web Service说明文档
TempUser 类 参见

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

参见

TempUser 类
WpimWebService 命名空间


WebServiceTest Class

[image]

伟鹏即时通讯Web Service说明文档
成员 参见
WebServiceTest 伟鹏即时通Web Service 测试类

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public class WebServiceTest : WebService
Visual Basic (Declaration)
Public Class WebServiceTest _
    Inherits WebService
Visual C++
public ref class WebServiceTest : public WebService

继承层次结构

System..::.Object
System.ComponentModel..::.MarshalByValueComponent
System.Web.Services..::.WebService
WpimWebService..::.WebServiceTest

参见

WebServiceTest 成员
WpimWebService 命名空间


WebServiceTest Members

[image] [image]

伟鹏即时通讯Web Service说明文档
WebServiceTest 类 构造函数 方法 参见

WebServiceTest 类型暴露了以下成员.

构造函数

名称 | 说明
WebServiceTest | Initializes a new instance of the WebServiceTest class

方法

名称 | 说明
GetObject | 测试返回对象
HelloWorld | HelloWorld方法测试
SendObject | 测试发送对象
SendRefObject | 测试发送对象(引用方式)

参见

WebServiceTest 类
WpimWebService 命名空间


WebServiceTest Constructor

[image]

伟鹏即时通讯Web Service说明文档
WebServiceTest 类 参见
Initializes a new instance of the WebServiceTest class

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public WebServiceTest()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebServiceTest()

参见

WebServiceTest 类
WpimWebService 命名空间


WebServiceTest Methods

[image] [image]

伟鹏即时通讯Web Service说明文档
WebServiceTest 类 参见

WebServiceTest 类型暴露了以下方法.

方法

名称 | 说明
GetObject | 测试返回对象
HelloWorld | HelloWorld方法测试
SendObject | 测试发送对象
SendRefObject | 测试发送对象(引用方式)

参见

WebServiceTest 类
WpimWebService 命名空间


GetObject Method

[image]

伟鹏即时通讯Web Service说明文档
WebServiceTest 类 参见
测试返回对象

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public TempUser GetObject()
Visual Basic (Declaration)
Public Function GetObject As TempUser
Visual C++
public:
TempUser^ GetObject()

返回值

参见

WebServiceTest 类
WpimWebService 命名空间


HelloWorld Method

[image]

伟鹏即时通讯Web Service说明文档
WebServiceTest 类 参见
HelloWorld方法测试

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string HelloWorld()
Visual Basic (Declaration)
Public Function HelloWorld As String
Visual C++
public:
String^ HelloWorld()

返回值

参见

WebServiceTest 类
WpimWebService 命名空间


SendObject Method

[image]

伟鹏即时通讯Web Service说明文档
WebServiceTest 类 参见
测试发送对象

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string SendObject(
    TempUser user
)
Visual Basic (Declaration)
Public Function SendObject ( _
    user As TempUser _
) As String
Visual C++
public:
String^ SendObject(
    TempUser^ user
)

参数

user
类型：WpimWebService..::.TempUser

返回值

参见

WebServiceTest 类
WpimWebService 命名空间


SendRefObject Method

[image]

伟鹏即时通讯Web Service说明文档
WebServiceTest 类 参见
测试发送对象(引用方式)

命名空间： WpimWebService
程序集： WpimWebService (in WpimWebService.dll) 版本: 1.0.0.0 (1.0.0.0)

语法

C#
public string SendRefObject(
    ref TempUser user
)
Visual Basic (Declaration)
Public Function SendRefObject ( _
    ByRef user As TempUser _
) As String
Visual C++
public:
String^ SendRefObject(
    TempUser^% user
)

参数

user
类型： WpimWebService..::.TempUser %

返回值

参见

WebServiceTest 类
WpimWebService 命名空间